Spamassassin startet nicht automatisch bei Neustart

Hallo

Habe ein komisches Problem mit Spamassassin unter Debian 8 Jessie.. Wenn ich den Server neu starte startet Spamassassin nicht automatisch. Habe schon verschiedenes probiert:

/etc/default/spamassassin:
ENABLED=1

geschaut das Spamassassin als letztes startet:
runlevel;la /etc/rc5.d
Code:
N 5
insgesamt 12
[...]
lrwxrwxrwx  1 root root   17 Mär 11  2014 S19dovecot -> ../init.d/dovecot
lrwxrwxrwx  1 root root   17 Mär 11  2014 S20postfix -> ../init.d/postfix
lrwxrwxrwx  1 root root   18 Mär 11  2014 S21rc.local -> ../init.d/rc.local
lrwxrwxrwx  1 root root   19 Mär 11  2014 S21rmnologin -> ../init.d/rmnologin
lrwxrwxrwx  1 root root   22 Mär 12  2014 S22spamassassin -> ../init.d/spamassassin

vi /etc/init.d/spamassassin:
Hab ich da auch mal ENABLED obwohl da steht don't touch...
Code:
# Defaults - don't touch, edit /etc/default/spamassassin
#ENABLED=0
ENABLED=1

Beim Neustarten des Servers habe ich rein gar nix von spamd in /var/log/syslog.

Wenn ich nach dem Neustart mit /etc/init.d/spamassassin start oder service spamassassins start den Spamassassin starte, gehts ohne Probleme. An was kann das liegen?

Danke für die Inputs
 

danton

Debian User
Der Wert in der /etc/default/spamassassin wirkt nur, wenn du noch sysvinit verwendest. Standard bei Jessie ist aber systemd - da mußt du Spamassassin einmalig aktivieren.
 
Danke für dein Hinweis! Habe gedacht das mit /etc/rc3.d/... resp. /etc/rc5.d/... geht nach wie vor.

Folgendermassen hats nun geklappt:
systemctl enable spamassassin
 
Top