• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

spamassassin löscht eingehende Mails nicht automatisch

zeichensatz

New Member
Auf einem Strato-Rootserver mit opensuse 11.0 und Plesk Panel 9.0.1 (mit postfix als MTA) habe ich in Plesk unter "Spamfilter für E-Mail-Account konfigurieren" die Option "Spam-E-Mails beim Eingehen in die Mailbox löschen" auf aktiv gesetzt. Eingehende SPAMs werden erkannt und eine entsprechende Markierung gesetzt (****SPAM****), die so erkannten Mails werden aber nicht automatisch aus der Mailbox gelöscht.

Mit dem für die Einstellungen des spamassassin zuständigen Skript (siehe /usr/local/psa/bin/spamassassin --help) habe ich die Einstellungen verifiziert und auch schon mal neu gesetzt, eine Veränderung konnte ich damit aber nicht erreichen.

Auf einem anderen Strato-Rootserver mit opensuse 11.1 und Plesk Panel 9.5.1 (ebenfalls mit postfix als MTA) scheint das Löschen der SPAMs zu funktionieren.

Hat jemand eine Idee, woran das Löschen auf dem System mit Plesk 9.0.1 scheitert und noch besser, wie man das Problem lösen kann?
 
Zeig uns die .qmail der entsprechenden Mailbox.

PS: SA selbst löscht nichts. Dafür sind andere Programme zuständig.

huschi.
 
In allen Mailboxen steht in der .qmail:
Code:
| true
| /usr/bin/deliverquota ./Maildir
Daran liegt es m.E. nicht. Hat diese Einstellung überhaupt eine Bedeutung, wenn man postfix verwendet?

Das geschilderte Problem habe ich schon seit längerem. Aber anscheinend muss irgendwas, was ich in den letzten Tagen ausprobiert habe, nun doch den richtigen Prozess ausgelöst zu haben, denn momentan scheinen erkannte SPAMs alle gleich aus den Mailboxen gelöscht zu werden.
Allerdings habe ich nichts gemacht, ausser mal die Optionen ein- oder auszuschalten.

Klar, dass spamassassin nichts selber löscht, aber welche Programme sind denn dafür zuständig?
Ich würde schon ganz gerne verstehen, warum das nun plötzlich funktioniert.

PS: Irgendwie spinnt der spamassassin doch noch, zumindest bei einem Postfach. Da werden jetzt plötzlich Mails von einem Freund als SPAM markiert, was vorher noch nie der Fall war (und bei ihm wurde nichts geändert). Merkwürdigerweise wird die Markierung *****SPAM***** gesetzt, die in der Plesk-Konfiguration in den Server-übergreifenden Einstellungen (Start -> Server -> Spamfilter-Einstellungen) gesetzt ist. Bei den Einstellungen der jeweiligen Mail-Accounts habe ich immer ****SPAM**** gesetzt. Glücklicherweise werden die mit *****SPAM***** markierten Mails nicht gelöscht.
Kann mir jemand diese Merkwürdigkeiten erklären?
 
Last edited by a moderator:
Ich bin gerade über den Befehl
Code:
/usr/local/psa/admin/sbin/mchk --spam-only
gestolpert.
In der Hilfe zu dem Befehl steht nur "restore only SpamAssassin settings" und zwar von der Plesk-Datenbank.
Das hört sich erst mal nicht schlecht an im Hinblick auf meine SPAM-Problematik, oder?
Hat jemand diesen Befehl schon mal ausprobiert?
 
Das Problem beruhte mehr oder weniger auf einer falschen Konfiguration einiger Mail-Accounts. In diesen wurden Grossbuchstaben verwendet, was zu Problemen führt, da für den spamassassin in den Konfigurationsdateien alle Pfadnamen in Kleinbuchstaben umgewandelt werden und so der Zugriff auf die spamassasin-Konfigurationsdateien in den Mailbox-Verzeichnissen unter
Code:
/var/qmail/mailnames/domain.tld/mailboxuser/.spamassassin/
nicht klappt.

Das zwischenzeitlich etwas merkwürdige Verhalten des spamassassin (markiert normale Mails als SPAM, Markierung mit *****SPAM***** anstelle von ****SPAM****) konnte ich durch einen Neustart beheben.

Bei mchk handelt es sich wohl wirklich um recht effektives Tool, mit dem man so manche Probleme bei der Mail-Konfiguration behandeln kann.
 
Back
Top