spamassassin auf vServer

Wirus

Registered User
Hi,

ich habe letzte Woche mit schrecken gesehen, dass an einem Tag innerhalb von 3 Stunden 15GB an traffic entstanden sind. Da ich davon ausgehe, dass irgend eine Sicherheitslücke ausgenutzt wurde (meine Seiten sind nicht SO gut besucht und Downloads gibt es auch nix) habe ich eine Neuinstallation auf RedHat 9 beauftragt. Nun habe ich aber ein Problem:

auf dem "alten" Server lief Spamassassin ohne Probleme. Bei RedHat 9 beisse ich mir aber die Zähne aus. Es scheint kein Sendmail mehr zu laufen? (ps -ef|grep sendmail gibt nur grep sendmail aus). Wie bekomme ich sendmail zum laufen? Oder ist auf meinem Server irgendetwas im Argen?

Ein anderes Problem:

nach einiger Zeit scheint mir Apache die HTML und PHP Seiten nur noch zum Download anbieten zu wollen. Ich muss mich dann auf dem Server einloggen und httpd neu starten. Woran kann das liegen?

ich hoffe ihr könnt mir helfen ;)
 
Last edited by a moderator:

Thorsten

SSF Facilitymanagement
Staff member
Hallo!
Zuerst solltest du feststellen welcher SMTP Server auf deinem System läuft. Ein telnet deine.v-server.ip 25 hilft da ;) . Speziell zum Thema SpamAssassin gabs hier schon einige Threads. Einfach mal die Suchfunktion nutzen.

Für dein zweites Problem schau mal unter [thread]442[/thread] .

mfG
Thorsten
 
Last edited by a moderator:

iceX

Registered User
bei mir das gleiche

also, mir scheint, das vserver(s4f) ganz schöne probleme mit ihrer redhat9 compilation hat (bzw. jetzt hab ich die probleme)....

sendmail läuft nicht mehr, installier ich webmin (1.130) und will änderungen im sendmail-bereich vornehmen, bzw. die nicht vorhandene sendmail im /etc/rc.d/init.d starten kann ich bis 10 Zählen, dann geht bis auf eine neuinstall gar nichts mehr...

wie kann ich sendmail neu installieren oder updaten oder sonstwas ???

ja richtig, wenn ich in linux perfekt wäre, würd ich webmin nicht installieren... habs auch schon per hand versucht, aber no chance... so viel zeit hab ich im moment nicht um mich 100% in linux einzuarbeiten.... grundzüge sind aber vorhanden...


greets & thx iceX
 

Thorsten

SSF Facilitymanagement
Staff member
Habe gerade mal meine sendmail Version überprüft. Meldet sich als sendmail-8.12.8-9-90.2.swsoft. Vielleicht kann mal jemand vom Support sagen warum auch sendmail eine getagged'te Version ist.

mfG
Thorsten
 

Hotte

Registered User
Bei RH9 wird sendmail über den xinetd gehändelt. Von daher werden wohl auch die Defaulteinstellungen in Webmin nicht funktionieren.
Das so einiges bei RH9 über den xinetd läuft, ist die Default-Einstellung von RedHat.
Und daß das rpm getaggt ist, liegt nur daran, weil es für die Virtuozzo-Installation angepasst ist.
 

Huschi

Moderator
Staff member
Wirus said:
auf dem "alten" Server lief Spamassassin ohne Probleme. Bei RedHat 9 beisse ich mir aber die Zähne aus.
Spamassassin wird nicht im sendmail sondern im procmail eingebunden (bei der lokalen Mail-Zustellung). Allerdings wird procmail durch sendmail aufgerufen.

Was hast Du denn für ein Problem mit SpamAssassin?

huschi.
 

barmala

Registered User
Hallo,

Huschi said:
Spamassassin wird nicht im sendmail sondern im procmail eingebunden (bei der lokalen Mail-Zustellung).
Es gibt recht unterschiedliche Möglichkeiten der Einbindung:
Aufruf via procmail ist die, die die wenigsten Eingriffe ins System verlangt, insbesondere wenn man Performancenachteil in Kauf nimmt und keinen spamd startet sondern die Commandline spamassasin aufruft. Ein Weiterer Vorteil ist, dass viele Einstellungen pro User gemacht werden können.

Eine Alternative ist die Perl Funktionen von Spamassassin direkt via "Milter" in Sendmail oder via "AMaViS" in Procmail einzubinden. Das hat den Vorteil, dass man bei per SMTP zugestellten Mails die Annahme verweigern kann, wenn sie hinreichend verdächtig Spam sind.

Bis auf Sendmail/Milter habe ich die Varianten schon durchgespielt. Hat jemand mit dieser Variante schon Erfahrungen?

Gruß, Christian
 
Last edited by a moderator:

Thorsten

SSF Facilitymanagement
Staff member
Wobei ich mich in letzter Zeit frage, wie man das ganze sinnvoll mit Confixx kombinieren kann. Zur Zeit werden alle Spammails bei mir gekennzeichnet. Ich habe es aber leider noch nicht geschafft, (Confixx-)benutzerabhängig auch gleich zu löschen.

mfG
Thorsten
 

luke

Registered User
Thorsten said:
Wobei ich mich in letzter Zeit frage, wie man das ganze sinnvoll mit Confixx kombinieren kann. Zur Zeit werden alle Spammails bei mir gekennzeichnet. Ich habe es aber leider noch nicht geschafft, (Confixx-)benutzerabhängig auch gleich zu löschen.
Das habe ich schon geaschafft indem ich (bei einem didizierten Server) die passwd angepasst habe. Darin habe ich den entsprechenden User (z.B. web1p1) andere Homeverzeichnise gegeben (anstelle von /XnirvanaX) und dann dort die Configdateien abgelegt und entsprechend angepasst.

Was ich gerne hätte, was ich aber noch nie gesehen habe, dass bei eMail-Weiterleitungen auch gefiltert wird. Weil es eben nur Weiterleitungen sind, wird es wohl nicht gehen, wäre aber schön.


So far!
#
Luke
 
Last edited by a moderator:

Commander_Keen

Registered User
Spamassassin oder Spamcop RBL

//EDIT//
Hat sich erledigt, habe das fantastische Script von Huschi gefunden ;)
//EDIT//

Hi,

habe heute dieses tolle Forum gefunden und hoffe meine Frage beantwortet zu bekommen. Es wurden hier diverse ANTI-SPAM Möglichkeiten diskutiert nun mein Problem:

seit ich RH9 auf dem vServer habe funktioniert das nicht mehr mit dem SpamCop Eintrag in der M4 Config. Laut SpamCop FAQ scheint das wohl ein Problem seitens Sendmail zu sein - auch die Workarounds scheinen bei mir nicht zu funktionieren. Jemand ne Idee??? Im Maillog sehe ich das keine Mail von Spamcop gecheckt wird.

Spamassassin wäre natürlich ne Alternative jedoch bin ich nicht so fit im Linux-gefummel und will mir nicht schon wieder den Server schrotten, da er ansonsten tadellos läuft.

Gruß
Commander_Keen
 
Last edited by a moderator:
Top