Soforthilfe gesuche

metin88

New Member
Hallo,

ich habe Proxmox von 3.3 auf 4.1 upgedatet, habe aber nun Probleme mit Abhängigkeiten:
Code:
root@c1323s01:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  apparmor cgmanager criu dh-python fence-agents-pve ifenslave ifenslave-2.6 libapparmor-perl libapparmor1 libapt-pkg-perl libcgmanager0 libcrypt-ssleay-perl libdlm3 libev-perl libfile-sync-perl
  libfilesys-df-perl libgnutlsxx28 liblinux-inotify2-perl libmpdec2 libnet-dns-perl libnih-dbus1 libnih1 libperl4-corelibs-perl libprotobuf-c1 libprotobuf9 libpython-stdlib libpython2.7
  libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libpython3.4-minimal libpython3.4-stdlib libseccomp2 libtext-iconv-perl libuuid-perl lxc-pve lxcfs netcat6 pve-container
  pve-ha-manager pve-manager python python-ipaddr python-minimal python-protobuf python2.7 python2.7-minimal python3 python3-minimal python3.4 python3.4-minimal qemu-server uidmap
Suggested packages:
  apparmor-profiles apparmor-profiles-extra apparmor-docs apparmor-utils iwatch python-doc python-tk python2.7-doc binutils binfmt-support python3-doc python3-tk python3-venv python3.4-venv
  python3.4-doc
The following packages will be REMOVED:
  redhat-cluster-pve resource-agents-pve vlan
The following NEW packages will be installed:
  apparmor cgmanager criu dh-python ifenslave libapparmor-perl libapparmor1 libcgmanager0 libdlm3 libev-perl libgnutlsxx28 libmpdec2 libnih-dbus1 libnih1 libperl4-corelibs-perl libprotobuf-c1
  libprotobuf9 libpython-stdlib libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libpython3.4-minimal libpython3.4-stdlib libseccomp2 lxc-pve lxcfs netcat6 pve-container pve-ha-manager
  python-ipaddr python-protobuf python3 python3-minimal python3.4 python3.4-minimal uidmap
The following packages will be upgraded:
  fence-agents-pve ifenslave-2.6 libapt-pkg-perl libcrypt-ssleay-perl libfile-sync-perl libfilesys-df-perl liblinux-inotify2-perl libnet-dns-perl libpython2.7 libtext-iconv-perl libuuid-perl
  pve-manager python python-minimal python2.7 python2.7-minimal qemu-server
17 upgraded, 36 newly installed, 3 to remove and 261 not upgraded.
4 not fully installed or removed.
Need to get 0 B/16.5 MB of archives.
After this operation, 28.2 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Reading changelogs... Done
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 37731 files and directories currently installed.)
Preparing to unpack .../libdlm3_4.0.2-1_amd64.deb ...
Unpacking libdlm3 (4.0.2-1) ...
dpkg: error processing archive /var/cache/apt/archives/libdlm3_4.0.2-1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/man/man8/dlm_tool.8.gz', which is also in package redhat-cluster-pve 3.2.0-2
Processing triggers for man-db (2.7.0.2-5) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libdlm3_4.0.2-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
sind hier die Profis, kann mir jemand adhoc helfen??? Muss auch nicht umsonst sein!!
 
Last edited by a moderator:

.A.

Code:
Unpacking libdlm3 (4.0.2-1) ...
dpkg: error processing archive /var/cache/apt/archives/libdlm3_4.0.2-1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/man/man8/dlm_tool.8.gz', which is also in package redhat-cluster-pve 3.2.0-2

Sowohl libdlm3 als auch redhat-cluster-pve wollen auf die selbe Datei (/usr/share/man/man8/dlm_tool.8.gz) schreiben. Du hast sicher eine zusätzliche Paketquelle hinzugefügt. Jetzt musst Du eben entscheiden, welches Paket den Vorrang haben soll und welches deinstalliert oder überschrieben werden soll.

--
.A.
 
Top