• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

rsync für Backup auf andere Maschine

tim

Registered User
Hallo zusammen,

hat hier jemand Erfahrung mit rsync? Ich möchte gerne Dateien, die ich auf meinem vServer liegen habe, per rsync auf meinen Heimrechner synchronisieren.
Habe auf dem vServer rsync 2.6.0 installiert und als Dämon konfiguriert. Bei mir zu Hause habe ich cygwin + ssh + rsync 2.6.0 installiert. Die Anmeldung klappt, aber dann bricht rsync ab.

$ rsync userxyz@??????.vserver.de:hello/hello .
userxyz@??????.vserver.de's password:
rsync: connection unexpectedly closed (0 bytes read so far)
rsync error: error in rsync protocol data stream (code 12) at /home/lapo/packaging/tmp/rsync-2.6.0/io.c(189)


Ok, dass der Fehler in der io.c erzeugt wird sehe ich selbst. Aber vielleicht habe ich auch nur was falsch konfiguriert. Es kann nicht an cygwin liegen. Der gleiche Fehler tritt auch auf, wenn ich auf dem vServer rsync auf den localhost mache. Ist der Fehler vielleicht beim Compilieren von rsync auf dem vServer entstanden (RH9)?

Meine /etc/rsync.conf sieht so aus:

uid = nobody
gid = nobody
use chroot = true
max connections = 1
syslog facility = local5
pid file = /var/run/rsyncd.pid

[backup]
path = /home/userxyz
list = false
comment = Server Backup (requires authentication)
auth users = backup
secrets file = /etc/rsyncd.secrets
strict modes = true


Gruß
Tim
 
tim said:
hat hier jemand Erfahrung mit rsync?
Erfahrung ja, allzuviel Ahnung nein.
Aber ich versuch es dennoch:
Laut Deinem Log bricht rsync nach (erfolgreicher?) Anmeldung ab. Also genau zu dem Zeitpunkt wo eine Shell aufgerufen wird.
Da rsync auf ssh aufbaut, braucht der User, mit dem Du Dich anmeldest, eine Shell. (Sprich: in /etc/passwd kein /bin/false am Ende.)

huschi.
 
Super, genau daran hat's gelegen. Der User hatte tatsächlich keine Shell.
Dankeschön für den Tip. :)

tim
 
Hallo Huschi,

ich habe das gleiche Problem! rsync version 2.6.2. Das passiert aber nur, wenn ich eine Sicherung über das Netz auf einen anderen Computer schreibe. Den gleichen Sicherungslauf auf eine im Rechner eingebaute Festplatte absolviert rsync ohne Probleme.

Den Befehl an der Shell abgesetzt hat zur Folge, dass rsync hier

[sender] make_file(home/admin/progs/webmin-1.070/sendmail/images/features.gif,*,2)

nach einer sehr langen Liste die mit [sender] beginnt, hängen bleibt.

Bis zum 4. Semptember funktionierte die Sicherung auch über das Netz mit der gleichen Syntax.

Wenn ich das gleiche mit einen cron-job mache kommt folgende Fehlermeldung nach einiger Wartezeit.

rsync: connection unexpectedly closed (8 bytes read so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(342)

Vielleicht hast Du da auch den passenden Tip!?

Schon mal Danke für die Mühe die Du/Ihr Euch macht!

Gruß

Aois
 
Den Befehl an der Shell abgesetzt hat zur Folge
Hier fehlt ein Detail: Wie lautet die genaue Befehlszeile?

Bis zum 4. Semptember funktionierte die Sicherung auch über das Netz mit der gleichen Syntax.
Dann such nach Veränderungen seit dem. Ist einer der Server rebooted worden?
Evtl. wäre auch mal ein fschk angesagt, da es auch ein Platten/Dateifehler sein könnte.

huschi.
 
Hallo Huschi,

das ist der Befehl, wie er am 04.09. noch funktioniert hat!

rsync -e ssh -auvz --delete --exclude "var/squid/cache" --exclude "/mnt" --exclude "/sys" --exclude "/cdrom" --exclude "/lost+found" --exclude "/proc" --exclude "/media" / root@192.168.0.17:/mnt/hdb3/ >>/var/log/rsync_log_systemsicherung

Beide Server sind seitdem rebootet worden. Den Zielserver habe ich auf Verdacht heute morgen noch rebootet.

Mit den Änderungen ist das so eine Sache. Ich habe erst sehr spät gemerkt, dass der Befehl, der per cronjob abgerbeitet wurde, nicht mehr durchlief.

Gruß

Alois
 
Wie gesagt: prüf mal ob überhaupt noch genug Kapazität auf dem Zielserver auf /mnt/hdb3 frei ist, laß mal ein fschk drüber laufen (vorher umount machen) oder schau Dir die Datei /mnt/hdb3/home/admin/progs/webmin-1.070/sendmail/images/features.gif an. Evtl. stimmt auch daran was nicht.

Schon mal das message-Log auf dem Zielsystem geprüft?

huschi.
 
Hallo Huschi,

Platz ist genug auf dem Ziellaufwerk!

Ich habe jetzt mal nur ein Unterverzeichnis in /Home mit rsync gesichert. Das ging problemlos. Kann es sein, dass irgend ein Cache volläuft?


Gruß

Alois
 
Hallo Huschi,

Sorry, ich habe fsck laufen lassen. Alles ok. In die Messages auf dem Zielserver wird nichts geschrieben, was von rsync herrührt!

Ich habe aber nach meinem oben geäusserten Verdacht mit dem gleichen Befehl nur ein Verzeichnis in /Home gesichert. Es hat funktioniert.

Danach das gleiche mit allen Unterverzeichnissen in /Home. Es funktioniert nicht.

Gerade lasse ich den Befehl noch einmal im Original laufen (mit einmal "v" weniger in den Optionen, weil ich den Verdacht habe, dass es daran liegen könnte. Das eine "v" habe ich nämlich vor kurzem hinzugefügt, weil ich gelesen habe, dass man dann von rsync mehr Infos bekommt.

Ich werde Dir schreiben, wie es ausgegangen ist!

Gruß

Alois
 
Hallo Huschi,

ich denke, dass ich den Fehler gefunden habe!

Ich habe folgendes gemacht:

rsync mit allen Optionen laufen lassen!

In einem Fenster lief "top" und zeigte an, was auf dem sendenden Rechner lief, im zweiten zeigte "top" was auf dem Empfänger lief.

Man konnte sehr schön sehen, dass rsync auf beiden Systemen arbeitete.

Was man auch sah der Swap-Speicher des Zielrechners war komplett ausgenutzt (0k free). Der Hauptspeicher lief langsam aber sicher voll, bis der Abbruch kam.

Der Zielrechner hat nur die Hälfte Arbeitsspeicher und eine um den Faktor zehn kleinere Swap-Partition.

Das muss ich ändern und dann sollte rsync funktionieren!

Gruß


Alois

Ergänzung: ich habe jetzt einmal das umfangreichste Verzeichnis /Home ausgenommen und schon läuft der Befehl wie eh und je. Damit ist auch klar, warum das seit 4.09. nicht mehr geklappt hat. An dem Tag habe ich über 1000 Benutzer neu angemeldet!

Ps. wenn Du mal ein Elektrotechnisches Problem hast. Du findest mich auf diesteckdose.net IT und Elektrotechnik Community melde Dich mit huschi an und Du bekommst erste Klasse Service :) versprochen!
 
Last edited by a moderator:
Hallo,

jetzt ist mir doch noch ein Fehler aufgefallen, der nicht von rsync bemerkt wird. Inwieweit er auch zu dem Problem beigetragen hat entzieht sich meiner Kenntnis.

An dieser Stelle fehlt ein "/"

--exclude "var/squid/cache"

Es muss

--exclude "/var/squid/cache"

heissen!

Gruß

Alois
 
Back
Top