Root-Server | Proxmox VM's IP zuweisen!?

Luczz

New Member
Hallo,

und zwar habe ich mir bei "servdiscount" einen dedizierten Server gekauft und Proxmox installiert. Die virtuelle Maschine an sich läuft (Debian 8) nur leider habe ich nicht verstanden wie ich einer meiner 3 IP Adressen dem Server zuweise.

----------------------------------------------------------------------
IPs:

193.111.141.XXX
80.86.170.XXX
5.199.130.XX

-----------------------------------------------------------------------

Hauptsystem:
/etc/network/interfaces

allow-hotplug eth0
iface eth0 inet static
address 193.111.141.XXX
netmask 255.255.255.0
network 193.111.141.0
broadcast 193.111.141.255
gateway 193.111.141.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 62.141.32.5 62.141.32.4 62.141.32.3
dns-search topaz.servdiscount-customer.com

auto vmbr0
iface vmbr0 inet static
address 193.111.141.XXX
broadcast 193.111.141.255
netmask 255.255.255.0
bridge_ports none
bridge_stp off
bridge_fd 0
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 62.141.32.5 62.141.32.4 62.141.32.3
dns-search topaz.servdiscount-customer.com
up ip route add 5.199.130.XX dev vmbr0


--------------------------------------------------------------------------

VM:


allow-hotplug eth0
address 5.199.130.XX
netmask 255.255.255.0
network 5.199.130.0
broadcast 5.199.130.255
gateway 5.199.130.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 62.141.32.5




Ich bitte ihr könnt mir helfen, sitze schon eine Woche an dem Problem :(

MfG Luczz
 
A

andreas0

Guest
Eventuell hilft dir folgende Konfiguration weiter, die auch bei mir sehr gut funktioniert.

In meiner KVM-VM mit Ubuntu 16.04 habe ich die zusätzliche IPv4 wie folgt eingetragen:

Code:
auto eth0
iface eth0 inet static
        address IP-Adresse vom vServer
        netmask 255.255.255.255
        network IP-Adresse vom vServer
        broadcast IP-Adresse vom vServer
        gateway IP-Adresse vom dedizierten Server
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 8.8.4.4 8.8.8.8
        dns-search meine-domain.de
Nebenbemerkung:
Als Betriebssystem auf dem dedizierten Server verwende ich CentOS 7.X.
 

IP-Projects.de

verifizierter Anbieter
verifizierter Anbieter
Was spricht dagegen den Support von Serverdiscount zu bemühen? Die werden am ehesten wissen, ob eventuell eine IP MAC Bindung im Netzwerk vorliegt oder was es bei Virtualisierung zu beachten gibt.
 

MadMakz

Member
eth0 im Host bekommt keine IP, die bekommt ja vmbr0 als Bridge zu eth0

Im Kundeninterface von myloc/webtropia/servdiscount unter Nutzungsart der IPs virtualisierung einstellen. Diesen switch muss man jedes mal wiederholen sollten weitere extra IP nachbestellt werden.
Steht übrigens auch so in deren FAQ.
 
Last edited by a moderator:

Luczz

New Member
Danke erstmal, falls ich es nicht hinbekomme, wäre jemand bereit es mir für nen 10er einzurichten, weil für jemand der sich auskennt ist es eine Arbeit von 5-10min.

MfG Luczz
 
A

andreas0

Guest
@Luczz
Wenn du es dir auch für die Zukunft vereinfachen möchtest, um damit für die Zukunft weitere Fehlerquellen zu begrenzen, solltest du es im Kundenbereich unbedingt bei der Voreinstellung belassen. Denn die Voreinstellung bindet die bis maximal 31 zusätzlich bestellbaren IP-Adressen an die MAC-Adresse deines Servers und stellt damit sicher, dass kein anderer Kunde ungewollt einer deiner zusätzlichen IP-Adressen wegen einem eventuellen Zahlendreher verwenden kann.

Bei dieser Variante ersparst du dir auch gleich den lästigen zu wiederholenden Switch, den @MadMakz meinte. Denn bei den maximal 31 nachbestellbaren IP-Adressen kann es schon mal sehr störend sein, wenn man diesen Switch mal vergißt, nur weil man die Anzahl der maximal bestellbaren IP-Adressen nicht gleich auf einen Schlag bestellt hatte.

Mein erstes Konfigurationsbeispiel bezieht sich auf die erste und sichere Variante.

Wenn du die zweite und unsichere Variante bevorzugen solltest, müßte deine Konfiguration in deiner VM wie folgt aussehen:

Code:
auto eth0
iface eth0 inet static
        address 5.199.130.XX
        netmask 255.255.255.0
        network 5.199.130.0
        broadcast 5.199.130.255
        gateway 193.111.141.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 8.8.4.4 8.8.8.8
        dns-search meine-domain.de
In deiner zu Anfang genannten Konfiguration für deine VM, welche für die zweite Variante vorgesehen ist, hast du als Gateway die IP-Adresse 5.199.130.1 verwendet. Da diese auf ein Ping innerhalb des Netzwerks bei myloc.de nicht wie gewünscht antwortet, nimm einfach mal als Gateway die IP-Adresse 193.111.141.1, die auch dein Server schon verwendet. Eventuell geht es dann.
 

Pascale

New Member
Hallo,

als erstes musst die Zusätzlichen IPs im Webinterface konfigurieren und auf Virtualisierungs-IP setzen.

Mein Hostsytem habe ich so konfiguriert:

Code:
# network interface settings; autogenerated
# Please do NOT modify this file directly, unless you know what
# you're doing.
#
# If you want to manage part of the network configuration manually,
# please utilize the 'source' or 'source-directory' directives to do
# so.
# PVE will preserve these directives, but will NOT its network
# configuration from sourced files, so do not attempt to move any of
# the PVE managed interfaces into external files!

auto lo
iface lo inet loopback

auto vmbr0
iface vmbr0 inet static
	address 193.111.140.*
	netmask 255.255.255.0
	gateway 193.111.140.1
	bridge_ports eth0
	bridge_stp off
	pointopoint 193.111.140.1
	bridge_maxwait 0
und den vServer so:
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
       address 89.163.152.*
       netmask 255.255.255.255
       pointopoint 193.111.140.1
       gateway 193.111.140.1
 

Luczz

New Member
@Pascale

Danke euch erstmal, habe alles gemacht so wie du Pascale, aber leider funktioniert es immer noch nicht. Kannst du mir eventuell über TeamSpeak³ helfen, wäre dir mega dankbar

MfG Luczz
 
Top