Repairing server-wide configuration parameters for web servers?

Hallo,
ich habe nun stunden damit verbracht mein Server mit Debian 9 zum laufen zu bekommen und alle Probleme bei Plesk fast beheben können,aber bei Folgender Fehlermelung bin ich überfordert.
Code:
Repairing web server configuration

  Reinstall SSL/TLS certificates and set the default certificate for all IP addresses? [Y/n] Y
    Reinstalling SSL/TLS certificates ............................... [OK]
    Applying the default SSL/TLS certificate to all IP addresses .... [OK]

  Repair server-wide configuration parameters for web servers? [Y/n] Y
    Repairing server-wide configuration parameters for web servers .. [2019-09-21 12:49:43.066] ERR [util_exec] proc_close() failed ['/opt/psa/admin/bin/httpdmng' '--reconfigure-server'] with exit code [1]
[FAILED]
    - httpdmng failed: [2019-09-21 12:49:42.540] ERR [util_exec]
      proc_close() failed ['/opt/psa/admin/bin/nginx_control'
      '--restart'] with exit code [1]
      Can not reload proxy server:

  Update the file of sharing passwords and permissions of users according to actual information? [Y/n] Y
    Updating the file of sharing passwords and permissions of users
    according to actual information ................................. [OK]

  Repair web server configuration for all domains? [Y/n] Y
    Repairing web server configuration for all domains. This aspect
    can be used with individual domains ("plesk repair web
    example.com"), and on the server level ("plesk repair web") ..... [2019-09-21 12:50:02.502] ERR [util_exec] proc_close() failed ['/opt/psa/admin/bin/httpdmng' '--reconfigure-all'] with exit code [1]
[FAILED]
    - httpdmng failed: Execution failed.
      Command: httpdmng
      Arguments: Array
      (
          [0] => --reconfigure-domains
          [1] => have-fun-community.de
      )

      Details: [2019-09-21 12:50:00.736] ERR [util_exec] proc_close()
      failed ['/opt/psa/admin/bin/nginx_control' '--restart'] with
      exit code [1]
      Can not reload proxy server:
Ich habe schon plesk repair all , plesk repair web und plesk repair installation in /var/log/apache2/error.log habe ich folgendes gefunden.
Code:
[Sat Sep 21 04:23:25.007473 2019] [mpm_event:notice] [pid 3497:tid 139736940466240] AH00489: Apache/2.4.25 (Debian) OpenSSL/1.0.2s mod_fcgid/2.3.9 configured -- resuming normal operations
[Sat Sep 21 04:23:25.007496 2019] [core:notice] [pid 3497:tid 139736940466240] AH00094: Command line: '/usr/sbin/apache2'
[Sat Sep 21 04:24:52.290306 2019] [mpm_event:notice] [pid 3497:tid 139736940466240] AH00491: caught SIGTERM, shutting down
[Sat Sep 21 04:24:53.001171 2019] [ssl:warn] [pid 3893:tid 140111393173568] AH01909: webmail.wbb-support24.de:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:24:53.001400 2019] [ssl:warn] [pid 3893:tid 140111393173568] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:24:53.001563 2019] [ssl:warn] [pid 3893:tid 140111393173568] AH01909: default-51_89_63_251:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:24:53.001624 2019] [:notice] [pid 3893:tid 140111393173568] ModSecurity for Apache/2.9.2 (http://www.modsecurity.org/) configured.
[Sat Sep 21 04:24:53.001629 2019] [:notice] [pid 3893:tid 140111393173568] ModSecurity: APR compiled version="1.5.2"; loaded version="1.5.2"
[Sat Sep 21 04:24:53.001633 2019] [:notice] [pid 3893:tid 140111393173568] ModSecurity: PCRE compiled version="8.39 "; loaded version="8.39 2016-06-14"
[Sat Sep 21 04:24:53.001637 2019] [:notice] [pid 3893:tid 140111393173568] ModSecurity: LUA compiled version="Lua 5.1"
[Sat Sep 21 04:24:53.001640 2019] [:notice] [pid 3893:tid 140111393173568] ModSecurity: LIBXML compiled version="2.9.4"
[Sat Sep 21 04:24:53.001643 2019] [:notice] [pid 3893:tid 140111393173568] ModSecurity: Status engine is currently disabled, enable it by set SecStatusEngine to On.
[Sat Sep 21 04:24:53.001890 2019] [suexec:notice] [pid 3893:tid 140111393173568] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Sat Sep 21 04:24:54.001089 2019] [ssl:warn] [pid 3894:tid 140111393173568] AH01909: webmail.wbb-support24.de:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:24:54.001279 2019] [ssl:warn] [pid 3894:tid 140111393173568] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:24:54.001432 2019] [ssl:warn] [pid 3894:tid 140111393173568] AH01909: default-51_89_63_251:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:24:54.005264 2019] [mpm_event:notice] [pid 3894:tid 140111393173568] AH00489: Apache/2.4.25 (Debian) OpenSSL/1.0.2s mod_fcgid/2.3.9 configured -- resuming normal operations
[Sat Sep 21 04:24:54.005290 2019] [core:notice] [pid 3894:tid 140111393173568] AH00094: Command line: '/usr/sbin/apache2'
[Sat Sep 21 04:49:03.512584 2019] [mpm_event:notice] [pid 3894:tid 140111393173568] AH00491: caught SIGTERM, shutting down
[Sat Sep 21 04:49:04.001490 2019] [ssl:warn] [pid 5941:tid 140132954193984] AH01909: webmail.wbb-support24.de:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:49:04.001734 2019] [ssl:warn] [pid 5941:tid 140132954193984] AH01909: webmail.have-fun-community.de:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:49:04.001944 2019] [ssl:warn] [pid 5941:tid 140132954193984] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:49:04.002149 2019] [ssl:warn] [pid 5941:tid 140132954193984] AH01909: default-51_89_63_251:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:49:04.002234 2019] [:notice] [pid 5941:tid 140132954193984] ModSecurity for Apache/2.9.2 (http://www.modsecurity.org/) configured.
[Sat Sep 21 04:49:04.002240 2019] [:notice] [pid 5941:tid 140132954193984] ModSecurity: APR compiled version="1.5.2"; loaded version="1.5.2"
[Sat Sep 21 04:49:04.002244 2019] [:notice] [pid 5941:tid 140132954193984] ModSecurity: PCRE compiled version="8.39 "; loaded version="8.39 2016-06-14"
[Sat Sep 21 04:49:04.002250 2019] [:notice] [pid 5941:tid 140132954193984] ModSecurity: LUA compiled version="Lua 5.1"
[Sat Sep 21 04:49:04.002254 2019] [:notice] [pid 5941:tid 140132954193984] ModSecurity: LIBXML compiled version="2.9.4"
[Sat Sep 21 04:49:04.002257 2019] [:notice] [pid 5941:tid 140132954193984] ModSecurity: Status engine is currently disabled, enable it by set SecStatusEngine to On.
[Sat Sep 21 04:49:04.002549 2019] [suexec:notice] [pid 5941:tid 140132954193984] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Sat Sep 21 04:49:05.001509 2019] [ssl:warn] [pid 5950:tid 140132954193984] AH01909: webmail.wbb-support24.de:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:49:05.001786 2019] [ssl:warn] [pid 5950:tid 140132954193984] AH01909: webmail.have-fun-community.de:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:49:05.002038 2019] [ssl:warn] [pid 5950:tid 140132954193984] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:49:05.002289 2019] [ssl:warn] [pid 5950:tid 140132954193984] AH01909: default-51_89_63_251:443:0 server certificate does NOT include an ID which matches the server name
[Sat Sep 21 04:49:05.006899 2019] [mpm_event:notice] [pid 5950:tid 140132954193984] AH00489: Apache/2.4.25 (Debian) OpenSSL/1.0.2s mod_fcgid/2.3.9 configured -- resuming normal operations
[Sat Sep 21 04:49:05.006923 2019] [core:notice] [pid 5950:tid 140132954193984] AH00094: Command line: '/usr/sbin/apache2'
Ich hoffe ich habe d as mit der error.log nun richtig gemacht und das ihr mir helfen könt das zu beheben?
 
Wenn ich das mache bekomme ich folgendes
BUSY: Update operation was locked by another update process.
exit status 1


In Plesk beim Aktivieren von nginx bekomme ich.
Der Start des Dienstes ist nicht möglich: Unable to manage service by nginxmng: ('start', 'nginx'). Error: [2019-09-21 13:35:03.305] ERR [util_exec] proc_close() failed ['/opt/psa/admin/bin/nginx_control' '--start'] with exit code [1] Can not start proxy server:

*EDIT*

Vielen dank das hat geholfen https://support.plesk.com/hc/en-us/articles/213933865
 
Last edited:

GwenDragon

Registered User
Sidn sich wohl Plesk Web GUI udn Plesk installer in die Quere gekommen.
Lösche mal /tmp/psa-installer.lock
Starte dann den Plesk Installer in der Shell.
 
Top