regelmäßiger verbindungsabbruch zu eigenem root

razor168

New Member
Moin moin.

ich habe einen Rootserver mit Debian gemietet. Auf diesem läuft auch fail2ban. Meine eigene Ip ist whitelisted. Die Dienste sind auch alle abgesichert inklusiver Verlegung des ssh Ports. Jetzt habe ich seit ein paar Tagen das Problem das ich ca. alle 60 Minuten die Verbindung zum Teamspeak 3 verliere. In HLSW werden meine Gameserver in diesem Moment auch als offline angezeigt. Erst wenn ich meinen Router neu starte habe ich wieder Zugriff. Ich muss dazu anmerken das sich die IP bei mir nur alle paar Tage wenn überhaupt ändert. Also die IP bleibt nach dem Routerneustart die gleiche. Sehr merkwürdig ist auch das ich danach wieder auf TS trotz gleichbleibender IP verbinden kann. Und die Gameserver werden dementsprechend auch wieder online angezeigt. Ich bin übrigens der einzige der aus Teamspeak 3 rausfliegt in diesem Moment. Ich bin die logs auch schon durchgegangen. Es steht jedoch nirgends drin das meine IP Addresse in diesem Moment gebannt worden ist. Kann das an meinen Internetprovider liegen oder vieleicht am Router?

Ich hoffe irgendjemand von euch hat eine Idee was das sein könnte.

razor168
 
Last edited:

mr_brain

Registered User
Wenn du die Verbindung zum Teamspeak verlierst, kannst du in dem Moment trotzdem dann noch die IP und/oder FQDN des Rootserver pingen?
 

razor168

New Member
ja das funktioniert. ich komme auch weiterhin über putty auf den server. ich habe jetzt gerade testweise nur den pc neugestartet. die gameserver werden in hlsw bei mir immer noch als offline angezeigt. Über Filezilla kann ich auch ohne Probleme verbinden. Kann es sein das die Config von Fail2ban komplett querschießt? nur wie schon geschrieben. ich bin der einzige auf Teamspeak 3 z.B. der die Verbindung verliert bzw. das die gameserver in HLSW auch als offiline angezeigt werden. Meine IP steht auch nicht in den IPTables.
 

mr_brain

Registered User
Fail2Ban sperrt die IP komplett. Du dürftest dann auch nicht pingen können oder auch nicht auf andere Dienste zugreifen können.

Wenn du den PC neu startest und sich nichts ändert und erst bei einem Reboot des Routers es wieder geht, dann schau dir halt mal den Router und dessen Logs an.
 

razor168

New Member
Die Sache mit Fail2ban bin ich der gleichen Meinung. Und es funktioniert auch wie ich anhand der IPTables und fail2ban.log sehen kann. Nur meine IP steht nicht mit drin unter den bans. "Logs bei meinem Router sind gut". ich habe den Compal CH7466CE Router von Vodafone. Entweder bin ich gerade blind oder der Router hat kein logging
 
Last edited:

Otzelott

Member
Im Teamspeak rechtsklick auf deinen Namen --> Verbindungsinformationen, und da mal den Paketverlust beobachten. Verbindung zu deinem Router über Wifi oder Kabel? Bei Kabel vielleicht mal das Kabel kontrollieren.
 

razor168

New Member
Paketverluste habe ich davor nicht. das Kabel werde ich im laufe des Tages nochmal überprüfen. Mich irritieren nur diese regelmäßigen Intervalle von ca. 1 stunde. vor allem sind andere server in hlsw trotzdem online. ich habe so das gefühl das fail2ban verbugged ist. was aber auch nicht hinkommen kann da ich der einzige bin der rausfliegt obwohl ich in der config whitelisted bin. und wie schon geschrieben. über ssh habe ich danach weiterhin zugriff auf den server. filezilla funktioniert auch. Gameserver und Teamspeak sind in dem Moment bei mir komplett unerreichbar. erst nach nem routerneustart.
 

danton

Debian User
Fail2Ban sperrt die IP komplett.
Nein, normalerweise nicht. Wenn bei Fail2Ban der SSH-Filter anspricht, dann sperrt Fail2Ban nur die Ports, die in der Jail angegeben sind (bei SSH halt Port 22).
@razor168 Fail2Ban kannst du doch relativ einfach ausschließen, indem du es einfach für einige Zeit deaktivierst. Bleibt der Fehler bestehen, dann liegt es wohl eher am Router oder Internetprovider. Ist der Fehler weg, musst du systematisch eine Jail nach der anderen im Fail2ban wieder aktivieren und testen. Sobald der fehler wieder auftritt, hast du den Schuldigen gefunden.
 

mr_brain

Registered User
Nein, normalerweise nicht. Wenn bei Fail2Ban der SSH-Filter anspricht, dann sperrt Fail2Ban nur die Ports, die in der Jail angegeben sind (bei SSH halt Port 22).

Auf einem Debian-System in der Standard-Konfiguration wird schon die komplette IP und nicht nur einzelne Ports gesperrt.
 

Joe User

Zentrum der Macht
Klingt nach überlastetem NIC (Caches voll, Überhitzung, kastrierte OEM-Chips) oder kaputtem Treiber oder irgendeiner "Sicherheitssoftware" (Anti-Viren oder ähnlicher Müll). Alles auf Clientseite (Router/PC) versteht sich.

Den Server können wir als Ursache weitestgehend ausschliessen, da kein anderer User betroffen ist und die Logs offenbar leer sind.
 

Lord Gurke

Nur echt mit 32 Zähnen
Kann es sein, dass du hinter einem Carrier-NAT sitzt - also keine eigene IPv4-Adresse hast?
Kannst du den Server weiterhin problemlos per IPv6 erreichen?
 

razor168

New Member
ok. Fehler gefunden. Es war die router firewall. Also hatte es mit der Serverkonfiguration gar nichts zu tun. So wie das aussieht hat meine Routerfirewall doch tatsächlich meinen Rootserver geblockt. Da muss man erstmal drauf kommen.

Ich werde das noch weiter beobachten aber ich denke das Problem ist gelöst.

Auf jeden Fall vielen Dank für die schnelle Hilfe und für die Tips.
 

razor168

New Member
Die Server wurden ja nicht nur in HLSW als offline angezeigt Die Server waren ja auch bei in steam offline.
 
Last edited:

DeaD_EyE

Blog Benutzer
Die Server wurden ja nicht nur in HLSW als offline angezeigt Die Server waren ja auch bei in steam offline.
Nein, er meint damit, dass man mit HLSW die Firewall aktivieren kann.

Möglicherweise eine Regel, die UDP-Traffic auf bestimmten Ports untersagt. Für den Query wird meist das UDP-Protokoll genutzt. Es kann sein, dass die Firewall des Routers diesen Traffic erkennt und dann deinen Server sperrt (ausgehender und ankommender Traffic vom/zum Server).
 

sbr2d2

Registered User
Wenn ich zurück denke hatte ich die Intervalle runter gesetzt. Vermutlich wurden zuviele Abfragen raus geschickt, bzw kamen dann zuviele Antworten zurück und der Router hat dicht gemacht. Aber ganz genau weiß ich es nicht mehr.
 

d4f

Kaffee? Wo?
Also hatte es mit der Serverkonfiguration gar nichts zu tun. So wie das aussieht hat meine Routerfirewall doch tatsächlich meinen Rootserver geblockt.
Meine generelle Empfehlung... schalte den Mist ab. Die Router-basierten "Sicherheitssysteme" auf zusammengefrickelten Billig-Homerouter funktionieren nie, kosten Unmengen Bandbreite/Latenz und bringen rein gar nichts an Vorteil. Durch NAT hast du bereits automatisch eine stabile Firewall, was soll der Router mehr machen?
 

d4f

Kaffee? Wo?
Naja UPnP ist auch wieder eine Router-Funktion. Entweder man schaltet es gleich mit ab oder man lässt es an weil man es haben will.
In beiden Fällen erwarte ich dass keine Firewall noch dabei ist welche magisch andere Entscheidungen trifft als ich.
 

Lord Gurke

Nur echt mit 32 Zähnen
Durch NAT hast du bereits automatisch eine stabile Firewall, was soll der Router mehr machen?
NAT ist keine Sicherheitsfunktion ;-)
Rein vom Funktionsprinzip verhindert es natürlich erstmal, dass Verbindungen von außerhalb des NAT nach innen gelangen - aber exakt das macht eine stateful arbeitende Firewall (wie bei IPv6) auch. Es ist also nicht das NAT sondern weiterhin die ganz profane Firewall, die dich gegen ungewollte Verbindungen von außen schützt.
 
Top