Proxmox Netzwerk Fehlkonfiguriert ?

meinlink

New Member
Guten Morgen,

folgendes Problem; Habe auf meinem Debian 10 Server Proxmox installiert. Die Installation lief Fehlerfrei durch. Das Anlegen und Starten und installieren eines OS in einer VM lief Problemlos durch, und funktioniert auch. Nur die VM ist von ausserhalb nicht erreichbar und von der VM nach aussen kommen ich auch nicht.

Habe eine Hauptip und 3 Zusätzliche:

Hauptip: xx.xx.96.238
1. ZusatzIP: xx.xx.231.154
2. ZusatzIP: xx.xx.231.158
3. ZusatzIP: xx.xx.214.133

Das ist meine Interfaces vom Hostsystem:

Code:
source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

iface lo inet6 loopback

auto enp0s31f6
iface enp0s31f6 inet static
        address xx.xx.96.238/26
        gateway xx.xx.96.193
        up route add -net xx.xx.96.192 netmask 255.255.255.192 gw xx.xx.96.193 dev enp0s31f6
# route xx.xx.96.192/26 via xx.xx.96.193

iface enp0s31f6 inet6 static
        address 2a01:xxxxx:221:ced::2/64
        gateway fe80::1

# fuer Einzel-IPs
auto vmbr0
iface vmbr0 inet static
  address xx.xx.96.238
  netmask 255.255.255.192
  bridge_ports none
  bridge_stp off
  bridge_fd 0
  up ip route add xx.xx.231.154/32 dev vmbr0
  up ip route add xx.xx.231.158/32 dev vmbr0

iface vmbr0 inet6 static
  address 2a01:xxxxxx:221:ced::3
  netmask 64
  up ip -6 route add 2a01:xxxxxx:221:ced::/64 dev vmbr0
Und hier die Interfaces der VM:

Code:
auto lo
iface lo inet loopback

# device: eth0
auto eth0
iface eth0 inet static
  address xx.xx.231.154
  netmask 255.255.255.255
  pointopoint xx.xx.96.238
  gateway xx.xx.96.238

iface eth0 inet6 static
  address 2a01:xxxxxx:221:ced::34
  netmask 64
  gateway fe80::1
Im Endeffekt war bis her egal was ich nutze (Bridge oder Routed) die VM bekommt keine Verbindung rein und auch nicht raus ?!

Wer hat Erfahrung oder schonmal selbst das Problem gehabt ?
 

danton

Debian User
Soweit ich das bei deiner Anonymisierung der IPs sehe, hast du deine Haupt-IP sowohl an die physischen LAN-Schnittstelle als auch an die Bridge gebunden. Außerdem schickst du die Pakete für deine VMs wieder übers LAN raus und nicht auf die Bridge. Und was auch nicht aus deiner Konfiguration hervorgeht, ist, ob im Linux-Kernel des Hosts IP-forwarding überhaupt aktiv ist - ohne wird er keine fremden Pakete routen.
Für das Bridging musst du ggfl. deinem Provider die MAC der Netzwerkkarte deiner VM mitteilen, da viele Provider auf ihren Switches Maßnahmen für MAC-Spoofing einsetzen und daher diese MAC erst vom Provider freigeschaltet werden muss.
 
Top