Prosody und User Search

ManDal

Member
Hallo zusammen
Ich Spiele mit dem Prosody XMPP Server rum und stehe an folgendem Problem, ich möchte die User Suche aktivieren (mod_vjud) und habe die auch eingebunden nur erhalte ich wen ich den Server neustarte folgenden Fehler:

Code:
Jun 10 22:07:37 general	info	Hello and welcome to Prosody version 0.9.8
Jun 10 22:07:37 general	info	Prosody is using the select backend for connection handling
Jun 10 22:07:37 portmanager	info	Activated service 'console' on [127.0.0.1]:5582, [::1]:5582
Jun 10 22:07:37 portmanager	info	Activated service 'c2s' on [::]:5222, [::]:5322, [*]:5222, [*]:5322
Jun 10 22:07:37 portmanager	info	Activated service 'legacy_ssl' on no ports
Jun 10 22:07:37 portmanager	info	Activated service 'http' on [::]:5280, [*]:5280
Jun 10 22:07:37 portmanager	info	Activated service 'https' on [::]:5281, [*]:5281
Jun 10 22:07:37 modulemanager	error	Error initializing module 'vjud' on 'swiss.chat': /usr/lib64/prosody/../../bin/prosody:168: module 'util.auxiliary' not found:
	no field package.preload['util.auxiliary']
	no file '/usr/lib64/prosody/util/auxiliary.lua'
	no file '/usr/share/lua/5.1/util/auxiliary.lua'
	no file '/usr/share/lua/5.1/util/auxiliary/init.lua'
	no file '/usr/lib64/lua/5.1/util/auxiliary.lua'
	no file '/usr/lib64/lua/5.1/util/auxiliary/init.lua'
	no file '/usr/lib64/prosody/util/auxiliary.so'
	no file '/usr/lib64/lua/5.1/util/auxiliary.so'
	no file '/usr/lib64/lua/5.1/loadall.so'
	no file '/usr/lib64/prosody/util.so'
	no file '/usr/lib64/lua/5.1/util.so'
	no file '/usr/lib64/lua/5.1/loadall.so'
stack traceback:
	/usr/lib64/prosody/core/modulemanager.lua:29: in function </usr/lib64/prosody/core/modulemanager.lua:29>
	[C]: in function '_real_require'
	/usr/lib64/prosody/../../bin/prosody:168: in function 'require'
	/usr/lib64/prosody/modules/mod_vjud.lua:9: in main chunk
	(tail call): ?
	[C]: in function 'xpcall'
	/usr/lib64/prosody/core/modulemanager.lua:29: in function 'pcall'
	/usr/lib64/prosody/core/modulemanager.lua:171: in function 'do_load_module'
	/usr/lib64/prosody/core/modulemanager.lua:249: in function 'load'
	/usr/lib64/prosody/core/modulemanager.lua:74: in function '?'
	/usr/lib64/prosody/util/events.lua:67: in function 'fire_event'
	/usr/lib64/prosody/core/hostmanager.lua:98: in function 'activate'
	/usr/lib64/prosody/core/hostmanager.lua:44: in function '?'
	/usr/lib64/prosody/util/events.lua:67: in function 'fire_event'
	/usr/lib64/prosody/../../bin/prosody:337: in function 'prepare_to_start'
	/usr/lib64/prosody/../../bin/prosody:403: in main chunk
	[C]: ?
Jun 10 22:07:37 portmanager	info	Activated service 's2s' on [::]:5269, [*]:5269
Jun 10 22:07:37 mod_posix	info	Prosody is about to detach from the console, disabling further console output
Jun 10 22:07:37 mod_posix	info	Successfully daemonized to PID 29041
Hat das schon jemand zum laufen gebracht?

System angaben:
  • OS: CentOS 6.6
  • Prosody: 0.9.8
Grüsse
ManDal
 

d3p

Blog Benutzer
Welche Lua-Version hast du denn installiert?
Lua 5.1, wie in deinem Output zu sehen oder 5.2?

Falls 5.2, bitte mal 5.1 probieren.
Bei mir läuft das Modul ohne Probleme.

Debian 7 64 Bit
Prosody 0.9.8
Lua version: Lua 5.1
 

ManDal

Member
Scheint so als hatte ich ein Fehler in den Files, nach dem erneuten Download hat es nun funktioniert...

Danke fürs unterstützen...

Was haltet ihr eigentlich von Prosody?
Was verwendet ihr den so?
 
Top