Proftpd auf Debian rootDS und TLS-Probleme

T

Tobster

Guest
Hallo,

ich habe ein merkwürdiges Phänomen.

Einloggen funktioniert wunderbar aber an der Stelle an der eine Verbindung über einen Port ungleich 21 zum Listen etc. aufgebaut werden soll wird die Verbindung geschlossen.

Das Problem habe ich nur zu Hause, aber nicht wenn ich mich über den Proxy auf der Arbeit verbinde.

In den Logs steht gar gar nix. Außer Connection opened und danach wieder closed.

Wenn ich TLS aus mache geht es. Den Portbereich habe ich eingeschränkt, mache ich das Rückgängig geht es auch nicht.

Ich habe auf meinem Clienten mal mitgeschnitten, über welchen Port er sich versucht zu verbinden, aber wenn das TLS an ist ist da leider kein Port über den er sich verbinden will. Hingegen ohne TLS verbindet er sich über den besagten anderen Port.

Eine ganze Weile ging das auch mit genau dieser Konfiguration.

Achso der Server ist selbst kompiliert. Mit dem Original Debianpaket ist es das selbe.
 
Last edited by a moderator:
Das hat was geändert, es geht jetzt deutlich schneller, dass der Client sagt Verbindung getrennt. Wie gesagt die Verbidung wird wärend der Zeit des Listens getrennt, wenn der Port ausgehandelt werden sollte.

Das schlimme ist im Frühjahr ging die Konfiguration noch so wie sie ist. In den Logs steht immer noch das selbe. Open Close und fertig. Nicht mehr und nicht weniger.

Kann vielleicht etwas vom SW-Softsystem ausgehen?
 
Ich habe mir mal eine TLS.log angelegt und siehe da ich bin auf was gestoßen.

Code:
Jul 11 20:07:30 mod_tls/2.1.1[18259]: TLS/TLS-C requested, starting TLS handshake
Jul 11 20:07:31 mod_tls/2.1.1[18259]: TLSv1/SSLv3 connection accepted, using cipher RC4-MD5 (128 bits)
Jul 11 20:07:36 mod_tls/2.1.1[18259]: Protection set to Private
Jul 11 20:07:37 mod_tls/2.1.1[18259]: starting TLS negotiation on data connection
Jul 11 20:07:37 mod_tls/2.1.1[18259]: TLSv1/SSLv3 data connection accepted, using cipher RC4-MD5 (128 bits)

Wenns funktioniert von der Arbeit

und wenn nicht geht.

Code:
Jul 10 16:41:59 mod_tls/2.1.1[3770]: TLS/TLS-C requested, starting TLS handshake
Jul 10 16:42:02 mod_tls/2.1.1[3770]: unable to accept TLS connection: 
  (1) error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
Jul 10 16:42:02 mod_tls/2.1.1[3770]: TLS/TLS-C negotiation failed on control channel

Kann sich das jemand erklären.

Code:
<IfModule mod_tls.c>        TLSEngine on        TLSLog /var/log/proftpd/proftpd_tls.log        TLSProtocol TLSv1        TLSRequired on        TLSVerifyClient off        TLSRSACertificateFile /etc/ftpcert/host.cert        TLSRSACertificateKeyFile /etc/ftpcert/host.key</IfModule>

Meine Conf. Von jetzt auf gleich - ich vermute nach dem OpenSSL update vor ein paar Wochen ging es mit dem Clienten zu Hause nicht mehr, deswegen die Vermutung das es mit dem Proxy zusammen hing.
 
Last edited by a moderator:
Nach der Anleitung habe ich es ja eingerichtet. Nur kapier ich nicht, dass es an manchen Rechnern geht und an manchen nicht. Wobei es vor ein paar Wochen noch mit der selben Einstellung an allen Clienten ging.
 
Ich habe das jetzt rausgefunden schuld war bvzw ist ein Fehler in Proftp 1.3.0. Man muss SSLv23 anstatt TLSv1 einstellen und es geht.
 
Tobster said:
Man muss SSLv23 anstatt TLSv1 einstellen und es geht.

DANKE!!! Du hast viele vergebliche Versuche SSL FTP zu aktivieren endlich durch ein Erfolgserlebnis belohnt!! :D

Gruß
Thunda
 
Back
Top