• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Probleme mit Zertifikat in Outlook

Loci

New Member
Zum Versenden meiner Mails wollte ich ein "Lets Encrypt" Zertifikat verwenden, das ich auch der Hauptdomain zugeordnet habe. Bisher breitet dies unter Outlook aber Probleme, es erscheint jedes Mal eine Meldung, die bestätigt werden muss.

Das zweite Problem ist, dass ich in Plesk für meine Mails nur eine Zertifikat anmelden kann, obwohl ich mehrere Domains habe. Wäre hier ein Multidomain-Zertifikat sinnvoll und gibt es da auch ein kostenloses?
 

Attachments

  • zertifikat.jpg
    zertifikat.jpg
    98.8 KB · Views: 277
Ich denke mal, dass dein Mailclient das Zertifikat auf Gültigkeit prüft und auch prüft, ob es für die verwendete Domain ausgestellt worden ist.

Ich weiß jetzt nicht nach welchem Kriterium geprüft wird. Einmal könnte die eingegebene Adresse des SMTP-Servers mit dem Zertifikat verglichen werden und/oder mit dem Namen, mit dem sich der SMTP-Server meldet.

Wenn dein Server nun smtp.domain.tld ist und deine Website domain.tld, würde es das Verhalten erklären.

Google findet folgendes: http://www.schieb.de/722377/outlook-fehler-meldung-zielprinzipalname-ist-falsch-beheben

Das ist aber nur ein drumherum arbeiten und erklärt nicht woher der Fehler jetzt genau kommt.
 
Wie bereits geschrieben, der Domänenname stimmt nicht überein.

Wenn das Zertifikat z.B. für "irgendwas.domain.tld" ausgestellt ist, gilt die auch für diese Domain.
Wenn in Outlook, nehme jetzt mal an das dort Pop3 oder IMAP verwendet wird, als SMTP/IMAP/POP3 Server "mail.domain.tld" verwendet wird, kommt dieser Fehler, selbst wenn bei beiden Domains die gleiche IP auflöst.

Lösung: in Plesk eine Subdomain für "mail.domain.tld" anlegen und dieses dann darüber erstellt Zertifikat in Plesk für den Mailserver verwenden.
Dann ist der Fehler weg. Alles andere sind nur Bastelarbeiten am Client.
 
Wie bereits geschrieben, der Domänenname stimmt nicht überein.

Wenn das Zertifikat z.B. für "irgendwas.domain.tld" ausgestellt ist, gilt die auch für diese Domain.
Wenn in Outlook, nehme jetzt mal an das dort Pop3 oder IMAP verwendet wird, als SMTP/IMAP/POP3 Server "mail.domain.tld" verwendet wird, kommt dieser Fehler, selbst wenn bei beiden Domains die gleiche IP auflöst.

Lösung: in Plesk eine Subdomain für "mail.domain.tld" anlegen und dieses dann darüber erstellt Zertifikat in Plesk für den Mailserver verwenden.
Dann ist der Fehler weg. Alles andere sind nur Bastelarbeiten am Client.

Funktioniert leider nicht. Habe in Plesk die Domain mail.domain.de und das passende SSL Zertifikat angelegt und dieses für den Schutz von E-Mails eingerichtet. Dann noch in Outlook pop.mail.domain.de und smtp.mail.domain.de eingstellt und dennoch geht es nicht.
 
Ja, und jetzt vergleiche mal...

Mail.domain.tld
pop.mail.domain.tld
smtp.mail.domain.tld

Ist irgendwie alles unterschiedlich, oder?
Verwende mail.domain.tld und gut ist.
Warum davor nochmals Subdomains?
 
Es gibt keinen Zwang, die eigene Maildomain pop.... oder smtp... zu nennen, mail... ist ok.
Trage mail... als Maildomain in Outlook ein und alles sollte funktionieren.
 
Dann wäre noch interessant zu wissen was sind für DNS Einträge gemacht, bzw. wohin zeigt jeder Eintrag.
Zeigen diese Einträge bezüglich Mail auch auf den Server?
Wie wurde das Konto in Outlook eingerichtet? Standard Ports?
 
Jetzt klappt es, hab den MX Wert überarbeitet. Pref (MX/SRV) stand auf 0, hab dort 20 eingetragen.

Wie schaut es mit den anderen Domains aus, die müssen dann bei pop und smtp dann den Mailserver der ersten Domain eintragen? Also mail.domain.de

Oder kann man in PLesk einen eigenen einrichten mail.domain2.de
 
Der Wert ist aufsteigend nach Priorität. Bsp der erst Mailserver hat 10, der zweite 20, usw.
Wenn einer ausfällt übernimmt der nächste je nach Priorität.

Alle nehmen dann "mail.domain.tld", denn es läuft ja nur ein Mailserver auf deinem Server.
Sonst hast Du ja wieder das gleiche Problem mit dem Zertifikat, denn "mail.domain2.tld" ist nicht gleich "mail.domain.tld"

Wenn Du nur einen Server hast, welcher für alles zuständig ist (Pop3, IMAP, Smtp usw), dann ist dies immer die gleiche Adresse.
Wenn je nach Dienst ein anderer Server zuständig ist, dann unterscheiden sich die Adressen, dann kannst Du aufteilen: pop.domain.tld, smtp.domain.tld usw.
 
Zum Verständnis:

Der Kunde mit der Domain "wurzelprumpft.de" nimmt als Mailserver (pop3, smtp, imap) "mail.domain.tld"
Wenn er seine eigene Domain nimmt, stimmt das Zertifikat nicht überein.
 
Back
Top