Probleme mit Anope

fremd

Registered User
Nabend

in meiner Unrealircd.conf steht im Linkblock folgendes:

Code:
link		services.domain.org
{
	username	*;
	hostname	127.0.0.1;
	bind-ip		*;
	port		8886;
	hub		*;
	password-connect "moepp";
	password-receive "moepp";
	class		servers;
		options {
			autoconnect;
			ssl;
			};
};
Der Remoteblock in der services.conf sieht folgendermassen aus:

Code:
RemoteServer    127.0.0.1 8886 "moepp"
#RemoteServer2  localhost 6667 "mypass"
#RemoteServer3  localhost 6667 "mypass"
Die verbinden sich net was mir irgendwie net ganz klar ist, im Logfile der Services steht folgendes:

Code:
[Jan 31 16:25:34 2008] Anope 1.6.5 (1197) (compiled for UnrealIRCd 3.1.1+) starting up
[Jan 31 16:25:34 2008] Attempting to load V3 HS Database
[Jan 31 16:25:34 2008] Databases loaded
[Jan 31 16:25:34 2008] FATAL: Can't connect to server: Connection refused
[Jan 31 16:26:38 2008] Anope 1.6.5 (1197) (compiled for UnrealIRCd 3.1.1+) starting up
[Jan 31 16:26:38 2008] Attempting to load V3 HS Database
[Jan 31 16:26:38 2008] Databases loaded
[Jan 31 16:26:38 2008] Connected to Server 1 (irc.domain.org:8886)
[Jan 31 16:26:38 2008] Read error from server: Connection reset by peer
Kann evtl hier jemand helfen.


Uli
 
T

TamCore

Guest
Code:
listen 127.0.0.1:8886 {
	options {
		serversonly;
	};
};
In die unrealircd.conf

PS: ich würde autoconnect; in der unrealircd.conf nicht für Services verwenden.
 

fremd

Registered User
will irgendwie nicht:

Code:
[17:28:07] -irc.domain.org- *** Notice -- Connection to services.domain.org[127.0.0.1] activated.
-
[17:28:08] -irc.domain.org- Lost connection to services.domain.org[127.0.0.1]:Connection reset by peer
Uli
 
T

TamCore

Guest
Hast du meinen Post überhaupt richtig gelesen?
autoconnect; und ssl; muss aus dem Linkblock in der unrealircd.conf raus.
 

Berli

Registered User
Hiho,

ich versuche mich auch grade in das Thema reinzuarbeiten.
Bei mir schaut das so aus:

listen *:6601
{
options
{
ssl;
clientsonly;
};
};
listen 127.0.0.1:6665
{
options
{
serversonly;
};
};
ist das

listen *:6601
{
options
{
ssl;
clientsonly;
};
};
nicht für eine eventuelle SSL-Verbindung da ?
 
Top