Problem mit zusätzlicher IP-Adresse auf 1&1 DCS

Stephen8

New Member
Moin Moin,

ich betreibe einen Dynamic Cloud Server (DCS) unter Windows Server 2008 R2 mit IIS 7.5 bei 1&1.

Auf dem Server waren bislang 6 IP-Adressen eingerichtet, die im IIS an diverse Websites gebunden sind und alle hervorragend funktionieren.

Nun habe ich kürzlich eine weitere IP-Adresse bestellt (und damit die max. Anzahl zusätzlicher IP-Adressen erreicht), diese wie üblich auf dem Server eingerichtet (streng nach 1&1-Hilfe-Anweisung), aber kann sie nicht von extern aufrufen.

Bin seit 2 Tagen mit dem 1&1 Tech Support zugange, aber die meinen, auf Ihrer Seite sei alles in Ordnung mit der neuen IP-Adresse... und verweisen ansonsten auf meine Eigenverantwortung bei der Serververwaltung.

Ich wüsste aber nicht, was ich beim Einrichten dieser neuen IP-Adresse anders gemacht hätte als bei den anderen:

1. Im ControlCenter die neue IP an die VM gebunden.

2. Auf dem Server die neue IP dem Netzwerkadapter (TCP/IPv4-Properties -> Advanced TCP/IP Settings) hinzugefügt, korrekte Subnet mask eingetragen.

3. Server neu gestartet (Reboot).

4. Im IIS eine Testsite eingerichtet und in den Site Bindings die neue IP zugewiesen (Port 80).

Lokal auf dem Server kann ich die Site über die IP im IE aufrufen, kein Problem. Remote gibt es jedoch immer einen Timeout.

Es gibt auf dem Server noch andere Sites, die remote über ihre IP aufgerufen werden können, da klappt das.

Wenn ich auf dem Server ein "netstat -ano" absetze, dann lauscht die neue IP auf den Ports 139 und 1801, aber nicht auf Port 80. Sollte sie das? Anscheinend muss das nicht unbedingt sein: Eine andere IP auf dem Server lauscht laut netstat auch nicht auf Port 80 und lässt sich dennoch remote aufrufen.

Hmmm... hier enden erstmal meine Ideen.

Weiß jemand Rat?

Vielen Dank im Voraus,
S.
 

Lord Gurke

Nur echt mit 32 Zähnen
Antwortet sie denn auf Pings? Wenn nein, wo bricht ein Traceroute von außen ab?
Notfalls mal mit anderen funktionierenden IPs vergleichen.

Alternativ kannst du auch vom Server aus einen Traceroute zu einem externen Ziel machen und sehen, wo es abbricht:

Code:
tracert -S deine.neue.ip.adresse serversupportforum.de

EDIT: Ach Mist, gerade erst gesehen dass der -S -Parameter nur für IPv6 ist :(
 

Stephen8

New Member
Keine der auf dem DCS eingerichteten IPs ist per ping oder tracert zu erreichen, das ist aber auch so gewollt.
 

Lord Gurke

Nur echt mit 32 Zähnen
Dann solltest du so lange diese Filterregel abschalten, damit du das testen kannst, denn genau dafür braucht man diese Dienste ;)
 

d4f

Kaffee? Wo?
traceroutebar ist die IP so oder so bis zumindest zum letzten Hop.
Eventuell solltest du aber ICMP Echo testweise ebenfalls auf der Machine aktivieren.
 

Stephen8

New Member
Danke erstmal für die Hinweise. Ich habe jetzt für die fragliche IP die externe Firewall deaktiviert und in der lokalen Firewall ICMP (aber nur für diese IP) erlaubt.

Ping und tracert leider wie gehabt: Ping 100% Verlust, tracert ab Pos. 13 (das ist im 1&1 Netz) nur noch timeouts.

Muss jetzt erstmal raus, mache morgen weiter.

So long,
S.
 

Stephen8

New Member
OK, ich habe weiter experimentiert. Wenn ich in der in der lokalen Firewall ICMP für alle lokalen Ports erlaube, dann kann ich alle anderen IPs des DCS anpingen und bekomme auch tracert-Ergebnisse. Nur bei der neuen IP klappt weder ping noch tracert. Das Ganze ist übrigens unabhängig von den aktuellen Einstellungen der externen Firewall.

Klingelt da bei jemandem irgendwas? Wo könnte ich weiterforschen?

Vielen Dank im Voraus,
S.
 

mkeil

Registered User
Hast Du mal bei 1&1 angefragt?
Wenn dort auch beim tracert nichts mehr passiert, würde ich die mal fragen ob etwas mit dem Routing/.. nicht stimmt.
 

Stephen8

New Member
Gelöst

Das Problem ist gelöst.

Was war? 1&1 hat vor einiger Zeit eine neue Hardwareplattform für die DCS bereitgestellt. Ich hatte meinen Vertrag entsprechend aktualisiert, aber um in den vollen Genuss der neuen Features zu kommen, muss der Umzug der VM in die neue Umgebung noch manuell angestoßen werden. Das habe ich bislang noch nicht gemacht, da laut 1&1 damit ein Verlust aller im DCS bereits eingerichteten IP-Adressen einhergeht. Man bekommt nach dem Umzug neue zugewiesen.

Anscheinend gibt es keine Möglichkeit, die alten IP-Adressen weiter zu nutzen oder nach dem Umzug wieder dieselben zugewiesen zu bekommen...

Dieser Umzug ist daher mit erheblichem Verwaltungsaufwand auf meiner Seite verbunden (auf meinem DCS laufen diverse Webauftritte internationaler Kunden, die ihre Domains jeweils selbst verwalten) und die laufenden Websites fallen auch für Stunden, wenn nicht für Tage aus. Das will also gut koordiniert werden. Aber ich schweife ab.

Also war die Situation die: schon neuer Vertrag, aber noch alte HW-Plattform. Das haben die 1&1er nicht geschnallt und die neue IP-Adresse, um die es hier ging, intern irgendwie schon auf die neue HW konfiguriert.

Ärgerlich nur, dass es gut eine Woche gedauert hat und ich immer wieder nachfragen musste, ehe der Fehler gefunden wurde. Einen Großteil der Fehlersuche habe ich denen praktisch abgenommen.

Na egal, jetzt läuft alles. Hoffentlich noch lange.

Danke an alle, die hier Anregungen gegeben haben!

So long,
S.
 
Top