Private IP im Plesk und sonst ein paar Fragen

MarroniJohny

New Member
Hi

Ich bin neu hier, und habe gleich schon ein paar Fragen. Ich hatte so um 2008 rum zuhause ein eigenes Plesk auf Windows am laufen. Das wurde uns mit SPAM Filter aber zu teuer, und wir sind auf ein Reseller Hosting mit Confixx umgestiegen. Nun habe ich eine 10 Gbit/s Anbindung bekommen. Da wurde ich schwach, und ich habe mir wieder ein Plesk angemietet, das kostet ja nun nicht mehr alle Welt. Das mittlere Abo mit 30 Domains gabs. Läuft auf einem Debian 10.9 auf dem einen ESXi.

Ich habe zwei ESXi am laufen. Eine Consumerbüchse und ein E5 v4 mit 128GB RAM mit napp-it AiO. Den Fibre Router kann man leider nicht bridgen. Da hängt am exposited Host eine Zywall 110, die DMZ von den Servern hängen direkt an der Zywall dran. Ich mache da im Falle von Plesk doppeltes NAT.

Nameserver hoste ich auf Cloudflare. Funktioniert auch mit meinen lokalen Zertifikaten (let's encrypt). So weit so gut.

Nun habe ich beim Plesk aber die private Adresse von meiner DMZ drin. Das funktioniert alles recht gut. Aber einige Funktionen, wie temporäre Domains oder die Web Statistik enthalten dann im Link halt die private Adresse. Kann ich im Plesk die öffentliche IP hinzufügen, oder macht das keinen Sinn? Wie ist da vorzugehen?

Dann habe ich bei Cloudflare im Nameserver den TXT Eintrag für die Zertifikate (_acme-challenge) angelegt. Ist das richtig so, oder sollte ich den Eintrag im Plesk vornehmen? Soll ich bei der Domain noch meine eigenen Nameserver als 3. Eintrag hinzufügen? Oder ist das Wumpe?

Die 10 Gbit/s Anbindung ist ein normaler privater Anschluss. Ich habe mal die fair use Policy vom Provider durchgelesen. Da steht nichts bzgl. eigenen Server hosten. Normale Nutzung halt, und der Rest ist nicht zutreffend. Ich bin schon recht der power User, da stehen diverse Hosts, und ich dürfte wohl so 40-50 VMs am laufen haben. Die machen allesammt aber wenig Traffic. Aber auf meinem neuen Plesk habe ich eine Seite am laufen, die macht schon so 3-5TB pro Monat. Bekomme ich da Probleme mit dem Provider, oder geht das als normale Nutzung durch? Die Zywall macht mit einem TCP Stream eh bei 500 Mbit/s zu, UDP macht sie bei drei Streams maximal 1.5 Gbit/s. Aber ist eh alles nur 1 Gbit/s verkabelt. So wie ich verstanden habe, hängen im Headend an den 10 Gbit/s 64 User, die sich die Bandbreite teilen. Nachfragen beim Provider möchte ich auch nicht unbedingt, schlafende Hunde soll man ja bekanntlich nicht wecken.

Gruss und danke

Martin
 

MarroniJohny

New Member
Hi

Das mit den IP Adressen habe ich hin gekriegt. Das war simpel, einfach die private IP wählen, dann kann man da zusätzlich die öffentliche IP eintragen.

Hartnäckiger war SFTP einzurichten: Ich hatte vergessen, denn SSH Server zu installieren. Ich dachte, ich lasse das Plesk machen. Im Admin Interface war das nirgends ersichtlich, dass der SSH Server fehlt. SFTP liess sich auch aktivieren, aber halt nicht ansprechen. Himmelherrgott, wieso hat das der Plesk Installer nicht mit installiert? Wie auch immer, hat mich den ganzen Tag gekostet das zu fixen.
 
Top