Postfix mit 2 Domains, IPs

marsman242

New Member
Hi!

Ich betreibe schon ein paar Jahren einen Linux-Server, auf dem auch ein Mail-Server läuft. Klassisch mit Postfix, Dovecot und Rsmapd. Dem Host sind 2 externe IPs und 2 de.-Domains zugewiesen. Einmal für privat und einmal für geschäftlich. Die Mail-Adressen lauten mail@domain1.de und mail@domain2.de. Den Mailserver habe ich nach Anleitung von Thomas Leistner eingerichtet. Damit postfix mit den beiden Domains klar kommt, habe ich in der master.cf jeweils einen Block pro Domains/IP und einen dritten für localhost konfiguriert (Doku). Also etwa so:

Code:
<ip1>:smtp      inet  n       -       y       -       1       postscreen
    -o smtpd_service_name=smtpd_1
    -o tlsproxy_service_name=tlsproxy_1
    -o syslog_name=postfix/<domain1>.de
    -o smtp_helo_name=mail.<domain1>.de
    -o smtpd_banner=<domain1>.de ESMTP $mail_name (Debian/GNU)
    -o smtpd_sasl_auth_enable=no
    -o smtpd_tls_key_file=/etc/letsencrypt/live/mail.<domain1>.de/privkey.pem
    -o smtpd_tls_cert_file=/etc/letsencrypt/live/mail.<domain1>.de/fullchain.pem
smtpd_1        pass  -       -       y       -       -       smtpd
    -o syslog_name=postfix/<domain1>.de
dnsblog   unix  -       -       y       -       0       dnsblog
tlsproxy  unix  -       -       y       -       0       tlsproxy
...
Das funktioniert zwar generell. Mit dieser Vorgehensweise bin ich aber nicht zufrieden. Schwerwiegend ist, dass postscreen nun parallel ausgeführt wird und sich auf btree:/var/lib/postfix/postscreen_cache selbst locked.

Meine Frage wäre nun, ob es für den Betrieb von 2 Domains auf einem Host eine bessere Konfiguration gibt. Ich habe ein bisschen über postmulti gelesen. Kann aber nicht abschätzen, ob ich damit besser fahre. Was meint ihr?
 

marsman242

New Member
Damit postscreen parallel ausgeführt werden kann, habe ich nun memcached installiert und eingebunden:

Code:
postscreen_cache_map = memcache:/etc/postfix/postscreen_cache
proxy_write_maps = proxy:btree:/var/lib/postfix/postscreen_cache
Insgesamt funktioniert meinen Konfiguration nun. Die mx-toolbox zeigt nur noch 2 Warnungen für meine zweite Domain:

Code:
smtp: Reverse DNS does not contain the hostname
smtp: Reverse DNS does not match SMTP Banner
 

danton

Debian User
In den PTR-Record für deine IP-Adresse gehört ein FQDN in der Form hostname.domain.tld, du hast da vermutlich nur domain.tld eingetragen (was nicht ausreicht und bei einiges Spamfiltern schon Probleme machen kann). Und es macht auch Sinn, dass der Mailserver sich im HELO ebenfalls mit hostname.domain.tld meldet, mindestens muss der HELO aber per A-Record wieder zur sendenden IP auflösen (also ausgehende Mails, nicht eingehend).
 

marsman242

New Member
Ich habe meinen Server bei Netcup. Soweit ich weiß, kann ich über das "Servicecontrolpanel" keine PTR-Records verwalten. Trotzdem Danke für den Tipp.
 

marsman242

New Member
Ja, sorry! Habs inzwischen auch gefunden. Wenn ich nun über meinen SMTP-Server eine Mail sende, sieht die Kommunikation so aus:

Code:
[16908:Main Thread]: I/SMTP SMTP Connecting to: smtp.domain1.de:587
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 220 submission.domain1.de ESMTP Postfix
[16908:Main Thread]: I/SMTP SMTP entering state: 14
[16908:Main Thread]: I/SMTP SMTP Send: EHLO [x.x.x.x]

[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-submission.domain1.de
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-PIPELINING
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-SIZE 52428800
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-VRFY
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-ETRN
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-STARTTLS
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-ENHANCEDSTATUSCODES
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-8BITMIME
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-DSN
[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250 CHUNKING
[16908:Main Thread]: I/SMTP SMTP entering state: 4
[16908:Main Thread]: I/SMTP SMTP entering state: 21
[16908:Main Thread]: I/SMTP SMTP Send: STARTTLS

[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 220 2.0.0 Ready to start TLS
[16908:Main Thread]: I/SMTP SMTP entering state: 19
[16908:Main Thread]: I/SMTP SMTP entering state: 14
[16908:Main Thread]: I/SMTP SMTP Send: EHLO [x.x.x.x]

[16908:Main Thread]: I/SMTP SMTP entering state: 0
[16908:Main Thread]: I/SMTP SMTP Response: 250-submission.domain.de
...
 
Top