Postfix für Versand einrichten

#1
Hallo,

wie kann ich Postfix korrekt einrichten, sodass ich Mails versenden kamm mit PHP bzw VHCS?

Habe es bisher nur installiert nichts konfiguriert
 

CentY

Registered User
#2
Wenn du VHCS mit dem Installationsscript installiert hast ist bereits alles fertig. Aber auch sonst wenn du dich an Anleitungen zu VHCS gehalten hast müsste bereits alles fertig eingerichtet sein.
 
#3
Und den SMTP-Client selbst muss ich nicht konfigurieren? Denn die PHP Mail Funktion funktioniert nicht, und die gesendeten Mail kommen ja auch nie an!
 
#5
Also hier die Logs

Code:
Aug 19 12:51:49 localhost postfix/pickup[2889]: 4F42E57E882: uid=33 from=<vu2002>
Aug 19 12:51:49 localhost postfix/cleanup[3094]: 4F42E57E882: message-id=<20090819105149.4F42E57E882@webserver-dw>
Aug 19 12:51:49 localhost postfix/qmgr[2891]: 4F42E57E882: from=<vu2002@webserver-dw.local>, size=398, nrcpt=1 (queue active)
Aug 19 12:51:49 localhost postfix/virtual[3096]: 4F42E57E882: to=<meine@mail.de>, relay=virtual, delay=0.2, delays=0.17/0.01/0/0.02, dsn=5.1.1, status=bounced (unknown user: "meine@mail.de")
Aug 19 12:51:49 localhost postfix/cleanup[3094]: 63F9857E883: message-id=<20090819105149.63F9857E883@webserver-dw>
Aug 19 12:51:49 localhost postfix/qmgr[2891]: 63F9857E883: from=<>, size=2154, nrcpt=1 (queue active)
Aug 19 12:51:49 localhost postfix/bounce[3097]: 4F42E57E882: sender non-delivery notification: 63F9857E883
Aug 19 12:51:49 localhost postfix/qmgr[2891]: 4F42E57E882: removed
Aug 19 12:51:49 localhost postfix/local[3098]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Aug 19 12:51:50 localhost postfix/local[3098]: 63F9857E883: to=<vu2002@webserver-dw.local>, relay=local, delay=1.1, delays=0.01/0.04/0/1.1, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Aug 19 12:51:50 localhost postfix/qmgr[2891]: 63F9857E883: removed

Meine Mailadresse habe ich mit meine@mail.de ersetzt.
 
#6
Hier noch die Logs in der Mail.warn
Code:
Aug 19 12:51:49 localhost postfix/local[3098]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Und in der Mail.err
Code:
Aug 18 14:21:28 webserver-dw postfix[8595]: fatal: file /etc/postfix/main.cf: parameter myhostname: bad parameter value: {MTA_HOSTNAME}
 
#7
warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Die erste Meldung ist nicht schlimm, sollte aber korrigiert werden: in /etc/postfix/main.cf nach Einträgen der Form "... = nis:...." suchen und den nis:...-Teil entfernen, sofern auf der rechten Seite noch weitere Sachen stehen. Im Zweifelsfall den Eintrag mal hier posten.

parameter myhostname: bad parameter value: {MTA_HOSTNAME}
Das ist ein richtiges Problem. Da ist wohl bei der Installation von VHCS was schief gelaufen. Falls das die einzige Zeile in der main.cf und master.cf ist, in der Ausdrücke in geschweiften Klammern stehen, reicht es wohl, das von Hand zu reparieren: Trage dort den vollständigen Hostnamen des Servers ein (schau auch gleich danach, dass für den Hostnamen ein PTR-Record im DNS existiert -> Suchfunktion es Forums).

Ansonsten solltest Du prüfen, ob der Rest der VHCS-Installation fehlerfrei verlaufen ist, und ggfs. überlegen ob eine Neuinstallation angebracht ist.
 
#8
In der man.cf habe ich jetzt folgende Zeilen geändert:
Code:
myhostname = localhost
mydomain = localhost
Nach einem restart kam diese Fehlermeldung nicht mehr!

:nis - Einträge konnte ich nicht finden!
Trotzdem werden die Mails nicht abgesendet!
Hier mal die Komplette main.cf
Code:
#
# Postfix MTA Manager Main Configuration File;
#
# Please do NOT edit this file manually;
#

#
# Postfix directory settings; These are critical for normal Postfix MTA functionallity;
#

command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
program_directory = /usr/lib/postfix

#
# Some common configuration parameters;
#

inet_interfaces = all
mynetworks_style = host

myhostname = localhost
mydomain = localhost
myorigin = $mydomain

smtpd_banner = $myhostname VHCS2 2.4 Rhea Managed ESMTP 2.4.8
setgid_group = postdrop

#
# Receiving messages parameters;
#

mydestination = $myhostname, $mydomain 
append_dot_mydomain = no
append_at_myorigin = yes
local_transport = local
virtual_transport = virtual
transport_maps = hash:/etc/postfix/vhcs2/transport

#
# Delivering local messages parameters;
#

mail_spool_directory = /var/mail
# Mailboxquota
# => 0 for unlimited
# => 104857600 for 100 MB
mailbox_size_limit = 0
mailbox_command = procmail -a "$EXTENSION"

biff = no

alias_database = hash:/etc/aliases

local_destination_recipient_limit = 1
local_recipient_maps = unix:passwd.byname $alias_database

#
# VHCS Autoresponder parameters;
#

vhcs2-arpl_destination_recipient_limit = 1

#
# Delivering virtual messages parameters;
#

virtual_mailbox_base = /var/mail/virtual
virtual_mailbox_limit = 0

virtual_mailbox_domains = hash:/etc/postfix/vhcs2/domains
virtual_mailbox_maps = hash:/etc/postfix/vhcs2/mailboxes

virtual_alias_maps = hash:/etc/postfix/vhcs2/aliases

virtual_minimum_uid = 1001
virtual_uid_maps = static:1001
virtual_gid_maps = static:8

#
# SASL paramters;
#

smtpd_sasl_auth_enable = yes
smtpd_sasl2_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,
			       permit_mynetworks,
			       reject_unauth_destination

#
# TLS parameters; activate, if avaible/used
#

#smtpd_tld_loglevel = 2
#smtpd_tls_cert_file = /etc/postfix/cert.pem
#smtpd_tls_key_file = /etc/postfix/privkey.pem
#smtpd_use_tls = yes
#smtpd_tls_auth_only = no
#smtpd_tls_received_header = yes


#
# AMaViS parameters; activate, if avaible/used
#

#content_filter = amavis:[127.0.0.1]:10024

#
# Quota support; activate, if avaible/used
#

#virtual_create_maildirsize = yes
#virtual_mailbox_extended = yes
#virtual_mailbox_limit_maps = mysql:/etc/postfix/mysql_virtual_mailbox_limit_maps.cf
#virtual_mailbox_limit_override = yes
#virtual_maildir_limit_message = "The user you're trying to reach is over mailbox quota."
#virtual_overquota_bounce = yes
Was könnte das Problem sein?
 
#10
Ist die Domain von "meine@mail.de" eine Domain auf dem Server oder ist das eine Mailadresse, die extern bei einem anderen Provider liegt?

PS: localhost ist kein vollständiger Hostname. Du musst dort den richtigen Hostnamen eintragen, den Du z.B. erhälst, wenn Du den Befehl
Code:
dig +short -x [I]<IP-Adresse des Servers>[/I]
ausführst.
 
#11
Ja, die Domain ist eine externe Mailadresse! Mit internen hab ich bisher noch nicht probiert.

Auch nach dem eintragen des korrekten Namens wird die Mail leider auch nicht versendet!

Code:
Aug 19 22:28:09 localhost postfix/pickup[5036]: 5AC2357E886: uid=33 from=<vu2002>
Aug 19 22:28:09 localhost postfix/cleanup[5049]: 5AC2357E886: message-id=<20090819202809.5AC2357E886@web-pc>
Aug 19 22:28:09 localhost postfix/qmgr[5037]: 5AC2357E886: from=<vu2002@web-pc>, size=402, nrcpt=1 (queue active)
Aug 19 22:28:09 localhost postfix/virtual[5052]: 5AC2357E886: to=<meine@mail.de>, relay=virtual, delay=0.06, delays=0.04/0.01/0/0.01, dsn=5.1.1, status=bounced (unknown user: "meine@mail.de")
Aug 19 22:28:09 localhost postfix/cleanup[5049]: 65F4F57E887: message-id=<20090819202809.65F4F57E887@web-pc>
Aug 19 22:28:09 localhost postfix/qmgr[5037]: 65F4F57E887: from=<>, size=2164, nrcpt=1 (queue active)
Aug 19 22:28:09 localhost postfix/bounce[5053]: 5AC2357E886: sender non-delivery notification: 65F4F57E887
Aug 19 22:28:09 localhost postfix/qmgr[5037]: 5AC2357E886: removed
Aug 19 22:28:09 localhost postfix/local[5054]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Aug 19 22:28:09 localhost postfix/local[5054]: 65F4F57E887: to=<vu2002@web-pc>, relay=local, delay=0.04, delays=0.01/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Aug 19 22:28:09 localhost postfix/qmgr[5037]: 65F4F57E887: removed
EDIT:

Was bedeutet diese Zeile in der Log File
Code:
delivered to command: procmail -a "$EXTENSION
Denn Procmail ist auf meinem Server soweit ich weiß nicht installiert!
 
#12
oO, die Domain an der ich eine mail senden wollte, war in VHCS bereits Lokal angelegt, deshalb gings wohl nicht!

Aber wie kann ich das Spamproblem lösen?
Code:
Aug 20 08:57:58 localhost postfix/smtp[7535]: A974D57E886: host ASPMX.L.GOOGLE.COM[209.85.218.40] said: 421-4.7.0 [meineip] Our system has detected an unusual amount of 421-4.7.0 unsolicited mail originating from your IP address. To protect our 421-4.7.0 users from spam, mail sent from your IP address has been temporarily 421-4.7.0 blocked. Please visit http://www.google.com/mail/help/bulk_mail.html 421 4.7.0 to review our Bulk Email Senders Guidelines. 20si2948299bwz.66 (in reply to end of DATA command)
 

bad_brain

Registered User
#13
Ist natürlich die Frage ob es sich wirklich um eine "ungewöhnliche Menge" handelt (solltest mal ganz schnell testen ob du dir da nicht eventuell durch falsche Konfiguration ein open relay ins Nest gelegt hast, aber das sollte eigentlich recht schnell durch hohe Server load auffallen wenn sich die Spammer drauf eingeschossen haben), oder ob es sich einfach nur um nicht konformes Verhalten/Konfiguration des Mailservers handelt (ausgehender Mailserver "localhost" anstelle des FQDN zum Beispiel).
Sende dir mal selbst eine Mail und prüfe was im Header steht, und hier kannst du testen ob dein Mailserver als open relay agiert:
http://www.spamhelp.org/shopenrelay/
 
Last edited by a moderator:

bad_brain

Registered User
#15
Code:
- Öffne die Email
- Klicke auf den kleinen Pfeil rechts oben neben "Antworten"
- Wähle aus "Original anzeigen"
Kann ich aber leider nicht verifizieren da ich noch nie Gmail benutzt habe...;)
 
#16
Hier der Code,

also

Von der main.cf
myhostname = home.test.int
mydomain = test.int

Mailadressen:
meine@mail.de= Gesendet an
absender@mail.de=Absender
Code:
Delivered-To: meine@mail.de
Received: by 10.86.72.17 with SMTP id u17cs31201fga;
        Thu, 20 Aug 2009 08:46:59 -0700 (PDT)
Received: by 10.204.24.130 with SMTP id v2mr6254975bkb.33.1250783219666;
        Thu, 20 Aug 2009 08:46:59 -0700 (PDT)
Return-Path: <vu2002@test.int>
Received: from home.test.int (host245-109-dynamic.16-79-r.retail.telecomitalia.it [79.16.109.245])
        by mx.google.com with ESMTP id 11si3737499bwz.23.2009.08.20.08.46.29;
        Thu, 20 Aug 2009 08:46:59 -0700 (PDT)
Received-SPF: neutral (google.com: 79.16.109.245 is neither permitted nor denied by best guess record for domain of vu2002@test.int) client-ip=79.16.109.245;
Authentication-Results: mx.google.com; spf=neutral (google.com: 79.16.109.245 is neither permitted nor denied by best guess record for domain of vu2002@test.int) smtp.mail=vu2002@test.int
Received: by home.test.int (Postfix, from userid 33)
	id 4222557E886; Thu, 20 Aug 2009 13:30:16 +0200 (CEST)
To: meine@mail.de
Subject: Test
From: absender@mail.de
Message-Id: <20090820113016.4222557E886@home.test.int>
Date: Thu, 20 Aug 2009 13:30:16 +0200 (CEST)

Hallo, Inhalt der Mail hier
 

bad_brain

Registered User
#17
Ist halt ziemlich witzlos die Hostnamen rauszunehmen, weil so kann ich nix dazu sagen. Am Besten du überprüfst mal ob sich Hostname und IP korrekt auflösen lassen, MX Record richtig gesetzt ist, etc...
 
#18
oO.... in Google Bulk steht, dass Mails von Servern mit Dynamischen IP's meistens als Spam erkannt werden........

IP-Adresse lässt sich korreft auflösen!
 
#19
Jetzt funktioniert es, aber nur dann, wenn ich als Absender eine nicht Gmail-Emailadresse als Absender eintrage!

Weiß jemand, woran das liegt?
 
Top