• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

POP3 unter IPV6

ludwigklr

New Member
Hallo, ich habe einen Raspiberry Server mit Debian 11.
Dort läuft ein solid-pop3d und stunnel4. Auf Port 110 lauscht der solid3d aber leider nur auf ipv4
der stunnel4 lauscht auf port 995 pop3s und übersetzt nach port 110. Das klappt auch für ipv4 und ipv6 bestens
Nur der port 110 wird nicht auf ipv6 bedient wie netstat -an |grep ^tcp kundtut.
Wie kriege ich ipv6 und port 110 pop3 zusammen?
 
Hallo /etc/spop3d.conf

Code:
/* Configuration file for Solid POP3 */

<Global>
    MailDropName    "/var/mail/%s"
    MailDropType    mailbox
    LogStatistics   no
</Global>

/*
  See also:
    /usr/share/doc/solid-pop3d/examples/
     and the spop3d.conf(5) manpage
*/
 
Hmm...Laut Manpage-> https://manpages.ubuntu.com/manpages/trusty/man5/spop3d.conf.5.html
fehlt da noch ein VirtualHost Block...

Ich kann es nicht testen, da ich diese Software nicht einsetze und mein Mailserver auch garkein POP3 mehr unterstützt.
Hallo,

kann ich auch nicht glauben da unter ipv4 ja auf post 110 gelauscht wird ohne das VirtualHosts vorhanden sind.

Ich habe es aber trotzdem probiert und ipv6 Adressen eingetragen hat aber keine Änderung gebracht es wird auch
damit nicht auf ipv6 port 110 gelauscht.
 
Ich hab mal fix eine lokale VM mit Debian 11 aufgesetzt, solid-pop3d installiert, die Konfig so angepaßt:

Code:
/* Configuration file for Solid POP3 */

<Global>
        MailDropName    "/var/mail/%s"
        MailDropType    mailbox
        LogStatistics   no
</Global>


# IPv4 und IPv6 aktivieren
listen_ipv4 = yes
listen_ipv6 = yes
und getestet:
Code:
root@debian11:~# netstat -tulpen | grep 110
tcp6       0      0 :::110                  :::*                    LISTEN      0          13102      819/solid-pop3d
root@debian11:~#


BTW:
Rein aus Neugier, warum setzt man heutzutage überhaupt noch POP3 ein...?
 
Last edited:
Ich hab mal fix eine lokale VM mit Debian 11 aufgesetzt, solid-pop3d installiert, die Konfig so angepaßt:

Code:
/* Configuration file for Solid POP3 */

<Global>
        MailDropName    "/var/mail/%s"
        MailDropType    mailbox
        LogStatistics   no
</Global>


# IPv4 und IPv6 aktivieren
listen_ipv4 = yes
listen_ipv6 = yes
und getestet:
Code:
root@debian11:~# netstat -tulpen | grep 110
tcp6       0      0 :::110                  :::*                    LISTEN      0          13102      819/solid-pop3d
root@debian11:~#


BTW:
Rein aus Neugier, warum setzt man heutzutage überhaupt noch POP3 ein...?
Hallo,

ich habe noch einige Sachen getestet. Deine Vorschläge haben leider keine Besserung gebracht. Für mich
sieht es so aus das nur auf mit einer Adresse also ipv6 oder ipv4 auf dem Port 995 gelauscht wird. Wenn ich
accept = :::995 in /etc/stunnel/stunnel.conf auskommentiere wird nicht mehr auf ipv6 gelauscht sondern
auf ipv4

pop3 auf ipv4 und ipv6 habe ich durch Einträge in inet.conf hinbekommen


Code:
/etc/inetd.conf

pop3    stream    tcp6    nowait    root.mail    /usr/sbin/tcpd    /usr/sbin/solid-pop3d
pop3    stream    tcp4    nowait    root.mail    /usr/sbin/tcpd    /usr/sbin/solid-pop3d
pop3s    stream    tcp    nowait    root.mail    /usr/sbin/tcpd  /usr/bin/stunnel4

netstat -an |grep ^tcp

tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN    
tcp6       0      0 :::110                  :::*                    LISTEN

Für pop3s klappte das leider nicht.

BTW: Ich nutze POP3 weil ich alle Mails auf meinem Win10 System mit thunderbird speichere und nicht mit
IMAP alle Nachrichten auf dem Server halte.
 
So ich habe eine Lösung gefunden mit der POP3 und POP3S auf ipv4 und ipv6 parallel laufen

Code:
/etc/inedt.conf

#:MAIL: Mail, news and uucp services.
pop3    stream    tcp6    nowait    root.mail    /usr/sbin/tcpd    /usr/sbin/solid-pop3d
pop3    stream    tcp4    nowait    root.mail    /usr/sbin/tcpd    /usr/sbin/solid-pop3d
995    stream    tcp4    nowait    root.mail    /usr/sbin/tcpd  /usr/bin/stunnel4
995    stream    tcp6    nowait  root.mail    /usr/sbin/tcpd  /usr/bin/stunnel4

netstat -an |grep ^tcp

tcp        0      0 0.0.0.0:995             0.0.0.0:*               LISTEN    
tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN    


tcp6       0      0 :::995                  :::*                    LISTEN    
tcp6       0      0 :::110                  :::*                    LISTEN    

und noch den Autostart von stunnel4 disabled
 
Last edited:
Es sah zwar gut aus funtionierte aber leider nicht. Ich habe es leider wieder zurück auf stunnel4 und in der inetd.conf den pop3s in inetd.conf deaktiviert.
 
Es sah zwar gut aus funtionierte aber leider nicht. Ich habe es leider wieder zurück auf stunnel4 und in der inetd.conf den pop3s in inetd.conf deaktiviert.
Hallo, nur nicht aufgeben.

Es geht doch man muss nur richtig lesen.

Im inetd mode darf kein accept in der stunnel.conf stehen aber der punkt connect = 110 muß vorhanden sein.


Code:
Auszug aus /etc/inetd.conf
pop3s   stream  tcp4    nowait  root  /usr/bin/stunnel stunnel /etc/stunnel/stunnel.conf
pop3s   stream  tcp6    nowait  root  /usr/bin/stunnel stunnel /etc/stunnel/stunnel.conf

Auszug aus /etc/etc/stunnel.conf
; **************************************************************************
; * Service definitions (remove all services for inetd mode)               *
; **************************************************************************

; Example SSL server mode services

;[pop3s]

;accept = :::995
connect = 110

Auszug aus netstat -an mail betreffend

tcp        0      0 0.0.0.0:587             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:995             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN     
tcp        0      0 0.0.0.0:465             0.0.0.0:*               LISTEN     
tcp6       0      0 :::587                  :::*                    LISTEN     
tcp6       0      0 :::995                  :::*                    LISTEN     
tcp6       0      0 :::110                  :::*                    LISTEN     
tcp6       0      0 :::25                   :::*                    LISTEN     
tcp6       0      0 :::465                  :::*                    LISTEN
War doch eine schwierige Geburt
 
Back
Top