Plesk installer Lade laufzeit erhöhen?

Shorty

Registered User
Ich habe Plesk eben neu aufgesetzt und der Installer hat gleich Probleme gemacht.

Ich habe Plesk versucht mit Folgender Anleitung zu Installieren https://docs.plesk.com/de-DE/onyx/d...on-plesk-für-linux-mit-nur-einem-klick.76444/

Aber da bekamm ich Folgenden Fehler.
Code:
ERROR: The certificate of 'autoinstall.plesk.com' is not trusted.
ERROR: The certificate of 'autoinstall.plesk.com' hasn't got a known issuer.
Normal habe ich es immer über https://get.plesk.com/ gemacht aber das ist das welches den Fehler mit dem Installer hat.
 

danton

Debian User
Sieht danach aus, als wenn auf deinem System die Zertifikate der CAs nicht installiert sind - unter Debian/Ubuntu ist es das Paket
ca-certificates
 

Shorty

Registered User
Wie kann ich die CA Zertifikate installieren meine versuche schlugen fehl.
Code:
 sudo wget -P /usr/local/share/ca-certificates/cacert.org http://www.cacert.org/certs/root.crt http://www.cacert.org/certs/class3.crt
-bash: sudo: command not found
[email protected]:~# sudo mkdir /usr/local/share/ca-certificates/extra
-bash: sudo: command not found
[email protected]:~# sudo cp root.cert.pem /usr/local/share/ca-certificates/extra/root.cert.crt
-bash: sudo: command not found
[email protected]:~# sudo update-ca-certificates
-bash: sudo: command not found
 

danton

Debian User
Du hast sudo nicht installiert. Du bist schon root und brauchst kein sudo. Du musst prüfen, ob du das Paket ca-certificates schon installiert ist und falls nicht, dieses nachholen. Außerdem wird dir das Root-Zertifikat von cacert nicht helfen, da autoinstall.plesk.com ein Zertfikat von Lets Encrypt verwendet.
Du scheinst hier wild Sachen auszuprobieren, die dir Google ausspuckt, ohne auch nur im Ansatz eine Ahnung zu haben, was du da tust. Ich bekomme immer mehr das Gefühl, dass du mit einem eigenen Server absolut überfordert bist...
 

Shorty

Registered User
Wir haben doch alle mal angefangen,ok ich bin schon länger dabei und kann mir leider nicht alles merken.Aber wie soll ich lernen und besser werden wenn ich nichts versuche.
 

nexus

Well-Known Member
Wir haben doch alle mal angefangen
Das ist einfach nur deine Ausrede für Faulheit und Lernresistenz!
Shorty
Joined Feb 4, 2006
Du bist jetzt seit über 14 Jahren(!) hier unterwegs und kannst immer noch nicht die elementarsten Meldungen:
Code:
-bash: sudo: command not found
korrekt interpretieren!

Aber wie soll ich lernen und besser werden wenn ich nichts versuche.
Die Erfahrung der letzten 14 Jahre zeigt eindeutig, daß du nicht besser werden wirst.
Also nimm dir den schon mehrfach gemachten Ratschlag endlich zu Herzen und kündige deinen Server und steig auf ein Webspacepaket um. Das ist völlig ausreichend für deine zwei Spaßforen und du brauchst dich nie wieder um administrative Sachen zu kümmern.
 

danton

Debian User
@nexus Dem kann ich nur zustimmen...
@Shorty Ich habe auch mal angefangen, aber das war daheim mit einem Zweitrechner (Virtualisierung gab es noch nicht). Außerdem übernehme ich nicht blind irgendwelche Anleitungen, die ich per Google gefunden habe. Ich schaue mir die Anleitung genau an und versuche zu verstehen, was welcher Befehl macht. Erst wenn ich verstanden habe, was da passiert, wird das ganze angewendet und dabei ggfl. an meine Umgebung adaptiert. Bezüglich deines Zertifikatsproblems habe ich dir schon um 15:01 geschrieben, welches Paket dir auf deinem System möglicherweise fehlt - den Paketmanager bedienen musst du schon selber hinbekommen.
 

GwenDragon

Registered User
Ich habe gerade mal in einer VM getstet, da gibt es das Zertifikat bei Debian 9.12 und wget holt das autoinstaller script.

Auf einem Debian Grundsystem das Zertifikat von Lets Encrypt nicht zu haben? Selbst wenn man Debian 9 nur rudimentär (über Netinst) installiert hat, ist das Zertifikat Let’s Encrypt Authority X3 vorhanden. Ich verstehe nicht wie man sowas selbst nur mit Grundkenntnissen über Linux so vermurksen kann.
 
Last edited:

Shorty

Registered User
Liegt eventuell daran ich Debian9 bei mir nur minimal installieren kann,ich weiss nicht wie ich es dann auf Debian9 full updaten kann.
 

GwenDragon

Registered User
Wie installierst du denn dein Debian 9? Das muss aber ein arg zurecht gestutzer Installer oder Image sein, wenn die keine Zertifikate haben.
 

danton

Debian User
Es gibt kein Debian Full in dem Sinne, da du nie alles installierst. Aufbauend auf ein Minimalsystem werden die Pakete mit apt installiert, die du wirklich benötigst - und auch nur die. Wenn dein Hoster in seinem Minimal-Image noch nicht mal die Zertifikate installiert haben sollte, dann musst du sie halt nachinstallieren.
 

GwenDragon

Registered User
Debian 9 kannste mit tasksel gar nicht so installieren, dass die ca-certificates fehlen. Es sei denn der Serverhoster hat ein spezielles kastriertes Image geschnürt.
Was @Shorty benutzt ist eher in des Forums Ratestube zu verfrachten oder ein Blick in die Glaskugel wird alles erhellen … ;)
 

danton

Debian User
Ich denke, es ist ein spezielles Image des Hosters, das sich komplett automatisch installiert. Wer weiss, was der da zusammengebaut hat. Als ich vor ein paar Jahren bei Strato war, war deren Debian Minimal-Image auch etwas seltsam zusammengestellt.
 

Shorty

Registered User
Ich konnte vorher im CP wählen zwischen ich sag mal Debian 9 normal und Debian 9 minimal nun gibt es leider nur noch minimal und über Google finde ich leider keine anleitung wie ich wider zu dem Normalen Debian 9 komme wo alles da ist was sollte.
 

danton

Debian User
Liest du überhaupt, was andere hier schreiben? Was habe ich oben geschrieben: Du musst die fehlenden Pakete installieren. Was bisher in dem "normalen" Debian-Image für zusätzliche Pakete drin waren, kann dir nur dein Hoster sagen und dann musst du sie von Hand installieren.
Aber das einfachste und beste ist, auf einen normalen Webspace zu wechseln.
 

Shorty

Registered User
Sorry da hast du recht,ich konnte das Problem mit hilfe des Supports meines anbieters beheben,allerdings weiss ich leider nicht genau was sie gemacht haben.
 
Top