• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

PHP-Upload ..

n0b0dy

Registered User
Hallo,

wusste jetzt nicht genau wo das Thema reinsoll. Deswegen mal unter Webserver.

Also mein Problem:

Wenn ich eine Datei über 500kb über den WebFTP von Confixx uploaden will sacht er mir immer die Datei ist schon verhanden. Genauso gehts wenn ich ein einfaches Upload script nehme. Also Größere Dateien können nicht hochgeladen werden. Nun in der Php.ini ist ein Limit von 2MB eingetragen. Dadran kanns also nicht liegen.

Da ich aber eine Community von einem Kollegen hoste der ein Script zum uploaden von Bilder hat muss ich dieses Problem lösen. Mich störts im Grunde ja nicht ;) Ich brauchs nie.
Mit seinem Scirpt werden Bilder hochgeladen (JPG) die ja auch mal Größer als 1MB sind bei 1600*1200 und werden umgewandelt zu kleineren. Jedoch muss das Große Bild natürlich erstmal up sein. Da dieses ja nicht funktioniert kann ers nur begrenzt nutzen.

Wir habens auf einem anderen Server von mir getestet und dort funktioniert es.

Also mein System:

Suse 9.0
Confixx 3 Pro
Apache 2
Php 4.3.4

Der andere Server ist genauso configuriert nur hat er PHP4.3.9 installiert.
Jedoch kann ich mir nicht vorstellen das dadran der upload scheitert.

Hat von euch jemand vielleicht ein Tipp für mich?
Wäre echt hilfreich!

greetz

n0b0dy
 
Ist das Error-Logging in der php.ini aktiviert? Wenn ja, was sagt das Apache-Errorlog zu dem Zeitpunkt? Du könntest auch deine php.ini hier mal anhängen/pasten.
 
500KB=2MB kann schon gewissenmaßen sein. Weiß jetzt nicht, wie PHP das ermittelt, aber die Daten werden ja vor der Übertragung encodiert, base64 oder sowas. Das bläht die Menge um einiges auf (immerhin werden die 8 Bit auf die im ASCII enthaltenen Buchstaben und Zahlen verteilt). Aber wie gesagt, weiß jetzt nicht, wo da PHP die Menge draus ermitteln, als dem encodierten oder danach.
 
brummfondel said:
5aber die Daten werden ja vor der Übertragung encodiert, base64 oder sowas. Das bläht die Menge um einiges auf
Es kommen etwa 1/3 der Datenmenge hinzu.

Allerdings sind 2MB zum max. hochladen sehr gering für Bildanwendungen.
Zum zweiten solltest Du Dir folgende Parameter in der php.ini genauer ansehen:
max_execution_time
max_input_time
memory_limit

Gerade Grafik-Anwendungen (z.B. runterrechnen der Bilder) brauchen viel Speicher und Ausführungszeit.

Und nicht vergessen:
Nach Änderungen der php.ini den Apache neustarten. Sonst hilft das nicht viel.

huschi.
 
Back
Top