php mail funktion

gius

New Member
Hallo,

ich betreibe für den Eigenbedarf zum ersten Mal einen vServer - dh. keine Kundenaccounts und ich will auch keinen eigenen Mailserver für den regulären Emailverkehr betreiben. Mir geht es nur darum, dass php-Installationen wie zb. Wordpress mails verschicken können. (geht derzeit nur über ein smtp plugin)

Bei meinem Webmin war exim4-light vorkonfiguriert und man kann damit immerhin die usermails lesen. Der sendmail-pfad in der php.ini ist auch korrekt mit exim verknüpft. Leider kommen keine emails von Wordpress an und es gibt auch keine Fehlermeldungen dazu.

Ich nehme an, dass irgendwas Grundlegendes an meiner Server-Installation fehlt bzw. nicht aktiviert ist. Ich habe es auch mit sSMTP als Alternative zur php-mailfunktion versucht - auch hier gibt es keine Reaktion oder Fehlermeldung. (ausser dass man die usermails nicht mehr lesen kann...)

Wo muss man den Fehler suchen?
 

TerraX

Active Member
Zuerst wäre es wichtig zu wissen, mit welcher Distribution wir es zu tun haben (da Exim vermutlich Debian o.ä.). Die Idee mit sSMTP war schon ganz in Ordnung. Hier wäre dann wichtig zu wissen, ob Exim vorher sauber deinstalliert wurde. Außerdem wäre der Inhalt der config-Datei für sSMTP hilfreich. Last but not least, die letzten 20 Einträge aus dem mail.log, wo man hoffentlich mal einen provozierten Mailversand nachvollziehen kann.
 

gius

New Member
Auf dem Server läuft Debian-60-squeeze-64-LAMP

Die mail.log enthält keine Einträge

Nachdem ich sSMTP aktiviert hatte, konnte ich die usermails nicht mehr lesen - dementsprechend könnte es natürlich sein, dass exim nicht korrekt ersetzt wurde. (ich wusste nicht dass sSMTP exim komplett ersetzten soll)

Die ssmtp-config ist wie folgt: (hatte es vorerst mit gmx getestet - habe aber auch andere provider)

root=adresse@gmx.net
mailhub=mail.gmx.net:465
UseTLS=YES
AuthUser=adresse@gmx.net
AuthPass=XXX
FromLineOverride=NO
rewriteDomain=adresse@gmx.net
hostname=hostname (ohne .de)
 

TerraX

Active Member
Gib nochmal den Parameter "Debug=YES" mit in die Config und teste das ganze dann mal von der Kommandozeile "ssmtp "testing ssmtp setup" yourMail@gmail.com". Anschließend bitte Report erstatten was in den logs steht ggf. auch in das syslog schauen, ob es bei der Ausführung des Tests eine Fehlermeldung gab usw.

Das Du keine lokalen Usermails mehr lesen konntest hat eigentlich weniger mit sSMTP zu tun. Falls Du Dir unsicher bist ob Exim4 restlos entsorgt wurde: apt-get purge für Exim4- und sSMTP-Paket durchführen und sSMTP mit apt-get install nochmal sauber neu aufsetzen.

Ach ja noch zwei hoffentlich hilfreiche Links zum Thema:

http://wiki.debian.org/sSMTP

http://nixbits.net/wiki/Ssmtp
 

gius

New Member
Ich habe es erneut installiert - jetzt bekomme ich:

> ssmtp "testing ssmtp setup" adresse@gmx.com
*** glibc detected *** ssmtp: munmap_chunk(): invalid pointer: 0x00000000016cb08d ***

und danach noch ca. 100 Zeilen mit backtrace und memory map daten

------------

- hab den Fehler selbst gefunden, bei rewrite domain musste das @ raus...

ABER jetzt kommt das: ssmtp: 550 5.7.1 Sorry, your envelope sender has been denied ( http://portal.gmx.net/serverrules ) {mp010}
 
Last edited by a moderator:

TerraX

Active Member
Hmm, das ist vermutlich nen Bug, der eigentlich nicht mehr da sein sollte. Versuch mal folgende Direktive in der config entsprechend für Dich anzupassen, also auf GMX

Code:
rewriteDomain=smtp.googlemail.com:465
 

gius

New Member
dann kommt folgendes:

ssmtp: 550 5.1.8 Cannot resolve your domain {mp034}

(hab den neuen test noch nicht gemacht)
 
Top