PHP 7.1 Manuel in Plesk Obsidian Version 18.0.49?

Anzeige:
Hallo,
Ich benötige in meinem Plesk PHP 7.1 m Ich habe mit Tante Google Folgendes Gefunden.

https://docs.plesk.com/de-DE/obsidi...ng/php-management/installieren-von-php.75153/

https://docs.plesk.com/de-DE/onyx/a...ng/php-management/installieren-von-php.75153/

https://www.plesk.com/kb/support/how-to-install-remove-additional-php-versions-provided-by-plesk/

Aber über diesen Weg habe ich kein PHP 7.1 zum Installieren und eine manuelle Anleitung wie zb
Code:
apt-get update && apt-get install ca-certificates

apt install apt-transport-https lsb-release ca-zertifikate -y
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list

apt-get update
apt-get install php5.6 php5.6-fpm php5.6-cgi php5.6-mysql php5.6-xsl php5.6-xml php5.6-tidy php5.6-recode php5.6-mcrypt php5.6 -mbstring php5.6-intl php5.6-gd php5.6-curl php5.6-json php5.6-imagick php5.6-bcmath php5.6-readline php5.6-sqlite3

plesk bin php_handler --add -displayname "5.6 by sury.org" -path /usr/bin/php-cgi5.6 -clipath /usr/bin/php5.6 -phpini /etc/php/5.6/cgi/etc/ php.ini -type cgi -id "php56-cgi"
plesk bin php_handler --add -displayname "5.6 by sury.org" -path /usr/bin/php-cgi5.6 -clipath /usr/bin/php5.6 -phpini /etc/php/5.6/cgi/etc/ php.ini -type fastcgi -id "php56-fastcgi"
plesk bin php_handler --add -displayname "5.6 by sury.org" -path /usr/sbin/php-fpm5.6 -clipath /usr/bin/php5.6 -phpini /etc/php/5.6/fpm/etc/ php.ini -type fpm -service php5.6-fpm -poold /etc/php/5.6/fpm/pool.d -id "php56-fpm"
Konte ich leider nicht finden,wie kann ich PHP 7.1 nun installieren?[/Code]
 

GwenDragon

Registered User
PHP-Pakete wie 7.1, die End of Life sind werden nicht von Plesk 18 Obsidian unterstützt.

⚠️Und du kannst auch nicht einfach mal PHP 7.1 per apt install auf dein Linux installieren, damit macht du das Ganze unsicher und lädst zum Einbruch auf deinem Server ein.
Dein System, deine Verwantwortung.

Wenn du die obigen Kommandozeilen nimmst und 5.6 durch 7.1 ersetzt könnte das klappen, aber das ist alles dein Risiko.

Ohne Gewähr:
Code:
apt-get update && apt-get install ca-certificates

apt install apt-transport-https lsb-release ca-zertifikate -y
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list

apt-get update
apt-get install php7.1 php7.1-fpm php7.1-cgi php7.1-mysql php7.1-xsl php7.1-xml php7.1-tidy php7.1-recode php7.1-mcrypt php7.1 -mbstring php7.1-intl php7.1-gd php7.1-curl php7.1-json php7.1-imagick php7.1-bcmath php7.1-readline php7.1-sqlite3

plesk bin php_handler --add -displayname "7.1 by sury.org" -path /usr/bin/php-cgi7.1 -clipath /usr/bin/php7.1 -phpini /etc/php/7.1/cgi/etc/ php.ini -type cgi -id "php71-cgi"
plesk bin php_handler --add -displayname "7.1 by sury.org" -path /usr/bin/php-cgi7.1 -clipath /usr/bin/php7.1 -phpini /etc/php/7.1/cgi/etc/ php.ini -type fastcgi -id "php71-fastcgi"
plesk bin php_handler --add -displayname "7.1 by sury.org" -path /usr/sbin/php-fpm7.1 -clipath /usr/bin/php7.1 -phpini /etc/php/7.1/fpm/etc/ php.ini -type fpm -service php7.1-fpm -poold /etc/php/7.1/fpm/pool.d -id "php71-fpm"
 
Last edited:
Anzeige:
Top