PHP 5.2.3 fuer Suse 9.3 und MYSQL 4.1.22

SpiderZLS

New Member
Hi, bin die folgende Anleitung Step bye Step durchgegangen



Leider erhalte ich beim PHP5 Teil folgende Fehlermeldung

Code:
ws-work:~/php5update # rpm -Uvh *.rpm
error: Failed dependencies:
        libmysqlclient.so.15 is needed by php5-mysql-5.2.3-2
        libmysqlclient.so.15(libmysqlclient_15) is needed by php5-mysql-5.2.3-2
kann mir einer sagen welches Paket ich da noch installieren muss bzw. wo ich diese Lib. herbekomme ??
 

society

Registered User
Wie bereits in meinen Blog schon geschrieben....
Halte dich 100% am HowTo das passiert sowas nicht.
 

SpiderZLS

New Member
habe es definitiv 2x so durchgespielt hier mal ein mitschnitt

1.) mkdir mysql4update
2.) cd mysql4update
3.) wget -r -np -nH http://rpms.serversupportforum.de/suse93/mysql-4.1.22/
Anm. -1 muss ich weglassen kennt mein wget nicht ebenso muss ich dann noch ein cd suse93/mysql-4.1.22 machen ich schätze mals das kommt durch das fehlende -1

4.)rm mysql-*.src.rpm
Anm. Das löscht die Datei mysql-4.1.22-1.src.rpm

5.)rpm -Uvh *.rpm
Ausgabe:
Code:
Preparing...                ########################################### [100%]
        package mysql-client-4.1.22-1 is already installed
        package mysql-4.1.22-1 is already installed
        package mysql-shared-4.1.22-1 is already installed
        package mysql-bench-4.1.22-1 is already installed
        package mysql-debuginfo-4.1.22-1 is already installed
        package mysql-devel-4.1.22-1 is already installed
6.) cd /root
7.) mkdir tidy
8.) cd tidy
9.) wget -r -np -nH http://rpms.serversupportforum.de/suse93/libtidy/
10.) rpm -Uvh *.rpm
AUSGABE:
Code:
warning: libtidy-050517-2.1.i586.rpm: V3 DSA signature: NOKEY, key ID efb694ea
Preparing...                ########################################### [100%]
        package libtidy-050517-2.1 is already installed
        package libtidy-devel-050517-2.1 is already installed
11.) cd /root
12.) mkdir libedit
13.) cd libedit
14.) wget -r -np -nH http://rpms.serversupportforum.de/suse93/libedit/
ANM: geht so nicht da der Ordner libedit nicht vorhanden ist wurde geändert in libedit-2.10-20070302-5.1

15.) wget -r -np -nH http://rpms.serversupportforum.de/suse93/libedit-2.10-20070302-5.1/
16.) rpm -Uvh *.rpm
AUSGABE:
Code:
Preparing...                ########################################### [100%]
        package libedit-2.10.snap20070302-5.1 is already installed
        package libedit-devel-2.10.snap20070302-5.1 is already installed
   1:libedit                ########################################### [ 33%]
17.) via YAST die Pakete aspell , aspell-en sowie mm installiert
18.) cd /root
19.) mkdir php5update
20.) cd php5update
21.) wget -r -np -nH http://rpms.serversupportforum.de/suse93/php-5.2.3
22.) rm php5-debuginfo-*.i586.rpm
23.) rm php5-*.src.rpm
24.) rpm -Uvh *.rpm
AUSGABE:
Code:
Preparing...                ########################################### [100%]
   1:php5                   ########################################### [  2%]
   2:php5-pdo               ########################################### [  4%]
   3:php5-dom               ########################################### [  6%]
   4:php5-openssl           ########################################### [  7%]
   5:php5-mbstring          ########################################### [  9%]
   6:php5-zlib              ########################################### [ 11%]
   7:apache2-mod_php5       ########################################### [ 13%]
   8:php5-bcmath            ########################################### [ 15%]
   9:php5-bz2               ########################################### [ 17%]
  10:php5-calendar          ########################################### [ 19%]
  11:php5-ctype             ########################################### [ 20%]
  12:php5-curl              ########################################### [ 22%]
  13:php5-dba               ########################################### [ 24%]
  14:php5-dbase             ########################################### [ 26%]
  15:php5-devel             ########################################### [ 28%]
  16:php5-exif              ########################################### [ 30%]
  17:php5-fastcgi           ########################################### [ 31%]
/var/tmp/rpm-tmp.72152: line 6: [: missing `]'
  18:php5-ftp               ########################################### [ 33%]
  19:php5-gd                ########################################### [ 35%]
  20:php5-gettext           ########################################### [ 37%]
  21:php5-gmp               ########################################### [ 39%]
  22:php5-hash              ########################################### [ 41%]
  23:php5-iconv             ########################################### [ 43%]
  24:php5-imap              ########################################### [ 44%]
  25:php5-json              ########################################### [ 46%]
  26:php5-ldap              ########################################### [ 48%]
  27:php5-mcrypt            ########################################### [ 50%]
  28:php5-mhash             ########################################### [ 52%]
  29:php5-mysql             ########################################### [ 54%]
  30:php5-ncurses           ########################################### [ 56%]
  31:php5-odbc              ########################################### [ 57%]
  32:php5-pcntl             ########################################### [ 59%]
  33:php5-pear              ########################################### [ 61%]
  34:php5-pgsql             ########################################### [ 63%]
  35:php5-posix             ########################################### [ 65%]
  36:php5-pspell            ########################################### [ 67%]
  37:php5-readline          ########################################### [ 69%]
  38:php5-shmop             ########################################### [ 70%]
  39:php5-snmp              ########################################### [ 72%]
  40:php5-soap              ########################################### [ 74%]
  41:php5-sockets           ########################################### [ 76%]
  42:php5-sqlite            ########################################### [ 78%]
  43:php5-suhosin           ########################################### [ 80%]
  44:php5-sysvmsg           ########################################### [ 81%]
  45:php5-sysvsem           ########################################### [ 83%]
  46:php5-sysvshm           ########################################### [ 85%]
  47:php5-tidy              ########################################### [ 87%]
  48:php5-tokenizer         ########################################### [ 89%]
  49:php5-wddx              ########################################### [ 91%]
  50:php5-xmlreader         ########################################### [ 93%]
  51:php5-xmlrpc            ########################################### [ 94%]
  52:php5-xmlwriter         ########################################### [ 96%]
  53:php5-xsl               ########################################### [ 98%]
  54:php5-zip               ########################################### [100%]
hmm ist ja echt komisch habe das 2x probiert und es ging nicht nun beim 3. Versuch macht er es ...allerdings mit einer Fehlermeldung beim rpm installer von php5
Code:
17:php5-fastcgi           ########################################### [ 31%]
/var/tmp/rpm-tmp.72152: line 6: [: missing `]'
  18:php5-ftp
habe nochmal den rpm -Uvh *.rpm laufen lassen diesesmal war kein Fehler.. ;)

Sehr Merkwürdig :confused::eek:

Was jetzt noch nicht funktioniert ist PHP :(
Bei jedem aufruf will er die .php datei runterladen..... :(
 

SpiderZLS

New Member
also mysql und apache2 habe ich restartet trotzdem läuft kein PHP :(

hier der Auszug aus der error_log von Apache2

Code:
[Tue Jul 31 15:18:02 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Tue Jul 31 15:18:02 2007] [notice] Digest: generating secret for digest authentication ...
[Tue Jul 31 15:18:02 2007] [notice] Digest: done
[Tue Jul 31 15:18:02 2007] [notice] Apache/2.0.53 (Linux/SUSE) configured -- resuming normal operations
Ich sehe da keinen Fehler..... :confused::(

Aufruf von der Console her geht

php info.php

AUSGABE:
Code:
phpinfo()
PHP Version => 5.2.3

System => Linux ws-work 2.6.11.4-21.17-default #1 Fri Apr 6 08:42:34 UTC 2007 i686
Build Date => Jun  1 2007 12:41:29
 
Last edited by a moderator:

SpiderZLS

New Member
nuja wie schon geschrieben im error_log steht nur
Code:
[Tue Jul 31 15:18:02 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Tue Jul 31 15:18:02 2007] [notice] Digest: generating secret for digest authentication ...
[Tue Jul 31 15:18:02 2007] [notice] Digest: done
[Tue Jul 31 15:18:02 2007] [notice] Apache/2.0.53 (Linux/SUSE) configured -- resuming normal operations
und im access_log steht dann nur der zugriff drinn

Code:
172.16.0.152 - - [31/Jul/2007:15:37:57 +0200] "GET /cpg/ HTTP/1.1" 200 9653 "http://172.16.0.37/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.1.5) Ge
cko/20070713 Firefox/2.0.0.5"
172.16.0.152 - - [31/Jul/2007:15:38:55 +0200] "GET /cpg/index.php HTTP/1.1" 200 40832 "http://172.16.0.37/cpg/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; de;
rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5"
 

society

Registered User
Man man man. Wo ist bitte der Fehler??? Weil wenn mit PHP was nicht stimmen würde würde es angezeigt.

Was sagt:
rpm -qa | grep php
 
Last edited by a moderator:

SpiderZLS

New Member
Ich Peils auch nichtmehr... :(
muss das ev. erstnoch irgendwo in der httpd.conf oder einer sonstigen config Datei Aktiviert werden ?
Ich meine mann müsste dem Apache ja auch sagen das da nun ein PHP5 am werke ist oder ?

Der rpm -qa | grep php gibt folgendes zurück:

Code:
php5-zlib-5.2.3-1
php5-dbase-5.2.3-1
php5-hash-5.2.3-1
php5-ncurses-5.2.3-1
php5-shmop-5.2.3-1
php5-sysvshm-5.2.3-1
php5-zip-5.2.3-1
php5-5.2.3-1
php5-bz2-5.2.3-1
php5-fastcgi-5.2.3-1
php5-json-5.2.3-1
php5-pear-5.2.3-1
php5-sockets-5.2.3-1
php5-wddx-5.2.3-1
php5-openssl-5.2.3-1
php5-bcmath-5.2.3-1
php5-curl-5.2.3-1
php5-exif-5.2.3-1
php5-gettext-5.2.3-1
php5-imap-5.2.3-1
php5-mhash-5.2.3-1
php5-pcntl-5.2.3-1
php5-pspell-5.2.3-1
php5-soap-5.2.3-1
php5-sysvmsg-5.2.3-1
php5-tokenizer-5.2.3-1
php5-xmlwriter-5.2.3-1
php5-dom-5.2.3-1
apache2-mod_php5-5.2.3-1
php5-ctype-5.2.3-1
php5-devel-5.2.3-1
php5-gd-5.2.3-1
php5-iconv-5.2.3-1
php5-mcrypt-5.2.3-1
php5-odbc-5.2.3-1
php5-posix-5.2.3-1
php5-snmp-5.2.3-1
php5-suhosin-5.2.3-1
php5-tidy-5.2.3-1
php5-xmlrpc-5.2.3-1
php5-pdo-5.2.3-1
php5-calendar-5.2.3-1
php5-ftp-5.2.3-1
php5-ldap-5.2.3-1
php5-pgsql-5.2.3-1
php5-sqlite-5.2.3-1
php5-xmlreader-5.2.3-1
php5-mbstring-5.2.3-1
php5-dba-5.2.3-1
php5-gmp-5.2.3-1
php5-mysql-5.2.3-1
php5-readline-5.2.3-1
php5-sysvsem-5.2.3-1
php5-xsl-5.2.3-1
Mir ist aber eben etwas anderes Aufgefallen, und zwar fehlte in der Datei
/etc/sysconfig/apache2
der Eintrag php5 bei den APACHE_MODULES ich habe ihn nun hinzugefügt und php5 scheint nun zu funktionieren.
 
Last edited by a moderator:

society

Registered User
Dieser Eintrag sollte normalerweise Automatisch hinzugefügt werden. Komisch... bisher hatte nie jemand damit Probleme.

Aber wenns nun geht... viel spass damit ;-)
 

SpiderZLS

New Member
Danke , Danke , Danke ;) !
Nochmals vielen dank für deine Mühe und bei der Fehlersuche ;) dickes Lob an Dich für diese tolle Anleitung (auch wenn ich mich 2x verlesen habe ;) ).
 
Top