• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Performance bei VServer Max (S4Y)?!

Ghostraider

Registered User
Hallo Server-Gemeinde,

ich betreibe seit ca. 2 Jahren ein Forum (http://www.das-serienboard.de). Da mein alter VServer Host (Goldvision.de) in letzter Zeit derbe an Performance eingebusst hatte, habe ich mich nach studieren der C't für den VMax von Server4You.de entschieden, der laut C't ja gut abgeschnitten hatte.
Vor dem Umzug noch schnell die Forensoftware von phpbb 2.0.2 auf die 2.0.8 upgegradet.
Und was muss ich feststellen? Die Performance ist genauso "mies" wie bei Goldvision, wenn nicht sogar noch schlechter. Also quasi vom Regen in die Traufe.
Das Forum hat derzeit ca. 160 MB SQL und 10MB WEB Space.
Dennoch: Ein phpbb oder Datenbank Problem schließe ich mal aus, da ich das ganze Board gespiegelt lokal bei mir in meiner Testumgebung laufen haben und da rennt das ganze wie Sau.
An den Confixx/Server Einstellungen habe ich noch nichts geändert, ist also noch der Auslieferungszustand (Scripte, Admin, Reseller, User etc.).
Gibt es hier noch Möglichkeiten zum Tuning?

Was mich gerade ein wenig wundert: Ich habe den Server gerade mal angetracert:

Code:
Routenverfolgung zu das-serienboard.de [62.75.149.214]  über maximal 30 Abschnitte:

  1     1 ms     1 ms     1 ms  192.168.0.1
  2    38 ms    19 ms    19 ms  ip1.co13.infocity.de [195.127.141.1]
  3    13 ms    14 ms     9 ms  192.168.3.1
  4    31 ms    35 ms    20 ms  82.140.1.1
  5    62 ms    20 ms    21 ms  Essen.de.ALTER.NET [139.4.61.153]
  6   102 ms    89 ms    65 ms  Pos0-2.CR3.ESS2.ALTER.NET [149.227.24.17]
  7    45 ms    18 ms    22 ms  so-1-0-0.XR2.HDN1.ALTER.NET[149.227.18.33]
  8    67 ms    32 ms    52 ms  so-1-1-0.TR2.HDN2.ALTER.NET [146.188.2.62]
  9    33 ms    33 ms    44 ms  so-1-0-0.TR1.FFT1.ALTER.NET [146.188.8.194]
 10    29 ms    32 ms    21 ms  POS1-0.BR2.FFT1.ALTER.NET [146.188.6.110]
 11    31 ms    28 ms    27 ms  MCI.F-2-so230.de.lambdanet.net[146.188.68.114]
 12    30 ms    24 ms    36 ms  F-4-eth120.de.lambdanet.net [217.71.105.62]
 13    49 ms    29 ms    25 ms  D-2-pos000.de.lambdanet.net [217.71.105.29]
 14    32 ms    31 ms    29 ms  intergenia-DUS1.de.lambdanet.net[217.71.104.30]
 [B]15     *        *        *     Zeitüberschreitung der Anforderung.[/B]
 16    52 ms    27 ms    32 ms  illomat.de [62.75.149.214]

Immer ist der 15. Hop mit einer Zeitüberschreitung gesegnet! Worauf deutet das hin?
Beim Ping liege ich meist zwischen 30-50ms.

Was auch komisch ist:
Früher wurden die Icons, Backgrounds etc. beim aktualisieren der Seite, nach einem Posting etc. nicht neu geladen. Nun werden diese Sachen nicht mehr gecachet. Jedesmal werden die Sachen neu geladen. Mag sein, daß auch dies die Performance-Bremse ist. Ich habe nur keine Ahnung, wie ich das ändern könnte. :confused:

Kann man eigentlich einen IMAP4 Server installieren? Wenn ja: Wie? Welchen? :confused:

Ich hoffe Ihr könnt mir weiter helfen.

TIA,

Ghost
 
Hallo erstmal und herzlich willkommen.

Du hast aber viele Fragen auf einmal... ;)

Ghostraider said:
Immer ist der 15. Hop mit einer Zeitüberschreitung gesegnet! Worauf deutet das hin?
Das ist wahrscheinlich das Hostsystem auf dem Dein virtueller Server sein physikalisches Zuhause hat. Der läßt sich nicht anpingen.

Früher wurden die Icons, Backgrounds etc. beim aktualisieren der Seite, nach einem Posting etc. nicht neu geladen. Nun werden diese Sachen nicht mehr gecachet.
Du kannst mal versuchen rauszufinden, welche 'Lebenszeit' der Grafik mitgeschickt wird. Z.B. mit wget: Lass Dir die Headerzeilen anzeigen und such nach 'cache' oder 'expires'.
Falls Du dort nicht fündig wirst, kann man den expires-Wert bei den Grafiken durch mod_expires setzten lassen.

Kann man eigentlich einen IMAP4 Server installieren? Wenn ja: Wie? Welchen?
Welches OS hast Du denn genau (Fedora, RH, Suse)?
Falls Suse, dann such einfach im Yast->Packetinstallation nach cyrus-imap4.

huschi.
 
Huschi said:
Du kannst mal versuchen rauszufinden, welche 'Lebenszeit' der Grafik mitgeschickt wird. Z.B. mit wget: Lass Dir die Headerzeilen anzeigen und such nach 'cache' oder 'expires'.
Falls Du dort nicht fündig wirst, kann man den expires-Wert bei den Grafiken durch mod_expires setzten lassen.
Welches OS hast Du denn genau (Fedora, RH, Suse)?
Falls Suse, dann such einfach im Yast->Packetinstallation nach cyrus-imap4.

huschi.

Hi Huschi,

ich habe RH als BS. Gibt es dort auch ne Möglichkeit für IMAP4?
Kannst Du die markierten Stellen ein wenig ausführlicher beschreiben? So habe ich Null Plan was ich jetzt tun soll.
 
Ghostraider said:
ich habe RH als BS. Gibt es dort auch ne Möglichkeit für IMAP4?
Ja, schau z.B. bei rpmseek.com nach einen imap-Packet für Redhat.

Kannst Du die markierten Stellen ein wenig ausführlicher beschreiben? So habe ich Null Plan was ich jetzt tun soll.
wget: ein Programm, mit dem man http-Request ohne Browser ausführen kann.
u.a. kann man sich damit auch den HTTP-Header anzeigen lassen.

mod_expires ist ein Modul (plugin) für Apache. Es ändert/setzt den expires-Eintrag für definierte Dateien im HTTP-Header.

huschi.
 
Back
Top