[Owncloud] "/lib" kann nicht gelöscht werden

I

ianklemm

Guest
Hi,

Ich wollte gerade meine komplette Owncloud Installation löschen, jedoch ist mir aufgefallen, dass ich den Ordner "/lib" nicht löschen kann. Der Ordner ist mit den selben Rechten und Eigentümer wie die anderen versehen, dennoch geht es nicht. Ich kann alle Ordner, bis auf den "/lib" löschen. Bei dem Lib bekomme ich die Meldung "keine Berechtigung".
Eine Ahnung woran das liegt und wie ich es beheben kann?
Eingesetzt wird FCGID unter Apache 2.4


Vielen Dank!
 

Attachments

Last edited by a moderator:
I

ianklemm

Guest
Wenn ich das richtig gesehen habe, gehören die Dateien alle dem User.
 

MadMakz

Member
Klasse das man noch nicht einmal im eigenen Forum zu wissen scheint was die eigene software eigentlich macht. https://forum.owncloud.org/viewtopic.php?f=21&t=32596

Ich glaube das OC irgendwelche flags setzt. Evtl. imutable oder so. Oder es waren versteckte ordner.
Versuchs via Shell wenn möglich.

Kann mich nicht mehr erinnern. Diese überladene und sicherheitsbedenkliche Software (hauptsächlich addons) läuft schon lange nicht mehr bei mir. Und nein., pydio als alternative ist da auch nicht sehr viel besser. Ich hoffe syncthing wird es besser machen.
 
Last edited by a moderator:
I

ianklemm

Guest
Klasse das man noch nicht einmal im eigenen Forum zu wissen scheint was die eigene software eigentlich macht. https://forum.owncloud.org/viewtopic.php?f=21&t=32596

Ich glaube das OC irgendwelche flags setzt. Evtl. imutable oder so. Oder es waren versteckte ordner.
Versuchs via Shell wenn möglich.

Kann mich nicht mehr erinnern. Diese überladene und sicherheitsbedenkliche Software (hauptsächlich addons) läuft schon lange nicht mehr bei mir. Und nein., pydio als alternative ist da auch nicht sehr viel besser. Ich hoffe syncthing wird es besser machen.
Das ist ein inoffizielles Forum, aber dennoch ärgerlich. Ich kann ja nicht der einzige sein. Via shell als Root geht es, jedoch nicht via FTP als Webuser.
 

MadMakz

Member
Ich kann ja nicht der einzige sein. Via shell als Root geht es, jedoch nicht via FTP als Webuser.
Denk ich auch.
Vielleicht fällt bei denen so eine Info aber auch schon unter Enterprise-Support.
 
Last edited by a moderator:
I

ianklemm

Guest
Das ist komisch.. Via shell als "Dev" kann ich die Datei ohne Probleme löschen, via FTP als selber User funktioniert es allerdings nicht.
Ich nutze Proftpd, die Config ist nach Froxlor Vorgaben konfiguriert, wenn Bedarf besteht, poste ich sie hier gerne.
 

DeaD_EyE

Blog Benutzer
Vielleicht ist ein regex drin, der Löschoperationen zufällig auf lib/ verbindert. Poste mal einfach deine Config, dann können wir die auseinander nehmen. Was noch sein könnte, dass im Verzeichnis lib noch eine .ftpaccess Datei ist, die die Berechtigungen außerhalb der Globalen Konfiguration beschränkt. Ich habe bei meiner Owncloud installation diese Dateien aber nicht gefunden.
 
Last edited by a moderator:
I

ianklemm

Guest
Hallo,

Eine .ftpaccess konnte ich nicht finden.

Hier die proftpd.conf

Code:
#
# /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes, reload proftpd after modifications, if
# it runs in daemon mode. It is not required in inetd/xinetd mode.
# 

# Includes DSO modules
Include /etc/proftpd/modules.conf

# Set off to disable IPv6 support which is annoying on IPv4 only boxes.
UseIPv6				on
# If set on you can experience a longer connection delay in many cases.
IdentLookups			off

ServerName                     "srv.Domain.de FTP Server"
ServerType			standalone
DeferWelcome			off

MultilineRFC2228		on
DefaultServer			on
ShowSymlinks			on

TimeoutNoTransfer		600
TimeoutStalled			600
TimeoutIdle			1200

DisplayLogin                    welcome.msg
DisplayChdir               	.message true
ListOptions                	"-l"

DenyFilter			\*.*/

# Use this to jail all users in their homes 
# DefaultRoot			~

# Users require a valid shell listed in /etc/shells to login.
# Use this directive to release that constrain.
# RequireValidShell		off

# Port 21 is the standard FTP port.
Port				21

# In some cases you have to specify passive ports range to by-pass
# firewall limitations. Ephemeral ports can be used for that, but
# feel free to use a more narrow range.
# PassivePorts                  49152 65534

# If your host was NATted, this option is useful in order to
# allow passive tranfers to work. You have to use your public
# address and opening the passive ports used on your firewall as well.
# MasqueradeAddress		1.2.3.4

# This is useful for masquerading address with dynamic IPs:
# refresh any configured MasqueradeAddress directives every 8 hours
<IfModule mod_dynmasq.c>
# DynMasqRefresh 28800
</IfModule>

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances			30

# Set the user and group that the server normally runs at.
User				proftpd
Group				nogroup

# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask				022  022
# Normally, we want files to be overwriteable.
AllowOverwrite			on

# Uncomment this if you are using NIS or LDAP via NSS to retrieve passwords:
# PersistentPasswd		off

# This is required to use both PAM-based authentication and local passwords
# AuthOrder			mod_auth_pam.c* mod_auth_unix.c

# Be warned: use of this directive impacts CPU average load!
# Uncomment this if you like to see progress and transfer rate with ftpwho
# in downloads. That is not needed for uploads rates.
#
# UseSendFile			off

TransferLog /var/log/proftpd/xferlog
SystemLog   /var/log/proftpd/proftpd.log

# Logging onto /var/log/lastlog is enabled but set to off by default
#UseLastlog on

# In order to keep log file dates consistent after chroot, use timezone info
# from /etc/localtime.  If this is not set, and proftpd is configured to
# chroot (e.g. DefaultRoot or <Anonymous>), it will use the non-daylight
# savings timezone regardless of whether DST is in effect.
#SetEnv TZ :/etc/localtime

<IfModule mod_quotatab.c>
QuotaEngine on
</IfModule>

<IfModule mod_ratio.c>
Ratios off
</IfModule>


# Delay engine reduces impact of the so-called Timing Attack described in
# http://www.securityfocus.com/bid/11430/discuss
# It is on by default. 
<IfModule mod_delay.c>
DelayEngine on
</IfModule>

<IfModule mod_ctrls.c>
ControlsEngine        off
ControlsMaxClients    2
ControlsLog           /var/log/proftpd/controls.log
ControlsInterval      5
ControlsSocket        /var/run/proftpd/proftpd.sock
</IfModule>

<IfModule mod_ctrls_admin.c>
AdminControlsEngine off
</IfModule>

#
# Alternative authentication frameworks
#
#Include /etc/proftpd/ldap.conf
Include /etc/proftpd/sql.conf

#
# This is used for FTPS connections
#
#Include /etc/proftpd/tls.conf

#
# Useful to keep VirtualHost/VirtualRoot directives separated
#
#Include /etc/proftpd/virtuals.conf

# A basic anonymous configuration, no upload directories.

# <Anonymous ~ftp>
#   User				ftp
#   Group				nogroup
#   # We want clients to be able to login with "anonymous" as well as "ftp"
#   UserAlias			anonymous ftp
#   # Cosmetic changes, all files belongs to ftp user
#   DirFakeUser	on ftp
#   DirFakeGroup on ftp
# 
#   RequireValidShell		off
# 
#   # Limit the maximum number of anonymous logins
#   MaxClients			10
# 
#   # We want 'welcome.msg' displayed at login, and '.message' displayed
#   # in each newly chdired directory.
#   DisplayLogin			welcome.msg
#   DisplayChdir		.message
# 
#   # Limit WRITE everywhere in the anonymous chroot
#   <Directory *>
#     <Limit WRITE>
#       DenyAll
#     </Limit>
#   </Directory>
# 
#   # Uncomment this if you're brave.
#   # <Directory incoming>
#   #   # Umask 022 is a good standard umask to prevent new files and dirs
#   #   # (second parm) from being group and world writable.
#   #   Umask				022  022
#   #            <Limit READ WRITE>
#   #            DenyAll
#   #            </Limit>
#   #            <Limit STOR>
#   #            AllowAll
#   #            </Limit>
#   # </Directory>
# 
# </Anonymous>

# Include other custom configuration files
Include /etc/proftpd/conf.d/
 
Last edited by a moderator:

DeaD_EyE

Blog Benutzer
Konnte jetzt auf die Schnelle nichts finden.
Schau mal in /etc/proftpd/conf.d/
Die Dateien werden im footer der Config integriert.
 
I

ianklemm

Guest
Der Ordner ist leer.
Eventuell bezieht sich dieser regex auch auf "private" Ordner.
 

DeaD_EyE

Blog Benutzer
Das mit dem Regex war eine Vermutung meinerseits. Versuch dich nicht daran aufzuhängen. Um das Problem näher untersuchen zu können, solltest du nochmals versuchen Dateien zu löschen und dann die betreffende Fehlermeldung kopieren. Von den betroffenen Datei bzw. das Verzeichnisse die Berechtigungen und den Besitzer überprüfen.

Wenn man nicht selbst davor sitzt, ist das gar nicht so einfach.
 

GwenDragon

Registered User
Last edited by a moderator:
I

ianklemm

Guest
Hi,

Laut lsof ist das Verzeichnis nicht in "Nutzung".
Der Extended Log sagt folgendes, wenn ich das Verzeichnis löschen möchte:
Code:
"DELE /lib/private/files.php" 550 9022
 
I

ianklemm

Guest
Uploaden kann ich in das Verzeichnis auch nichts.
Das selbe Problem tritt scheinbar auch bei einem gemieteten Webspace auf, der auf die selbe Software setzt.
Jemand eine Idee?
 

d4f

Müder Benutzer
Welchen genauen Fehler zeigt dein FTP-Client in seiner Log an?

FTP erlaubt in der Standardform kein rekursives Löschen, somit muss der FTP-Client jede Datei im Ordner löschen bevor ein Ordner gelöscht werden kann. Genau dieses Problem kann dadurch auftreten dass der Client Dateien (bspw .htaccess) schlicht nicht sieht oder ausblendet.
Das hat somit oft nichts mit (fehlenden) Rechten sondern schlicht einer Restriktion des FTP-Programmes zu tun.

[Edit]
Ich habe den Teil mit "Uploaden kann ich auch nicht" übersehen. Bitte stelle sicher dass im FTP-Programm der Besitzer des Ordners den anderen Ordner entspricht und die Dateiberechtigung (CHMOD) auf mindestens 755 steht, dann versuche erneut.
 
I

ianklemm

Guest
Hi,
WINSCP zeigt folgendes an:
/lib/private/files.php: Keine Berechtigung

Proftpd Extended LOG:
"DELE /lib/private/files.php" 550 9022
Es betrifft aber nicht nur diese Datei

[EDIT]

Die Rechte des Ordners sind exakt die selben, wie auf den anderen Ordnern
 
Last edited by a moderator:
I

ianklemm

Guest
Ich habe per Shell die Rechte manuell auf "777" gestellt und nochmals den Owner zu "Dev" geändert.
Dennoch kann ich es per FTP nicht löschen.
Per Shell geht es wie schon vorher wunderbar.
Eine Idee? Gerne kann jemand auch drüberschauen.
 
I

ianklemm

Guest
Also irgendwas scheint da nicht zu stimmen.
Ich kann allgemein keine "lib" Verzeichnisse hochladen, umbenennen oder löschen.
Selbst wenn ich einen leeren Ordner mit dem Namen "lib" erstelle, kann ich ihn nicht hochladen bzw löschen.
 
Top