OpenVPN keine Verbindung in anderes Netz

motte

Member
Hallo:)

Ich habe folgendes Problem.

Ich habe zuhause mein Netzwerk wie folgt aufgebaut:

Speedport Hybrid für LTE Zugang LAN1 -> LAN1 Tp-Link mit DD-WRT

Der SP macht DHCP für IPv4 und 6 und DYNDNS sowie sämtliche Portweiterleitungen zum DD-WRT .

Der DD-WRT macht WLAN AP und OpenVPN und der dd-wrt läut als Router und nicht als Gateway ( doppeltes nat)

Netz:

SP
IP 192.168.2.1 255.255.255.0 DNS 192.168.2.1

Dd-wrt
IP 192.168.2.2 255.255.255.0 GW 192.168.2.1 DNS 192.168.2.1

OpenVPN

192.168.3.0 255.255.255.0

Der SP hat eine öffentliche v4 und v6 . Der Zugriff auf das WebGUI und den OpenVPN klappt.

VPN verbindet aber ich habe keinen Zugriff auf das Netz des SP um über den VPN von außerhalb auf das webgui des SP zuzugreifen.

Wie kann ich das am besten umsetzen?
 

danton

Debian User
In der OpenVPN-Konfiguration hast du eine Route für das Netz 192.168.2.0/24 gesetzt?
Sofern der Speedport das Setzen von Routen unterstützt, würde ich außerdem beim DD-WRT auf NAT verzichten und im Speedport entsprechende Routen für die Netze des DD-WRT setzen.
 

elias5000

Site Reliability Engineer
EDIT: Das ist nicht die Lösung, da ich den ursprünglichen Post missverstanden hatte.

1. Benutze auf beiden Seiten Netze, die sich nicht überlagern (beide Netze 192.168.2.0/24 geht nicht)
2. Setze auf den Routern jewels eine Route, die Traffic für das Netz auf der anderen Seite durch das VPN routet (VPN-IP des anderen Routers als Gateway)
3. ???
4. PROFIT!
 
Last edited by a moderator:

elias5000

Site Reliability Engineer
Ach das ist alles in einem Netz und nicht ein VPN zwischen den beiden Kisten. (Vielleicht wäre "anderes Netz" besser zu formulieren gewesen).
Mach doch mal ne Zeichnung von deinem Setup. Vielleicht lässt es sich dann verstehen, wie das zusammenhängt.

Soweit ich das sehe ist das Problem, dass du zwei Netze hast, die sich überlagern. Das mit dem doppeltem NAT sollte ok gehen aber das Netz zwischen dem SpeedPort und dem TP-Link sollte eine andere Range haben als das interne Netz. Der TP-Link macht nochmal DHCP für sein eigenes internes Netz und die internen Geräte sehen nur den TP-Link.

Durch das NAT auf dem TP-Link ist es egal, ob er SpeedPort statische Routen kann. NAT bzw. Gateway-settings sollten dafür sorgen, dass alle Pakete jeweils die richtige Route finden sollten.

Mach doch 192.168.1.0/24 zwischen SpeedPort und TP-Link, 192.168.2.0/24 zwischen TP-Link und internen Geräten und 192.168.3.0/24 für das VPN. Wobei das VPN am besten was schön ungewöhnliches Bekommt, da du sonst bei Verbindung mit dem VPN in einem Netz mit der selben Range vom lokalen Netz isoliert wirst (da aller lokaler Traffic dann ins VPN geht).
 
Last edited by a moderator:

motte

Member
Also jetzt kann der Speedport Routen . Habe jetzt Telnet Verbindung und kann Routen setzen. Der Sp hört auf 192.168.2.1 , der dd-wrt hört auf 192.168.2.2 der VPN soll’ auf 192.168.3.0 laufen .

Wie müsste dann die Route vom sp zum VPN bzw dd-wrt lauten und wie vom dd-wrt zum sp?
 

danton

Debian User
Auf dem Speedport muß eine Route für 192.168.3.0/24 auf das Gateway 192.168.2.2 gesetzt werden. Der DD-WRT selbst braucht keine besonderen Routen, da der Speedport das Default-Gateway sein dürfte. In der OpenVPN-Konfigdatei brauchst du noch eine Route für das Speedport-Netz:
Code:
route 192.168.2.0 255.255.255.0
Sofern du noch weitere IP-Bereiche bei dir hast, jeweils analog verfahren.
 

motte

Member
Kannst du mir vllt noch den telnet befehl sagen für das hinzufügen?


route add -net 192.168.3.0 netmask 255.255.225.0 gw 192.168.2.1 br0

ist das der?
 

danton

Debian User
Das kommt drauf an, was der Speedport für Befehle zum Setzen einer Route per telnet kennt. Aber der von dir genannte wird nicht funktionieren, ist das falsche Gateway
 
Top