Neue php Version in Plesk regestrieren?

Hallo ich habe es nun endlisch geschaft eine andere php Version zu Installieren aber nun muss ich es ja mit Folgendem befehl in Plesk Regestrieren.
Code:
/usr/local/psa/bin/php_handler --add -displayname <NN> -path <path to php cgi> -phpini <path to php.ini> -type <php handler> -id <NN-custom>
Aber ich weiss nun nicht wo ich den Pfad für die cgi,fascgi und apache finde?
 

GwenDragon

Registered User
Du findest sie dort wo DU die PHP-Versionen installiert hast!


Beispiel (nicht finktionsfähig):
Code:
php_handler --add -id cgi56 -displayname 5.6.999 \
   -path /usr/bin/php52/php-cgi -phpini \
   /etc/php56/cgi/php.ini -type cgi 
 
php_handler --add -id fastcgi56 -displayname 5.6.999 \
   -path /usr/bin/php56/php-cgi -phpini \
   /etc/php56/cgi/php.ini -type fastcgi
Du kannst auch gern die /etc/psa/php_versions.json erweitern und mit php_handler --reread die neu einlesen..
 
Last edited by a moderator:
Vielen dank das habe ich nun hin bekommen php wurde Installiert und in Plesk regestriert,aber wenn ich es nun anwenden möchte bekomme ich nur eine Weisse Seite angezeigt u nd die error.log der Betroffenen Domain gibt zu dem Zeitpunkt einen Fehler der eigentlich Ignoriert werden kann.

Nun bin ich auf der suche was schief gelaufen ist das die php Installation nicht verwendet werden kann.
 

nexus

Well-Known Member
bekomme ich nur eine Weisse Seite angezeigt u nd die error.log der Betroffenen Domain gibt zu dem Zeitpunkt einen Fehler der eigentlich Ignoriert werden kann.
Schön, deine Logfiles (alle relevanten?) hast du also schon analysiert...:eek:

Nun bin ich auf der suche was schief gelaufen ist das die php Installation nicht verwendet werden kann.
Ohne spezifischere Infos wird das nur blindes Herumraten...
Also wie wäre es denn für den Anfang mal mit Auszügen aus den relevanten Logfiles zum Zeitpunkt des Aufrufs der entsprechenden Seite?

P.S.:
Logfileeinträge werden nicht ohne Grund geschrieben, in den meisten Fällen sollte man diese also nicht einfach ignorieren.
 
In der error.log steht zu diesem zeitpunkt.
Code:
[Wed Nov 26 15:22:33 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 15:22:34 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 15:23:01 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 15:23:01 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
Über Google habe ich Folgenden Shell-Befehl zum beheben gefunden und diesen auch ausgeführt.
Code:
# for i in `ls /usr/local/psa/var/certificates/`; do echo -n $i": "; openssl x509 -in /usr/local/psa/var/certificates/$i -subject -noout; done
Aber der fehlt ist nicht weg.
 

Joe User

Zentrum der Macht
Und was diese Warnung nun mit PHP zu tun? Richtig, gar nichts.

Du bist jetzt seit zwei Jahren im SSF registriert, betreibst mindestens ebenso lange einen Server und hast noch immer nicht gelernt wie man Logfiles liest?
Wer so lernresistent ist, der soll einen Admin bezahlen und nicht hier rumheulen. Wir haben Besseres zu tun als unsere Zeit an Lernunwillige wie Dich zu verschwenden.

Sorry, aber das muss mal gesagt werden...
 
Ich verstehe diesen vorwurf nicht,ich habe die erorr.log file nach dem Fehler durchsucht und sogar über Google nach einer Lösung gesucht die leider nicht geklappt hat den Fehler zu beheben.

Was genau kann ich nicht lesen?
 

danton

Debian User
Du solltest mal in dein PHP-Logfile schauen, ob PHP evtl. mit einem Fatal-Error aussteigt. GGfl. in deiner korrekten php.ini für die neue Version eintragen, falls noch nicht geschehen.
 

Thorsten

SSF Facilitymanagement
Staff member
Hallo!
Ich verstehe diesen vorwurf nicht,ich habe die erorr.log file nach dem Fehler durchsucht ...
Welche error.log denn? Ist das die Richtige? Mal als Hinweis:

/var/log/apache2/access.log
/var/log/apache2/error.log
/var/log/apache2/other_vhosts_access.log
/var/log/apache2/suexec.log

Plus die Logfiles der Domain, für die du die neue PHP Version installiert hast:

/var/www/vhosts/examples.com/error_log
/var/www/vhosts/examples.com/access_log
/var/www/vhosts/examples.com/proxy_access_log
/var/www/vhosts/examples.com/proxy_error_log

Plus, falls vorhanden, die zugehörigen SSL Logs.

Und du findest in keiner Datei irgendeinen relevanten Hinweis auf einen PHP Fehler?

mfG
Thorsten
 

GwenDragon

Registered User
Ob das zusätzliche PHP für die Domain wirklich beim Web-Server registriert ist, siehst du nur in deiner VHost-Konfiguration der Domain. Und je nachdem es als CGI, FastCGI registriert wurde, steht bei Fehlern garantiert auch was im Logfile.
Vielleicht solltest du einfach mal eine index.php erstellen, die nur
PHP:
<?php phpinfo(); ?>
enthält.
 

GwenDragon

Registered User
Meine Herren! Dass man das Original sichern sollte, wenn mann es noch braucht, setze ich voraus bei jemannd der einen Server besitzt.
:cool:
 
Ich habe in der richtigen error.log geschaut und da steht zum Zeitpunkt des Fehlers.
Code:
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Wed Nov 26 03:47:04 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Wed Nov 26 03:47:04 2014] [notice] Digest: generating secret for digest authentication ...
[Wed Nov 26 03:47:04 2014] [notice] Digest: done
[Wed Nov 26 03:47:04 2014] [error] python_init: Python version mismatch, expected '2.7.2+', found '2.7.3'.
[Wed Nov 26 03:47:04 2014] [error] python_init: Python executable found '/usr/bin/python'.
[Wed Nov 26 03:47:04 2014] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
[Wed Nov 26 03:47:04 2014] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
[Wed Nov 26 03:47:04 2014] [notice] mod_python: using mutex_directory /tmp 
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
[Wed Nov 26 03:47:04 2014] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Wed Nov 26 03:47:04 2014] [notice] Apache/2.2.22 (Debian) DAV/2 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.3 mod_ssl/2.2.22 OpenSSL/1.0.1e mod_perl/2.0.7 Perl/v5.14.2 configured -- resuming normal operations
In der info.php steht nur die PHP Version die mit dem Server Installiert wurde.
http://www.wbb-support.eu/info.php

Ich vermute das ich bei der Regestrierung etwas Falsch gemacht habe oder Vergessen.
 
Ja die Anleitung kenne ich und danach habe ich es auch gemacht über Shell mit Putty und mir wurde auch angezeigt das das Regestrieren in Plesk erfolgreich war,aber etwas muss ja schief gelaufen sein weil ja das Problem mit der Weissen Seite ist wenn ich die Neue PHP Version anwenden möchte.
 
Eine Weiße Seite deutet oft auf einen PHP Fehler hin. Diese PHP Fehler findest du nicht im Apache error.log. Du solltest mal im PHP Error Log nachsehen was das Problem ist oder du schaltest display_errors in deiner PHP ini vorübergehend ein. Dann müsste es direkt im Browser angezeigt werden was schief läuft.
 

GwenDragon

Registered User
Bitte aktiviere mal das Errorlog von PHP, in dem du in der php.ini vorübergehende das änderst:
Code:
error_log = /var/log/php-scripts.log
log_errors = On
display_errors = Off
 
Last edited by a moderator:
Danke aber wo genau finde ich dir richtige php.ini für den Fall das die ich nun finde Falsch sind.
/var/www/vhosts/system/wbb-support.eu/etc/php.ini gibt es das nicht.
Code:
error_log = /var/log/php-scripts.log
log_errors = On
display_errors = Off
und in der /etc/php5/apache2/php.ini steht es schon wie Folgt drinne.
Code:
error_log = php_errors.log
log_errors = On
display_errors = Off
Ich habe aber nun mal zum Testen in der php.ini folgendes geändert.
Code:
error_log = php_errors.log
ersetzt mit
Code:
error_log = /var/log/php-scripts.log
und
Code:
display_errors = Off
mit
Code:
display_errors = on
aber leider kein Fehler,die Seite bleibt einfach nur weiß.
 

nexus

Well-Known Member
@All: Sorry für das nun folgende Off-Topic :)

Ich hab mir mal die Seite wbb-support.eu angeschaut. Du betreibst bzw. hostest eine Seite, die Support zum WBB bieten soll und scheiterst (wie in diesem Thread zu lesen ist) an einem WBB-Plugin? :eek:

Davon mal abgesehen finde ich auf der Seite kein Impressum.
Und die Versionsangabe des Boards
Forensoftware: Burning Board® 3.9.9, entwickelt von WoltLab® GmbH
ist ja wohl ein Witz...
 
Top