neue Festplatte mit ext4-formatieren geht nicht

biertragl

Member
Hallo zusammen.

Habe Debian 9 auf ner VM unter ESXi am laufen. Eben habe ich eine neue Festplatte zugewiesen mit 250GB speicher,
jedoch kann ich die irgendwie nicht als ext4-formatieren. Bin wie folgt vorgegangen:

Festplatte über fdisk partitioniert (fdisk /dev/sdb -> n -> primary -> 1 -> write), danach mit "mkfs.ext4 /dev/sdv1" formatiert, folgende
Ausgabe erscheint:

1553167083055.png

1553167167773.png

1553167238193.png

Was mache ich hier falsch?
 

marce

Active Member
Aus dem Kopf heraus: Bei fdisk den richtigen Partition-Type angeben / auswählen (Linux anstatt DOS).
 

greystone

Member
Nach der Partitionierung entweder rebooten oder

Code:
partprobe /dev/sdb
ausführen, sonst verwendet der kernel evtl. noch die alte Partitionstabelle(eigentlich nur, wenn die Partition in Benutzung ist). partprobe ist im Paket parted enthalten
 

biertragl

Member
Aus dem Kopf heraus: Bei fdisk den richtigen Partition-Type angeben / auswählen (Linux anstatt DOS).
Hab jetzt mal eine neue Partition erstellt. Angezeigt wird auch Typ 83 Linux, wird auch so angezeigt - allerdings geht keine Formatierung
mit ext4... in ESXi wurde die ganz normal als "neue Festplatte" erstellt uund in die VM eingebunden.

1553170209804.png

1553169954443.png

1553169980755.png

1553170012089.png
 

biertragl

Member
Nach der Partitionierung entweder rebooten oder

Code:
partprobe /dev/sdb
ausführen, sonst verwendet der kernel evtl. noch die alte Partitionstabelle(eigentlich nur, wenn die Partition in Benutzung ist). partprobe ist im Paket parted enthalten
auch damit ändert sich leider nichts... :-(
 
Top