• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

nach spamassassin kein smtp-versand per thunderbird?

Nintendist

Registered User
Hi
habe nach dem Tutorial sehr erfolgreich Spamassassin auf meinem vserver (s4y, suse 9) installiert. Bin seit dem (etwa 2 Tage) sehr viel entspannter, wenn ich meine Postfächer abrufe.

Aber heute wollte ich eine Mail über Thunderbird (1.0.2) versenden, dies schlug jedoch fehl mit der Meldung:

"Die Nachricht konnte nicht versendet werden, weil keine Verbindung mit dem SMTP-Server mail.<meinedomain> hergestellt werden konnte. Der Server ist entweder nicht verfügbar oder lehnt SMTP-Verbindungen ab."

Am Mailprogramm wurde nichts geändert, ebenso funktioniert der Mailversand über das Webmail-Interface.

Bin nicht gerade sehr vertraut mit der Unix-Umgebung, daher fragt einfach nach, wenn ihr mehr Infos braucht.

Nachtrag: Mailabruf klappt ohne weiteres (über Thunderbird und WebMail). Ich vermute einfach, dass es an einer fehlerhaften Spamassassin-Einstellung liegt, da dies die einzige Änderung am Server ist, die zwischen dem letzten, erfolgreichen Mail-Versand und heute liegt.
 
Last edited by a moderator:
Nach einigem Googeln konnte ich das problem zwar immer noch nicht lösen, hab aber folgende Meldung in der mail.err gefunden

Code:
Apr 24 20:23:32 vs156072 smtp[32611]: j3OINWSS032611: Milter (spamassassin): local socket name /var/spamd/spamass-milter.sock unsafe

Sagt dies jemandem was? Und hat dies mit meinem sturen SMTP-Server zu tun?
 
Nintendist said:
"... Der Server ist entweder nicht verfügbar oder lehnt SMTP-Verbindungen ab."
Schon mal nachgesehen, ob sendmail überhaupt läuft?

ebenso funktioniert der Mailversand über das Webmail-Interface.
Das sagt nun mal rein gar nichts, da hierbei der Schritt über den eigenen SMTP-Server wegfällt.

huschi.
 
Huschi said:
Schon mal nachgesehen, ob sendmail überhaupt läuft?

sendmail läuft...

Huschi said:
Das sagt nun mal rein gar nichts, da hierbei der Schritt über den eigenen SMTP-Server wegfällt.
wieder was gelernt ;)

Mittlerweile scheine ich das Problem weiter eingrenzen zu können. Wenn ich die Original sendmail.cf wieder hochlade und sendmail neu starte, funktioniert der Mailversand per smtp, dafür wird kein Spam gefiltert.

Was mich beim compillieren per maike -C /etc/mail gewundert hat, war die Ausgabe

nothing to be done for 'all'

zwischen dem "now entering..." / "now leaving..." Output.
 
Hi,

hast Du vorher das Zeugs schonmal kompiliert? Das würde "nothing to be done" erklären. Um alles neu zu machen sollte man vorher "make clean" ausführen, das räumt den schon kompilierten Kram weg.

Cheers

tcs
 
Die Meldung nothing to be dine for 'all' bestand von Anfang an.

Der Aufruf von 'make clean' erzeugt diese Ausgabe:

*** No rule to make target 'clean'.Stop

Ich rufe das make clean im /etc/mail Ordner auf.
 
Vergiss 'make clean' für diesen Fall.
Hattest Du bereits eine Datei /etc/mail/sendmail.mc oder hast Du eine andere bearbeitet (z.B. linux.mc) ?
Exisitiert eine Datei /etc/mail/Makefile ?

huschi.
 
Mittlerweile hab ich einen neuen Anlauf gestartet.

Vserver neu installieren lassen
Tutorial nochmal gemacht
um ganz sicher zu gehen alle Änderungen mi vi gemacht

Das Ergebnis:
Ich kann immer noch keine Mail per smtp versenden, allerdings bekomme ich eine neue Meldung beim "make -C /etc/mail":

vs156072:/etc/mail # make -C /etc/mail
make: Entering directory `/etc/mail'
Rebuilding /etc/aliases.db.
sendmail -bi
/etc/aliases: 40 aliases, longest 10 bytes, 465 bytes total
test -e /etc/aliases.db && touch /etc/aliases.db
chmod --reference=/etc/aliases /etc/aliases.db
make: Leaving directory `/etc/mail'
 
Der make klingt doch richtig gut. ;)

Lautet der Fehler im maillog immer noch 'local socket name /var/spamd/spamass-milter.sock unsafe'?

Wie sehen die Benutzerrechte von /var/spamd/spamass-milter.sock aus?
Existiert die Datei überhaupt?

huschi.
 
Lautet der Fehler im maillog immer noch 'local socket name /var/spamd/spamass-milter.sock unsafe'?
Nein, nun steht aber in der mail.info folgendes:
Code:
May  7 13:03:17 vs156072 smtp[7424]: j47B3GYO007424: pD902FA44.dip.t-dialin.net [217.2.250.68] did not issue MAIL/EXPN/VRFY/ETRN during connection to stdin

Wie sehen die Benutzerrechte von /var/spamd/spamass-milter.sock aus?
Code:
srwxr-xr-x    1 root     root            0 May  7 12:55 spamass-milter.sock
 
did not issue MAIL/EXPN/VRFY/ETRN during connection to stdin
Das heißt, daß ein Mail-Client (ist das Deine Einwahl-Verbindung?) zwar verbindet, aber keinen gültigen Befehl absetzt.
Evtl. ist es ein Konfig-Problem mit Deinem Mail-Client?
Hast Du vieleicht SSL oder TLS eingestellt aber der Server kann es nicht?

huschi.
 
Hi,

guckst Du wieder hier: In diesem Thread hab ich was geschrieben, was genau mit Deinem Problem zusammen hängt.

Das unsafe liegt zwar an was anderem, aber linux.mc ist unsinn.

Unsafe heißt übrigens nur, daß die Datei socket-Datei von den falschen Leuten lesbar ist. Da muß nochmal der chown und chmod über das /var/spamd drüber. Dann denn spamd und spamass-milter nochmal durchstarten, dann sollte es klappen.

CU

Christoph
 
Back
Top