Munin Berechtigung fürs Web richtig setzen

TiCar

New Member
Hi,

ich habe jetzt hier schon einige Munin Threads durchforstet, bin aber leider noch nicht fündig geworden, bzw. das was ich gefunden habe führte bei mir nicht zum Erfolg.

Munin läuft soweit eigentlich, nur das ablegen im Webverz bringt eine Fehlermeldung.

Ich habe diese unter /www/pages/web/public_html/munin in ein Unterverzeichnises meines Webs gelegt, nur da hat er irgendwie keine Berechtigung :( Das munin Verzeichnis habe ich schon mit chown -R munin:munin munin geändert, genauso wie mit chmod die Berechtigungen, nur ich vermute, dass er auf das Verz. /www/pages/web/public_html keine Rechte hat und deswegen streikt. Wenn ich das Verz. in der conf wieder zurück auf das bei der Installation angelegt Verz. /www/pages/munin lege, funktioniert alles wunderbar, nur da kann ich ja leider nicht drauf zugreifen :(

Wie muss ich denn die Berechtigungen setzen, damit es funktioniert?

Gruß,
Lars
 

traced

Registered User
Hi, poste Doch bitte mal ein

Code:
ls -la /www/pages/web/public_html
und ein

Code:
ls -la /www/pages/munin
dann sehen wir gleich warum es in dem einen Verzeichnis funktioniert, und in dem anderen nicht.

Grüsse
 

Whistler

Blog Benutzer
Was spricht gegen ein
Code:
Alias /munin/ /www/pages/munin/
samt passender <Directory>-Clause und ggf. Zugriffsschutz?
 

TiCar

New Member
[root@lv-i:/home]# ls -la /www/pages/lv-i/public_html
insgesamt 88
drwxr-x--- 7 lv-i lv-i 4096 2009-10-08 00:44 .
drwxr-xr-x 9 lv-i lv-i 4096 2008-11-23 20:04 ..
drwxr-xr-x 4 lv-i lv-i 4096 2008-12-27 10:43 files
-rw-r--r-- 1 lv-i lv-i 6819 2007-12-07 19:55 _getstarted.txt
-rw-r--r-- 1 lv-i lv-i 179 2007-12-07 19:55 _.htaccess
-rw-r--r-- 1 lv-i lv-i 1844 2007-12-07 19:55 index.php
-rw-r--r-- 1 lv-i lv-i 17588 2007-12-07 19:55 _lastchanges.txt
-rw-r--r-- 1 lv-i lv-i 14207 2007-12-07 19:55 _lizenz.txt
drw-r-xr-x 3 munin munin 92 2009-10-09 00:00 munin
-rw-r--r-- 1 lv-i lv-i 7051 2007-12-07 19:55 _readme.txt
drwxr-xr-x 4 lv-i lv-i 48 2007-12-07 19:55 redaxo
drwxr-xr-x 6 lv-i lv-i 4096 2007-12-07 19:55 redaxo3_2
-rw-r--r-- 1 lv-i lv-i 87 2009-10-08 00:44 robots.txt
drwxr-xr-x 2 lv-i lv-i 4096 2009-10-01 02:27 stats
[root@lv-i:/home]#
chmod 755 hatte ich auch schon für das Verzeichnis versucht - half nix :-/
[root@lv-i:/home]# ls -la /www/pages/munin
insgesamt 32
drwxr-xr-x 3 munin munin 92 2009-10-08 04:11 .
drwxr-xr-x 40 root root 4096 2009-10-08 11:11 ..
-rw-r--r-- 1 munin munin 2555 2009-10-08 04:11 definitions.html
-rw-r--r-- 1 munin munin 1596 2009-10-09 09:10 index.html
-rw-r--r-- 1 munin munin 473 2009-10-08 04:11 logo.png
drwxr-xr-x 2 munin munin 8192 2009-10-08 04:11 lv-i.net
-rw-r--r-- 1 munin munin 3538 2009-10-08 04:11 style.css
[root@lv-i:/home]#
Das /www/pages/munin Verzeichnis selbst hat:
drwxr-xr-x 3 munin munin 92 2009-10-08 04:11 munin
@Whistler: Wie kann ich das /www/pages/munin in mein Web einbinden - so?
Alias /munin /www/pages/munin
<Directory /www/pages/lv-i/public_html/munin>
Options -Indexes FollowSymLinks
DirectoryIndex index.html
</Directory>
Zumindest scheint es so funktioniert zu haben - cool *freu* Danke für den Tipp, daran habe ich gar nicht gedacht :)
 
Last edited by a moderator:
Top