mod_rewrite funktioniert nicht

philmue95

New Member
Guten Tag,

Seit Stunden versuche ich mod_rewrite zu aktivieren.
Das geht soweit auch. Ich starte den Apache Server neu, will die CMS installation beginnen und bekomme wieder die Meldung das mod_rewrite nicht aktiviert ist.
Ich habe auch keine Dateiberechtigung, selbst wenn alles auf 777 steht.


An was kann das liegen?

Danke schonmal.
LG. Phil
 

Attachments

Last edited by a moderator:

Whistler

Blog Benutzer
Was steht in der phpinfo()? Ist die RewriteEngine für den betreffenden vHost on? Werden Dateien außerhalb des DocRoot verwendet?
 

d4f

Kaffee? Wo?
Wo kann ich das schaun?
apache2handler -> Loaded modules
Und ja, es ist geladen ;)

Hast du die entsprechende .htaccess hochgeladen?
Die Erkennung der Module durch PHP-Skripte ist nicht immer 100% korrekt sofern er keine .htaccess zum Test benutzt.
 

converge

New Member
Erlaubst Du das Überschreiben der VirtualHost-Direktiven? Falls nein werden htaccess-Dateien garnicht erst ausgewertet.

Schau mal im entsprechenden VirtualHost nach dem Eintrag:
Code:
AllowOverride Wert
Sollte dies z.B. auf None gestellt sein, muss die Rewrite-Regel direkt in der VirtualHost-Definition festgelegt werden.
 

converge

New Member
Gute Frage. Ist nicht mein Server, von daher kenne ich die Konfiguration leider nicht. Eventuell wäre jedoch der Ort /etc/apache2/sites-enabled ein guter Ort, um mit der KONSOLE mal nachzusehen.
 
Top