MariaDB Timeout beim Starten

Werner S

Member
Hallo,

ich setze mir gerade ein frischen Testsystem local auf mit Debian und MariaDB.
MariaDB ist installiert aber er lässt sich nicht starten und bricht immer mit einem Timeout ab.

systemctl status mariadb.service

Code:
* mariadb.service - MariaDB database server
   Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
   Active: failed (Result: timeout) since Wed 2018-06-06 14:39:53 UTC; 17s ago
  Process: 20177 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 20090 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=
  Process: 20088 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 20087 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
 Main PID: 20177 (code=exited, status=0/SUCCESS)

Jun 06 14:38:18 dev systemd[1]: Starting MariaDB database server...
Jun 06 14:38:20 dev mysqld[20177]: 2018-06-06 14:38:20 140499625579072 [Note] /usr/sbin/mysqld (mysqld 10.1.26-MariaDB-0+deb9u1) starting as process 20177 ...
Jun 06 14:39:50 dev systemd[1]: mariadb.service: Start operation timed out. Terminating.
Jun 06 14:39:53 dev systemd[1]: Failed to start MariaDB database server.
Jun 06 14:39:53 dev systemd[1]: mariadb.service: Unit entered failed state.
Jun 06 14:39:53 dev systemd[1]: mariadb.service: Failed with result 'timeout'.
journalctl -xe

-- Unit mariadb.service has begun starting up.
Jun 06 14:38:20 dev mysqld[20177]: 2018-06-06 14:38:20 140499625579072 [Note] /usr/sbin/mysqld (mysqld 10.1.26-MariaDB-0+deb9u1) starting as process 20177 ...
Jun 06 14:39:50 dev systemd[1]: mariadb.service: Start operation timed out. Terminating.
Jun 06 14:39:53 dev systemd[1]: Failed to start MariaDB database server.
-- Subject: Unit mariadb.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit mariadb.service has failed.
--
-- The result is failed.
Jun 06 14:39:53 dev systemd[1]: mariadb.service: Unit entered failed state.
Jun 06 14:39:53 dev systemd[1]: mariadb.service: Failed with result 'timeout'.
var/log/mysql/error.log

2018-06-06 14:38:20 140499625579072 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2018-06-06 14:38:20 140499625579072 [Note] InnoDB: The InnoDB memory heap is disabled
2018-06-06 14:38:20 140499625579072 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-06-06 14:38:20 140499625579072 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2018-06-06 14:38:20 140499625579072 [Note] InnoDB: Compressed tables use zlib 1.2.8
2018-06-06 14:38:20 140499625579072 [Note] InnoDB: Using Linux native AIO
2018-06-06 14:38:20 140499625579072 [Note] InnoDB: Using SSE crc32 instructions
2018-06-06 14:38:20 140499625579072 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2018-06-06 14:38:21 140499625579072 [Note] InnoDB: Completed initialization of buffer pool
2018-06-06 14:38:21 140499625579072 [Note] InnoDB: Highest supported file format is Barracuda.
2018-06-06 14:38:21 140499625579072 [Note] InnoDB: 128 rollback segment(s) are active.
2018-06-06 14:38:21 140499625579072 [Note] InnoDB: Waiting for purge to start
2018-06-06 14:38:21 140499625579072 [Note] InnoDB: Percona XtraDB (http://www.percona.com) 5.6.36-82.1 started; log sequence number 1616879
2018-06-06 14:38:21 140499625579072 [Note] Plugin 'FEEDBACK' is disabled.
2018-06-06 14:38:21 140498962478848 [Note] InnoDB: Dumping buffer pool(s) not yet started
2018-06-06 14:38:21 140499625579072 [Note] Server socket created on IP: '127.0.0.1'.
2018-06-06 14:38:21 140499625579072 [Note] /usr/sbin/mysqld: ready for connections.
Version: '10.1.26-MariaDB-0+deb9u1' socket: '/var/run/mysqld/mysqld.sock' port: 3306 Debian 9.1
2018-06-06 14:39:50 140499624953600 [Note] /usr/sbin/mysqld: Normal shutdown

2018-06-06 14:39:50 140499624953600 [Note] Event Scheduler: Purging the queue. 0 events
2018-06-06 14:39:50 140499025372928 [Note] InnoDB: FTS optimize thread exiting.
2018-06-06 14:39:50 140499624953600 [Note] InnoDB: Starting shutdown...
2018-06-06 14:39:51 140499624953600 [Note] InnoDB: Waiting for page_cleaner to finish flushing of buffer pool
2018-06-06 14:39:53 140499624953600 [Note] InnoDB: Shutdown completed; log sequence number 1616889
2018-06-06 14:39:53 140499624953600 [Note] /usr/sbin/mysqld: Shutdown complete
 

danton

Debian User
Es ist halt die Frage, warum der Start so lange benötigt. Du könntest versuchen, diesen Timeout im Systemd Service-File zu erhöhen (er steht auf 90 Sekunden) - am besten über den Befehl systemctl edit mariadb.service eine Override-Datei erstellen, die nur die geänderten Werte enthält.
 

Top