locale problem

vb-server

Registered User
Hallo zusammen

Hab' heute mein xubuntu neu installiert (neue SSD). Seit da macht locale Probleme, wenn ich SSH nutze. Auf meinen Servern ist en_US.UTF-8 installiert:

Code:
root@web:~# locale -a
C
C.UTF-8
en_US.utf8
POSIX

auf meinem PC:
Code:
patrick@patrickhome:~$ locale -a
C
C.UTF-8
de_CH.utf8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
POSIX


Zum Beispiel wenn ich apt-get per SSH nutze, bekomme ich den unschönen Fehler:
Code:
Can't set locale; make sure $LC_* and $LANG are correct!
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "en_US:en",
	LC_ALL = (unset),
	LC_TIME = "de_CH.UTF-8",
	LC_MONETARY = "de_CH.UTF-8",
	LC_ADDRESS = "de_CH.UTF-8",
	LC_TELEPHONE = "de_CH.UTF-8",
	LC_NAME = "de_CH.UTF-8",
	LC_MEASUREMENT = "de_CH.UTF-8",
	LC_IDENTIFICATION = "de_CH.UTF-8",
	LC_NUMERIC = "de_CH.UTF-8",
	LC_PAPER = "de_CH.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: No such file or directory

Weiss jemand gerade die Lösung? Ich war bis jetzt erfolglos... :-(

Viele Grüsse
 

vb-server

Registered User
Danke für deine Antwort. Den Link hab ich auch schon gefunden. Bei mir wären auf beiden Systemen die richtigen Locales drauf und es geht trotzdem nicht...
 
Top