• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Lets Encrypt Zertifikat wird unter PLesk nicht akzeptiert.

Mutti

Member
Hallo ihr Lieben,

mit Plesk kann ich mein LetsEncrypt Zertifikat nicht aktualisieren. (s.u. | likely firewall problem)

Domain ist ip4 und ip6 zugewiesen.

Konfiguration IP6-Tables ist

Code:
root@xxxxxx:~# ip6tables -L
Chain INPUT (policy DROP)
target     prot opt source               destination
ACCEPT     tcp      anywhere             anywhere             tcp dpt:https
ACCEPT     tcp      anywhere             anywhere             tcp dpt:http
ACCEPT     all      anywhere             anywhere

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Meldung von Plesk ist

Code:
SSL/TLS-Zertifikat konnte für example nicht ausgestellt werden.
Details:
Let's Encrypt-SSL/TLS-Zertifikat konnte nicht ausgestellt werden für example. Die Autorisierung dieser Domain ist fehlgeschlagen.
Details
Invalid response from https://acme-v02.api.letsencrypt.org/acme/authz-v3/240699069967.

Details:

Type: urn:ietf:params:acme:error:connection

Status: 400

Detail: 1xx.xx.xxx.xxx: Fetching https://www.example/.well-known/acme-challenge/7CSXLFuZnEfM42Lw_AMJrwuGXrlLPYLmwxZlTWrg7-0: Timeout during connect (likely firewall problem)

Meldung vom Portchecker ist
Code:
 2a:xxx:xxx::xxx 443 failed 2023-06-28 06:11:06
 2a:xxx:xxx::xxx 80 failed 2023-06-28 06:10:59

Mit der Konfiguration von ip6tables müsste aber soweit ich das sehe 80 und 443 offen sein.

Danke voraus.
 
Ist in Linux (Stichwort sysctl) IPv6 und IPv4 aktiviert?
Ist für die Domain denn IPv6 und IPv4 aktiviert?
Hört der Apache auf IPv4 und IPv6?
 
Antwort 1 - ist aktiv
Code:
net.ipv6.conf.all.disable_ipv6 = 0
Antwort 2 - ist aktiviert

Antwort 3

Anpingen gibt die richtige IP aus.

Für weitere Tipps, Dank voraus.
 
Wenn du von Außen (dein PC oder Tool-Website) sowohl die IPv6 als auch die IPv4 anpingen kannst, klappt wenigstens UDP.

Aber ob auch TCP Port 80 und 443 offen ist?
Schon vom PC aus mit nmap geprüft welche offen sind?

Und ob der Apache oder NGinx dran hört? Schau mal nach:
netstat -tulpen | egrep ':(443|80)'

Und prüfe mal ob dein Server sowas wie fail2ban nutzt, vielleicht hat da was geblockt. Und auch falls dein Apache mod_security aktiviert hat, da passieren Blockaden bei manche Blockregeln auch gern.
 
Hallo Gwen... er lauscht...
Code:
tcp6       0      0 :::80                   :::*                    LISTEN      0          20049      635/apache2
tcp6       0      0 :::443                  :::*                    LISTEN      0          20053      635/apache2

Fail2Ban hatte ich auch im Verdacht. Mod Security ist da nicht aktiv.

Wenn ich die AAAA EInträge entferne dann funktioniert es.

Danke wieder voraus. :)
 
Der Scan mit Nmap gibt folgendes aus.

Code:
Scanning 2xxx:xxxx:x:xxx::xxxx [65535 ports]
Discovered open port 443/tcp on 2xxx:xxxx:x:xxx::xxxx
Discovered open port 80/tcp on 2xxx:xxxx:x:xxx::xxxx

PORT    STATE  SERVICE  VERSION
25/tcp  closed smtp
80/tcp  open   http     Apache httpd
|_http-server-header: Apache
|_http-title: 400 Bad Request
443/tcp open   ssl/http Apache httpd

80 und 443 sind offen
 
Ich habes. Der u.s. Befehl war noch nötig. Funktioniert dann einwandfrei.
Danke für die Hilfe. :)

Code:
ip6tables -A INPUT -p icmpv6 -j ACCEPT
 
Back
Top