• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

lets encrypt: Keine Zertifikate mehr, limit erreicht?

Silas6473

New Member
hallo, ich habe gerade Froxlor neu eingerichtet, alles wie immer. das 1. Zertifikat für die domain und subdomains wurden erstellt, die anderen für die weiteren Domains werden aber nicht mehr erstelt... in der log stehen einige "fehler" wie :

Code:
letsencrypt Please check http://XXX.de/.well-known/acme-challenge/k3PsqZzHagJDnpKmtJK9VCM6awUzI4zeqBKc4wMmqKw - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/XXX.de\/.well-known\/acme-challenge\/k3PsqZzHagJDnpKmtJK9VCM6awUzI4zeqBKc4wMmqKw): failed to open stream: HTTP request failed! HTTP\/1.1 404 Not Found\r\n","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232}

oder

Code:
Could not get Let's Encrypt certificate for XXX.de: Verification ended with error: {"identifier":{"type":"dns","value":"XXX.de"},"status":"invalid","expires":"2017-11-18T21:15:14Z","challenges":[{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/MhOhXACQq7GA4IqvrY-osHKCkvlIOr2BYen2ZA8V6sc\/2445806636","token":"8wkKJg3ev8_LqAkuJPftGi8RkPp7NFkHFnkMPWV7150"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/MhOhXACQq7GA4IqvrY-osHKCkvlIOr2BYen2ZA8V6sc\/2445806642","token":"eKdHS73f0qGzz8U1yU4Xw-tbZQ8Sll6Sl7N-r8fph5Q"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:unauthorized","detail":"Invalid response from http:\/\/XXX.de\/.well-known\/acme-challenge\/k3PsqZzHagJDnpKmtJK9VCM6awUzI4zeqBKc4wMmqKw: \"<!DOCTYPE HTML PUBLIC \"-\/\/IETF\/\/DTD HTML 2.0\/\/EN\">\n<html><head>\n<title>404 Not Found<\/title>\n<\/head><body>\n<h1>Not Found<\/h1>\n<p\"","status":403},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/MhOhXACQq7GA4IqvrY-osHKCkvlIOr2BYen2ZA8V6sc\/2445806646","token":"k3PsqZzHagJDnpKmtJK9VCM6awUzI4zeqBKc4wMmqKw","keyAuthorization":"k3PsqZzHagJDnpKmtJK9VCM6awUzI4zeqBKc4wMmqKw.PzvldqHRngY_zmtayTbAIZIwBQQWQXjw6YOvVe0RHho","validationRecord":[{"url":"https:\/\/XXX.de\/.well-known\/acme-challenge\/k3PsqZzHagJDnpKmtJK9VCM6awUzI4zeqBKc4wMmqKw","hostname":"XXX.de","port":"443","addressesResolved":["212.224.XXX.XX"],"addressUsed":"212.224.XXX.XX","addressesTried":[]},{"url":"http:\/\/XXX.de\/.well-known\/acme-challenge\/k3PsqZzHagJDnpKmtJK9VCM6awUzI4zeqBKc4wMmqKw","hostname":"XXX.de","port":"80","addressesResolved":["212.224.XXX.XX"],"addressUsed":"212.224.XXX.XX","addressesTried":[]}]}],"combinations":[[1],[0],[2]]}

und nur bei den Domains, nicht subdomains, manchmal das :

Code:
Could not get Let's Encrypt certificate for XXX.de: No challenges received for XXX.de. Whole response: {"type":"urn:acme:error:rateLimited","detail":"Error creating new authz :: Too many failed authorizations recently.","status":429}

habe ich nur ein Limit erreicht ? muss ich einfach warten oder was ist das ? Ich meine es hat ja anfangs geklappt...
 
Last edited by a moderator:
wie kann ich denn die Zertifikate vom alten server importieren ? einfach in etc/ssl/froxlor-custom kopieren brachte nichts, froxlor hat sie gelöscht. und als Kunde eingeloggt bei "SSL Zertifikate" kann ich auch keins importieren oder so...
 
Falls das Problem noch besteht: Wenn du irgendwelche von Froxlor generierten Dateien kopierst, und verhindern möchtest, dass sie überschrieben werden, musst du den Cronjob von Froxlor deaktivieren.
 
Back
Top