KeyHelp | Web-Login in phpMyAdmin mit Passwort nicht möglich.

Mutti

Member
Hallo,

ich hatte schon mein Problem im KeyHelp Forum gepostet, da hab ich aber leider keine Hilfe bekommen.

Nach der Installation von KeyHelp kann ich mich nicht per Benutzer und Passwort in phyMyAdmin anmelden.

Laut Dokumentation finden sich die Zugangsdaten in dem File /root/keyhelp_login_data_yyyy-mm-dd_hh-mm-ss, was auch korrekt ist.

Folgende Benutzer sind angelegt

MariaDB-/MySQL-Datenbank
Benutzername: root | Nur für Zugriff über Befehlszeile
mysqladmin | Für Webzugriff

Zugriff über Konsole funktioniert auch einwandfrei, aber nicht über Browser.

Eventuell hatte jemand schon das gleiche Problem und kann helfen.

Danke voraus.
 

sbr2d2

Registered User
Bei meinen 3 Installationen läuft es. Du kannst über Konsole und dem Rootzugang testen ob der User mysqladmin existiert und zur Not das Passwort für den User auch dort ändern. Wenn der User nicht existiert kannst du denn auch einfach anlegen über die Konsole.
 

Mutti

Member
Hallo, vielen Dank.

User mysqladmin existiert. Neues Passwort setzen hat leider keinen Erfolg gebracht.

Fehlermeldung immer noch

Code:
mysqli_real_connect(): (HY000/1045): Access denied for user 'mysqladmin '@'localhost' (using password: YES)
 

mr_brain

Registered User
Die Fehlemeldung ist eine Fehlermeldung von PHP. Hast du mal versucht, dass Passwort via SSH und der mySQL-Shell zu ändern?
 

Mutti

Member
Hallo, Passwort ändern habe ich auch probiert. Ich habe auch alles nochmal neu Installiert (Testumgebung).
Wieder das gleiche Problem. :(
 

Mutti

Member
Die Rechte hab ich gerade überprüft.... sind wohl OK
Code:
MariaDB [mysql]> # SHOW GRANTS FOR 'mysqladmin'@'localhost';
+----------------------------------------------------------------------------------------------------------------------------------------------+
| Grants for mysqladmin@localhost                                                                                                              |
+----------------------------------------------------------------------------------------------------------------------------------------------+
GRANT ALL PRIVILEGES ON *.* TO 'mysqladmin'@'localhost' IDENTIFIED BY PASSWORD '*xxxxxxxxxxxxxxx' WITH GRANT OPTION |
 
Top