Kernel mix-up: Getting back to strato's kernel 5.4.0


New Member

I am using a strato vserver and tried to install wireguard.
Somehow I ended up with a kernel mix:
uname -r
but /boot lists 5.15.0 as exepected for ubuntu 22.04.
I think Stratos environment does not allow a different kernel to run so I manually installed 5.4.0 using
Now I get:
The following packages have unmet dependencies.
linux-headers-5.4.0-050400-generic : Depends: libssl1.1 (>= 1.1.0) but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
this would remove the 5.4.0 kernel.

I don't really care which kernel is installed, I would like to have a running wireguard and a correct system setup. For the last bit, I'd like to know how I can install the running version so the system appears clean again.

Help very much appreciated,

This is a great link, thanks for mentioning it, installation on ubuntu 22.04 can actually be done via package manager, so much easier. It points in the right direction.
Unfortunately due to the kernel mixup I still get:
>Unable to access interface: Protocol not supported
>RTNETLINK answers: Operation not supported
apparently the correct kernel headers are missing.
apt-get install --reinstall linux-headers-generic
>Unpacking linux-headers-generic ( over ( ...
>Setting up linux-headers-generic ( ...
instead of
5.4.0 as pointed to by uname -r.

How do I solve that?
I think Stratos environment does not allow a different kernel to run...
That's right, changing the kernel, adding certain kernel modules will not work under OpenVZ.
so I manually installed 5.4.0 using
And that's what you're trying to do. That has to fail. It is precisely this step that must now be undone. Unfortunately I cannot tell you which exact steps are necessary here.

Maybe one of the other members can help you to correctly resolve the unmet dependencies.
Strato uses OpenVZ for their linux vServers so you do not get a full virtualized hardware but a container that is controlled by the host systems linux kernel. OpenVZ has some limitations compared to full virtualisation. You cannot install your own kernel and you cannot install you own kernel extensions. They must be loaded on the host system by Strato.
Therefore you cannot install the kernel based wireguard on a Strato vServer. But there are some userspace implementations that should work as they use the tun driver for which Strato has added support on their OpenVZ hosts a few years ago. I have not works with wireguard myself but I think one of the userspace implementations is wireguard-go that is mentioned on
For the kernel implementation you will have to select another hosting firm - I am quite happy with IP-Projects (where I have 2 vServers) but PHP-Friends and Netcup are also often recommended in this forum.