Keine Emails von Monit oder Munin->554 Relay denied 4 lokale Dienste (wegen Confixx?)

Anzeige:

TimBo

Registered User
Hallo,

ich habe eine Standard Confixx-Konfiguration von Postfix mit SASL-auth, d.h. Postfix bzw. Sendmail verweigert allen außer Root den lokalen Emailversand ohne Authentifizierung. Leider auch Munin und Monit, die mir Systemnachrichten schicken sollen.

Hat jemand eine Idee, wie ich den lokalen Versand gestatte bevor ich die Postfix-Konfig platt mache?

mail.log sagt:
Mar 23 19:32:38 t1 postfix/smtpd[1868]: connect from localhost.localdomain[127.0.0.1]
Mar 23 19:32:38 t1 postfix/smtpd[1868]: NOQUEUE: reject: RCPT from localhost.localdomain[127.0.0.1]: 554 5.7.1 <t.bob@gmail.com>: Relay access denied; from=<monit@t1.greatnet.de> to=<t.bob@gmail.com> proto=SMTP helo=<t1>
Mar 23 19:32:38 t1 postfix/smtpd[1868]: lost connection after RCPT from localhost.localdomain[127.0.0.1]
Mar 23 19:32:38 t1 postfix/smtpd[1868]: disconnect from localhost.localdomain[127.0.0.1]

auth.log sagt nichts zu monit

Gruß Tim
 
Last edited by a moderator:

LinuxAdmin

Moderator
wie sehen den die Parameter smtpd_recipient_restrictions, mynetworks_style und mynetworks in /etc/postfix/main.cf aus?
 

TimBo

Registered User
postfix -n bringt
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
mailbox_command = /usr/bin/procmail
mailbox_size_limit = 0
mydestination = t1.greatnet.de, localhost.greatnet.de, , localhost
myhostname = t1.greatnet.de
mynetworks = 127.0.0.0/8
myorigin = /etc/mailname
recipient_delimiter = +
relayhost =
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtpd_use_tls = yes

Danke für die Zeit :)
 

TimBo

Registered User
Du bist der Größte! Danke!
Muss ich noch irgendwelche Sicherungsmaßnahmen durchführen?
 
Anzeige:
Top