• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Kein Mail-Versand via Perl-Script mit sendmail?

Loewenherz

Registered User
Hi,
ich habe gerade eine frischen Debian Woody Server (VPS) bei HostEurope laufen, sendmail und postfix sind bereits drauf. Allerdings musste ich feststellen, dass z.B. ein Perl-Kontaktformular sich korrekt abzuarbeiten scheint, aber leider keine eMails ankommen. Der Pfad auf /usr/sbin/sendmail im Script ist jedenfalls korrekt. Im Errorlog steht nichts. Im suexec-log wird der Zugriff vermerkt. Dann gibt es unter /var/log/ noch diverse Maillogs von Postfix, die allerdings alle vom 03.03 datieren.
An sich hatte ich nicht vor, einen kompletten Mailserver aufzusetzen, weil ich auf dem System gar keine Mailadressen, Postfächer etc. einrichten wollte. Muss ich das trotzdem tun, damit einfache Kontaktformulare oder Scripte arbeiten? Oder muss ich etwas an der Konfiguration von postfix oder sendmail drehen?
 
Loewenherz said:
Oder muss ich etwas an der Konfiguration von postfix oder sendmail drehen?
Ja, aber das ist schwerer als einfach postfix zu starten und zuzusehen, daß er nicht relayed.
Du brauchst einen lokalen MTA um mit /usr/sbin/sendmail Mails zu verschicken.
Ausserdem läufst Du gefahr, daß die Mails als Spam aussortiert werden, wenn Du sie über einen anderen SMTP-Server verschickst.

PS: sendmail ist bei Dir lediglich ein entsprechendes kompatibles Programm, welches zum Postfix-Packet gehört.

huschi.
 
Mittlerweile war ein Supportmitarbeiter auf der Kiste und seitdem läuft es - sollte wohl auch standardmässig so sein, da es bei einem vergleichbaren vServer-System ohne Probleme ging. Was er allerdings getan hat, weiss ich leider nicht.
 
Back
Top