Ich sehe nur "Index of" trotz Virtual host

RaffiRaftNix

New Member
Hallo,

ich habe wie hier erklärt meine Domain zu apache hinzugefügt und eine virtual Host Config erstellt: https://www.webhosterwissen.de/know-how/eigener-webserver/tutorial-apache-virtual-hosts-anlegen/

Diese sieht so aus:

Code:
<VirtualHost *:80>
    ServerAdmin admin@XXX.de
    ServerName XXX.de
    ServerAlias www.XXX.de
    DocumentRoot /var/www/osticket
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

<Directory /var/www/osticket/>
    AllowOverride All
</Directory>
Dann habe ich unter /var/www einen neuen Ordner namens "osticket" mit einer index erstellt und Rechte gesetzt.

Die VirtualHost Konfiguration habe ich dann geladen und apache neu gestartet. doch beim Aufruf der Domain sehe ich nur das :

Code:
Index of /
[ICO]    Name    Last modified    Size    Description
Apache/2.4.25 (Debian) Server at XXX.de Port 80
Doch wieso? mMn habe ich alles richtig gemacht. Apache ist auch alles grün:

Code:
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-05-12 19:33:52 CEST; 4min 25s ago
  Process: 13478 ExecStop=/usr/sbin/apachectl stop (code=exited, status=0/SUCCESS)
  Process: 13485 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
Main PID: 13489 (apache2)
    Tasks: 7 (limit: 4915)
   CGroup: /system.slice/apache2.service
           ├─13489 /usr/sbin/apache2 -k start
           ├─13490 /usr/sbin/apache2 -k start
           ├─13491 /usr/sbin/apache2 -k start
           ├─13492 /usr/sbin/apache2 -k start
           ├─13493 /usr/sbin/apache2 -k start
           ├─13494 /usr/sbin/apache2 -k start
           └─13495 /usr/sbin/apache2 -k start

Mai 12 19:33:52 kvm440654 systemd[1]: Starting The Apache HTTP Server...
Mai 12 19:33:52 kvm440654 apachectl[13485]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Mai 12 19:33:52 kvm440654 systemd[1]: Started The Apache HTTP Server.
was habe ich aber falsch gemacht?
 
Top