I need help with my filezilla Server

Butterbrezn

New Member
Hello,

I build a new FTP Server on my old computer and have some Problems with the connection.
Everything works fine with plain FTP but when I try to connect with FTPS It says that it cant get the recieve the directory.
It also is not working with the passive mode. Thats the log
Antwort: 425 Can't open data connection for transfer of "/"
I dont know what to do now I opened port 980-990 for FTP over TLS and passive mode as well as port 21 for plain FTP I put the ports in the passive mode settings from 980-989 and 990 is for FTP over TLS
Thanks for your help
 

Butterbrezn

New Member
@GwenDragon Die Firewall vom server habe ich testweise komplett ausgestellt und bin auf das gleiche resultat gekommen oder meinst du die firewall des empfängers/ mit dem filezilla client? Port 20 ist natürlich auf offen hatte ich oben vergessen zu erwähnen
 

Butterbrezn

New Member
Also ich habe alles eingestellt und es hat immer noch nicht richtig funktioniert als ich es dann nach tagen wiederversucht habe hat es funktioniert genau 1 mal jetzt funktioniert es wieder nicht was komisch ist weil ich nicht verstehe warum ?
Eine Idee villeicht ?
 

DjTom-i

verifizierter Anbieter
verifizierter Anbieter
Das ist ist die Standard proftpd.conf von Plesk. Ob die nun toll oder untoll ist ist Hupe.

Code:
<IfModule mod_tls.c>
        # common settings for all virtual hosts
        TLSEngine on
        TLSRequired off

        TLSLog /var/log/plesk/ftp_tls.log

        TLSRSACertificateFile /opt/psa/admin/conf/httpsd.pem
        TLSRSACertificateKeyFile /opt/psa/admin/conf/httpsd.pem

        # Authenticate clients that want to use FTP over TLS?
        TLSVerifyClient off

        # Allow SSL/TLS renegotiations when the client requests them, but
        # do not force the renegotations.  Some clients do not support
        # SSL/TLS renegotiations; when mod_tls forces a renegotiation, these
        # clients will close the data connection, or there will be a timeout
        # on an idle data connection.
        TLSRenegotiate none

        # As of ProFTPD 1.3.3rc1, mod_tls only accepts SSL/TLS data connections
        # that reuse the SSL session of the control connection, as a security measure.
        # Unfortunately, there are some clients (e.g. curl) which do not reuse SSL sessions.
        TLSOptions NoSessionReuseRequired
</IfModule>
Die drei bitte prüfen und ggf testweise setzen:
Code:
        TLSVerifyClient off
        TLSRenegotiate none
        TLSOptions NoSessionReuseRequired
EDIT: Da hats den letzen Part irgendwie nicht übermittelt.. Für den Filezilla Server selbst ist es ein Häkchen: https://www.limilabs.com/blog/ftp-tls-encrypted-data-connections-fail-ems (glaube ich.. aber müsste so sein.)
 
Last edited:

Butterbrezn

New Member
Ich konnte mit dem ersten leider nichts anfangen aber das zweite habe ich versucht und genaus so gemacht wie es dastand und das hat mir leider nichts geholfen ich würde mich über weitere Ideen freuen vielen dank für die Hilfe schon einmal im vorraus
das Problem ist ja nicht das die TLS connection nicht funktioniert die scheint sich laut protokoll immer zu aktivieren aber der Verzeichnis inhalt kann nicht empfangen werden und leider konnte ich auch nach langer Recherche nichts finden was dieses Problem löst
 

sbr2d2

Registered User
Hat der User vielleicht keine Rechte das Verzeichnis zu lesen, falsche Verzeichnis angegeben?
 

Butterbrezn

New Member
Also nach @GwenDragon s Antwort habe ich nachgedacht und Programm gewechselt da hat es dann zu WINSCP da hat es dann wieder einmal mit explizitem FTP/TLS funktioniet im aktiven Modus und ohne MLSD ich konnte in dieser sitzung auch hoch und runterladen aber als ich dann neu connected bin hatte ich wieder das ursprüngliche Problem "Verzeichnissinhalt konnte nicht empfangen werden"
 

GwenDragon

Registered User
Ich habe gerade FileZilla Server 0.9.60.2 auf Windows 10 2004 pro getestet, da werden die Ordner bei TLS 990 angezeigt, wenn ich mit Notepad++ NppFTP zugreife.
 

Butterbrezn

New Member
Status: Verbindung hergestellt, warte auf Willkommensnachricht...
Status: Initialisiere TLS...
Status: Überprüfe Zertifikat...
Status: TLS-Verbindung hergestellt.
Status: Angemeldet
Status: Empfange Verzeichnisinhalt...
Befehl: PWD
Antwort: 257 "/" is current directory.
Befehl: TYPE I
Antwort: 200 Type set to I
Befehl: PORT xxx,xxx,xxx,xx,xxx,xx
Antwort: 200 Port command successful
Befehl: MLSD
Antwort: 150 Opening data channel for directory listing of "/"
Antwort: 425 Can't open data connection for transfer of "/"
Fehler: Verzeichnisinhalt konnte nicht empfangen werden
das ist das Protokoll
 

Butterbrezn

New Member
Also ich habe mir @Joe User s Beitrag angeschaut und der hat mir leider auch nicht weitergeholfen aber ich habe gute neuigkeiten ich habe es jetzt noch einmal mit meinem Handy versucht und da hat TLS wieder funktioniert und alles war super und ging (ich konnte alles runterladen aber Fotos und videos gingen komischerweise nicht) auch nach einem reconnect hat explizites FTP over TLS ohne Probleme funktioniert was mich zum nachdenken gebracht hat das beweist nämlich das es ein client Problem ist welches ich nicht verstehe vielleicht habt ihr ja noch irgendwelche Ideen
 
Top