HP NC552SFP / Emulex OneConnect 10Gb: LLDP deaktivieren

bjo

New Member
[GELÖST] HP NC552SFP / Emulex OneConnect 10Gb: LLDP deaktivieren

Moin,

wir haben von einem Freifunk-Projekt aus einen Server bei IN-Berlin stehen, dieser soll über 2 SFP-Ports ans Community-IX angeschlossen werden.

Im Server steckt eine HP NC552SFP, die sich bei lspci 2x als Emulex OneConnect 10Gb ausweist.

Seitens Community-IX sind auf dem Switch LLDP-Pakete von MAC+1 zu sehen, die Ports haben xx:xx:xx:xx:13:88 und xx:xx:xx:xx:13:8c, die LLDP-Pakete kommen von xx:xx:xx:xx:13:89. Auf dem System selbst sind die LLDP-Pakete nicht sichtbar.

Nun haben wir per lldptool versucht, jeglichen LLDP-Foo abzuschalten, was aber keine Besserung brachte, und hbacmd in einem CentOS-chroot findet die Karte nicht. Im BIOS der Karte findet sich nichts zu LLDP, nur zu PXE, was natürlich abgeschaltet ist.

Laut einer Seite zu einer Karte, die auch das be2net Modul verwendet, lässt sich dieses Verhalten auch nicht deaktivieren:
The adapter uses the second or the MAC+1 port address for LLDP/DCBX (Link Layer Discovery Protocol)/(Data Center Bridging eXchange) link exchange. The DCBX engine is built into the network controller ASIC for FCoE and is always active although FCoE is not supported. This MAC+1 address remains constant and is not changed with OFM. The forwarding data base of the switch will show the Ethernet Base port MAC + 1 address value. A user may expect to only see the port Base MAC address. This is a potential point of confusion for a user who is unaware of the reason why the base MAC+1 address is present.
Ist somit die Karte schlichtweg nicht geeignet für einen derartigen Einsatz, da LLDP gegen die IX-Policy verstösst; oder welche Möglichkeiten, die LLDP-Pakete abzuschalten, gibt es noch?
 
Last edited by a moderator:

bjo

New Member
Habt ihr das schon durch:

http://h22208.www2.hpe.com/eginfolib/networking/docs/switches/WB/15-18/5998-8162_wb_2920_mcg/content/ch06s03.html

Ist das auch schon versucht worden: lldp admin-status disable
Ja, jedenfalls "lldptool set-lldp -i enp1s0f0 adminStatus=disabled" und eben so ein Centos-Chroot installiert, um zu schauen, ob hbacmd was ausrichten kann. hbacmd findet aber die Ports nicht:

hbacmd GetDCBParam xx-xx-xx-xx-13-8c
The specified port does not exist on the local host.
The 'h=' option must be specified to access remote ports
Sorry für das Doppelpost, wir sind da was den Kram betrifft mittlerweile etwas verzweifelt :rolleyes:

Edit: Gelöst. Man sollte im chroot auch den Management-Daemon starten, da hbacmd per TCP mit dem Daemon kommuniziert und darüber dann Parameter setzt:
bash-4.1# hbacmd GetDCBParam d4-c9-ef-76-13-88
DCBX
----
Operating Version : 0
Maximum Version : 0

Param Description Param Name Value
----------------- ---------- -------
DCBX State dcbxstate Disabled

LLDP
----
Transmit State txstate Disabled
Receive State rxstate Disabled
Transmit Port Description txportdesc Disabled
Transmit System Description txsysdesc Enabled
Transmit System Name txsysname Disabled
Transmit System Capabilities txsyscap Enabled
 
Last edited by a moderator:

Top