[Hilfe] Problem mit Update / Plesk - Debian 10

bilker

New Member
Hallo,

ich hoffe man kann mir hier weiterhelfen. Leider bin ich noch recht neu in Sachen vServer bzw. nicht so fit wie manch anderer.
Seit einigen Tagen habe ich das Problem das ich meinen Server nicht mehr richtig Updaten konnte, das Problem kam mit einem mal.
Auf meinem Server läuft Debian 10.4 (seit ca. 6 Monaten).

Aufmerksam bin ich auf den Fehler in Plesk geworden, das die Paketliste nicht abgerufen werden kann .Plesk.PNG
Ich dachte es sei eine einfache Sache und habe meinen Server manuell geupdatet und geupgradet.
Dort bekam ich dann auch Fehlermeldungen bzw. Putty2.png
Nach mehreren Suchen im Foren und im Internet, bin ich darauf gestoßen ,,sudo apt-get dist-upgrade" zu machen.
Leider schlägt dieses immer fehl und ,,Maria DB" wirft einen Fehler raus. putty3.png
Danach geht natürlich gar nichts mehr. Da ich kein IT-Administrator bin, weiß ich mir nicht anders zu helfen und spiele ein Backup von heute Morgen auf.

Meine Source List sieht wie folgt aus. Putty1.png

Ich hoffe man kann mir helfen, sofern es ein dummer Fehler ist der von mir verursacht wurde. Seht drüber hinweg :p

Gruß

Marcel
 

DjTom-i

verifizierter Anbieter
verifizierter Anbieter
- "mischmasch" aus stretch und buster Paketen bisher gehabt
- durch das "dist-upgrade" nun den buster Stand erreicht welchen von Plesk aktuell noch nicht supportet.

Befürchte das wird ein wenig Arbeit es wieder zu fixen.
 

GwenDragon

Registered User
Nach mehreren Suchen im Foren und im Internet, bin ich darauf gestoßen ,,sudo apt-get dist-upgrade" zu machen.
Damit hast du dir leider mehr kaputt gemacht.
Und Plesk läuft nicht mit Debian 10, da sind manche Debian-Pakete zu neu doer Konfigurationen inkompatibel.

Auf meinem Server läuft Debian 10.4 (seit ca. 6 Monaten).
Und Plesk lief damit noch? Schwer vorstellbar, da st nichts garantiert, dass sowas geht.

Setze deinen Server mit Debian 9 neu auf, installiere Plesk, spiele dein Plesk-Backup, das du vor dem 10er-Upgrade machtest, zurück.
Oder wenn du Debian 10 nutzen willst, verzichte auf Plesk.

Oder such dir bezahlte Hilfe hier im Forum, denn das kostet erheblich Zeit, das dann zu reparieren.
 

bilker

New Member
Danke, für die Hilfe. Ein bekannter hatte mir den Server geupdatet und sagte es läuft alles. Ich hätte alles auf Debian 9 gelassen.
Ich hab den Server zurückgesetzt und einfach ein Backup über Plesk eingerichtet.

Das hat geholfen, war zwar etwas schwierig weil man ja noch einiges umstellen muss damit Plesk Backups über 2 GB einspielt, aber nicht unmöglich. Vielen Dank für die Hilfe!
 
Top