[HILFE] Domains in confixx eingetragen aber nicht erreichbar!

hellspicker

Registered User
Hallo Leute!

Ich habe mir eine domain geholt (http://www.lose-werbung.de/)

web3 in confixx angelegt und dann kunden die domain lose-werbung.de zugeordnet!

Wenn ich jetzt aber die domain aufrufe kommt confixx und nicht die normale index.html Seite. Warum?
 
Last edited by a moderator:

DerFalk

Registered User
hellspicker said:
Hallo Leute!

Ich habe mir nen domain gehollt (http://www.lose-werbung.de/)

web3 in confixx Angelegt und denn kunden denn domain lose-werbung.de zugeortnet!

WEnn ich jetzt aber die domain aufruhfe kommt confixx und nicht die momahle index.html seite warum?

Haste ihm lose-werbung.de UND www.lose-werbung.de gegeben?
Update-Intervalle mal auf sofort-Ausführen gemacht?
stimmt die Domain-weiterleitung von dem "Domainverkäufer" auf deine IP?
 
Last edited by a moderator:

hellspicker

Registered User
ne nur ohne www. und Update-Intervalle habe ich auch gemacht! die ip kann ja nicht flasch sein sonst wörde er ja über denn domain nicht confixx öffnen oder?
 
Last edited by a moderator:

Thorsten

SSF Facilitymanagement
Staff member
Hallo Hellspicker,
versuchen wir es mal :)
Ist die Domain lose-werbung.de die einzige Domain die du auf diesem Server mit Confixx verwaltest?
Poste hier bitte mal die entsprechenden Stellen aus der Datei confixx_vhosts.conf. Dann sehen wir weiter.

mfG
Thorsten
 

hellspicker

Registered User
Habe nur die Datei confixx_vhost_conf.tmp gefunden:

#### CONFIXX APACHE VHOST FILE ####
### created Tue May 25 17:22:14 2004 ###

NameVirtualHost 62.112.153.46:80
php_admin_flag safe_mode On
php_admin_value safe_mode_exec_dir /opt/empty

UseCanonicalName Off
LogFormat "%V:#:%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\"" confixx
LogFormat "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\"" confixx2
CustomLog |/root/confixx/pipelog.pl confixx
<Directory "/opt">
<Files ~ "^\.ht">
deny from all
</Files>
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Options None
Options -FollowSymLinks -SymLinksIfOwnerMatch +Includes
</Directory>

<Directory "/opt/web2/html">
DirectoryIndex index.html index.htm index.php index.php3 index.php4
<Files ~ "\.shtml$">
deny from all
</Files>
<Files ~ "\.(wml.*|wbmp)$">
deny from all
</Files>
</Directory>

<VirtualHost 62.112.153.46:80>
DocumentRoot /opt/confixx/html/gesperrt
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName www.luckylos.de
ServerAlias luckylos.de web2.1265-1.1st-housing.de
DocumentRoot /opt/web2/html
User web2
Group apache
php_admin_value open_basedir /opt/web2/
php_admin_value upload_tmp_dir /opt/web2/phptmp/
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName bubbles.hellspicker.de
ServerAlias bubbles.serfus.de bubble.hellspicker.de bubble.serfus.de
DocumentRoot /opt/web1/html/bubble
User web1
Group apache
ScriptAlias /cgi-bin/ /opt/web1/html/cgi-bin/
php_admin_value open_basedir /opt/web1/
php_admin_value upload_tmp_dir /opt/web1/phptmp/
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName web1.1265-1.1st-housing.de
ServerAlias www.hellspicker.de hellspicker.de www.serfus.de gg.62.112.153.46
DocumentRoot /opt/web1/html
User web1
Group apache
ScriptAlias /cgi-bin/ /opt/web1/html/cgi-bin/
php_admin_value open_basedir /opt/web1/
php_admin_value upload_tmp_dir /opt/web1/phptmp/
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName www.62.112.153.46
ServerAlias 62.112.153.46 serfus.de
DocumentRoot /opt/web1/html/index.php
User web1
Group apache
ScriptAlias /cgi-bin/ /opt/web1/html/cgi-bin/
php_admin_value open_basedir /opt/web1/
php_admin_value upload_tmp_dir /opt/web1/phptmp/
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName forum.hellspicker.de
Redirect / http://www.hellspicker.de/forum
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName zeche.serfus.de
Redirect / http://www.serfus.de/zeche/
</VirtualHost>
 

Onkel

Registered User
Hallo,

kann es sein das du im
confixx_main.conf die Passwörter für die mysql User confixx und root geändert hast ?
 
S

server4downs

Guest
Onkel said:
Hallo,

kann es sein das du im
confixx_main.conf die Passwörter für die mysql User confixx und root geändert hast ?
Das würde ihm das Update-Script bei manueller Ausführung erzählen.
Mich besorgt eher folgender Satz:
Habe nur die Datei confixx_vhost_conf.tmp gefunden
Das kann ja kaum sein, sonst gingen die anderen Domains ja auch nicht mehr, da er (apache) ja die orginale Datei braucht, nicht eine.tmp-Datei.
Die confixx_vhost.conf befindet sich im selben Ordner wie die httpd.conf. Wirst du sicher finden.
 

Thorsten

SSF Facilitymanagement
Staff member
Weiterhin ist die Domain lose-werbung.de überhaupt nicht angelegt.
Apache sollte im Log Hinweise darauf hinterlassen, dass er die Datei confixx_vhost.conf nicht includieren kann.
Versuch noch mal explizit nach confixx_vhost.conf zu suchen:
find / -name confixx_vhost.conf

mfG
Thorsten
 
Last edited by a moderator:

hellspicker

Registered User
@Onkel NEIN

obs ok habe sie gefunden *G*

#### CONFIXX APACHE VHOST FILE ####
### created Tue May 25 17:22:14 2004 ###

NameVirtualHost 62.112.153.46:80
php_admin_flag safe_mode On
php_admin_value safe_mode_exec_dir /opt/empty

UseCanonicalName Off
LogFormat "%V:#:%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\"" confixx
LogFormat "%h %l %u %t \"%r\" %s %b \"%{Referer}i\" \"%{User-agent}i\"" confixx2
CustomLog |/root/confixx/pipelog.pl confixx
<Directory "/opt">
<Files ~ "^\.ht">
deny from all
</Files>
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Options None
Options -FollowSymLinks -SymLinksIfOwnerMatch +Includes
</Directory>

<Directory "/opt/web2/html">
DirectoryIndex index.html index.htm index.php index.php3 index.php4
<Files ~ "\.shtml$">
deny from all
</Files>
<Files ~ "\.(wml.*|wbmp)$">
deny from all
</Files>
</Directory>

<VirtualHost 62.112.153.46:80>
DocumentRoot /opt/confixx/html/gesperrt
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName www.luckylos.de
ServerAlias luckylos.de web2.1265-1.1st-housing.de
DocumentRoot /opt/web2/html
User web2
Group apache
php_admin_value open_basedir /opt/web2/
php_admin_value upload_tmp_dir /opt/web2/phptmp/
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName bubbles.hellspicker.de
ServerAlias bubbles.serfus.de bubble.hellspicker.de bubble.serfus.de
DocumentRoot /opt/web1/html/bubble
User web1
Group apache
ScriptAlias /cgi-bin/ /opt/web1/html/cgi-bin/
php_admin_value open_basedir /opt/web1/
php_admin_value upload_tmp_dir /opt/web1/phptmp/
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName web1.1265-1.1st-housing.de
ServerAlias www.hellspicker.de hellspicker.de www.serfus.de gg.62.112.153.46
DocumentRoot /opt/web1/html
User web1
Group apache
ScriptAlias /cgi-bin/ /opt/web1/html/cgi-bin/
php_admin_value open_basedir /opt/web1/
php_admin_value upload_tmp_dir /opt/web1/phptmp/
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName www.62.112.153.46
ServerAlias 62.112.153.46 serfus.de
DocumentRoot /opt/web1/html/index.php
User web1
Group apache
ScriptAlias /cgi-bin/ /opt/web1/html/cgi-bin/
php_admin_value open_basedir /opt/web1/
php_admin_value upload_tmp_dir /opt/web1/phptmp/
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName forum.hellspicker.de
Redirect / http://www.hellspicker.de/forum
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName zeche.serfus.de
Redirect / http://www.serfus.de/zeche/
</VirtualHost>
und das von thorsten bitte noch mal für mich über setzt *lol* verstehe da von nur "mfg" :D
 

Thorsten

SSF Facilitymanagement
Staff member
Hallo!

Gut, die Datei hast du gefunden. Ist dir beim lesen der Datei nicht aufgefallen, das dort nirgendwo ein Verweis auf die Domain lose-werbung.de zu findes ist?
Am einfachsten ist es, die Domain lose-werbung.de bzw. den entsprechenden Confixx Benutzer einmal zu löschen, warten bis das Update-Script lief (5 Minuten sollten eigentlich reichen) und dann wieder anlegen.
Nach einem weiteren Lauf des Update-Scripts sollte in der Datei confixx_vohost.conf ein Eintrag für die Domain lose-werbung.de zu finden sein. Ist dem nicht so, stimmt etwas mit deinem Confixx nicht.

mfG
Thorsten
 
S

server4downs

Guest
Läuft das Script überhaupt ordnungsgemäßt?
Führe es mal manuell aus.
Finde den Pfad zum Script, über z.B. locate:
Code:
locate confixx_updatescript.pl
und gebe ihn dann in die Shell ein. Kommt keine Meldund ist alles ok, kommt eine.. dann eben nicht. Weiteres wird die Meldung verklickern ;)
 

hellspicker

Registered User
$ locate confixx_updatescript.pl
warning: locate: could not open database: /var/lib/slocate/slocate.db: No such file or directory
warning: You need to run the 'updatedb' command (as root) to create the database.
 

Thorsten

SSF Facilitymanagement
Staff member
Hallo hellspicker!
- Als root anmelden
- updatedb eingeben
- warten ...
- warten ...
- locate confixx_updatescript.pl

mfG
Thorsten
 

hellspicker

Registered User
[[email protected] root]# locate confixx_updatescript.pl
/root/confixx/admin/scripts/confixx_updatescript.pl
/root/confixx/confixx_updatescript.pl

Geht aber immer noch nicht kann ich denn vieleicht auch per hand eintragen oder so was in der art? Brauche denn domain ja ?

währe denn web3 und nen subdomain mit dieb.lose-werbung.de bräuchte ich auch naja vielen dank schon mal!
 
Last edited by a moderator:

hellspicker

Registered User
kann ich nicht eigentlich einfach nur das mit in die datei eintragen?


<VirtualHost 62.112.153.46:80>
ServerName www.62.112.153.46
ServerAlias 62.112.153.46 lose-werbung.de
DocumentRoot /opt/web1/html/index.php
User web1
Group apache
ScriptAlias /cgi-bin/ /opt/web1/html/cgi-bin/
php_admin_value open_basedir /opt/web1/
php_admin_value upload_tmp_dir /opt/web1/phptmp/
</VirtualHost>
<VirtualHost 62.112.153.46:80>
ServerName dieb.lose-werbung.de
Redirect / http://www.lose-werbung.de/losedieb/
</VirtualHost>
oder währe das nicht möglich vieleicht kann ja jemand helfen... ...weil der domain ist mir sehr wichtig!
 

Huschi

Moderator
Staff member
hellspicker said:
kann ich nicht eigentlich einfach nur das mit in die datei eintragen?
Mit in die Datei, wäre schlecht, denn wenn Confixx dann mal läuft, wird es überschrieben.
Daher schreib es einfach ein eine neue 'meine_vhost.conf' Datei und mach am Ende der httpd.conf einen Include wie schon mit dem confixx_vhost.conf.
(Apache restart nicht vergessen)

PS: Manche hier - mit ähnlichen Probleme - haben einfach in Confixx einen neuen User angelegt, und die Domain dort verwaltet.

huschi.
 

hoffie

Registered User
hellspicker said:
[[email protected] root]# locate confixx_updatescript.pl
/root/confixx/admin/scripts/confixx_updatescript.pl
/root/confixx/confixx_updatescript.pl

Geht aber immer noch nicht kann ich denn vieleicht auch per hand eintragen oder so was in der art? Brauche denn domain ja ?
Ähm, du hast das Skript jetzt aber jetzt schon mal manuell gestartet oder?
Wenn nicht, dann /root/confixx/confixx_updatescript.pl (ich nehme mal an, dass die beiden Skripte die gleichen sind, kenne mich mit Confixx nicht aus)
 

Huschi

Moderator
Staff member
hoffie said:
(ich nehme mal an, dass die beiden Skripte die gleichen sind, kenne mich mit Confixx nicht aus)
Nein, die Scripts sind nicht zwingend das gleiche. /root/confixx/confixx_counterscript.pl startet die restlichen Scripte. Wenn man zusätzlich den Parameter 'DEBUG' übergibt, sollte er auch eine Ausgabe machen, was er macht, oder welchen Fehler er findet.

huschi.
 
Last edited by a moderator:
Top