• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

Habe Postfix zu 99% hinbekommen, aber noch ein was ist ...

Smoker

Registered User
So, mein Postfix läuft endlich wunderbar.
Ich kann per PHP Senden, es kommen die mails auch in den von Confixx angelegten Postfächern auch, die Aliase gehen.

Ich kann auch per Outlock abrufen.

So jetzt das letzte ...

Senden kann ich per Outlock nur an Adresse die auf meinem Server liegen, also ala name@smokers-board.de

An andere adressen wie hotmal sagt es mir immer ...

Die Nachricht konnte nicht gesendet werden, da einer der Empfänger vom Server nicht akzeptiert wurde. Die nicht akzeptierte E-Mail-Adresse ist "toni@tonitown.com". Betreff 'test', Konto: '-= Smoker =-', Server: 'mail.smokers-board.de', Protokoll: SMTP, Serverantwort: '554 <toni@tonitown.com>: Relay access denied', Port: 25, Secure (SSL): Nein, Serverfehler: 554, Fehlernummer: 0x800CCC79

Was kann da noch falsch sein ?

Thxx
Smoker
 
Ganz vergessen zu schreiben.

Über Webmin kann ich an ALLE adressen schicken.
Der Fehler ist nur bei Outlock via SMTP senden.

bye
Smoker
 
Hallo!
Ist der Haken 'Postausgangsserver / Dieser Server erfordert Authentifizierung' gesetzt?

mfG
Thorsten
 
Wie oben schon geschrieben ... egal ob der drin ist oder nicht, es kommt leider immer die selbe Fehlermeldung. :(

bye
Smoker
 
Hallo!
Läuft SASL?
Wie sieht es mit SSL (bei SMTP) aus?
Ist das Debian?

mfG
Thorsten
 
Ne denke das ist SuSE 9.0 auf einen Root Server mit Confixx 2003 Premium.

aber dieses Problem kenn ich momentan nicht, kannst du mir bitte deine /etc/postfix/main.cfg posten? denke da müßte der Wurm begraben sein.

Gut ich sehe aber das bei dir SSL an ist beim Postfixm,, wie hast denn das geschaft? *g
 
Ist SuSe 9.0 mit Confixx
SASL ... weis ich nicht, glaube aber nicht, denn ich habe Postfix ohne extra sachen einfach per YasT installiert, dann sendmail ausgeschalten, dann Postfix an und dann die /usr/local/confixx/admin/subs/postfix_install.pl ausgeführt.
Die soll eigentlich alles richtig vom Sendmail übernehmen und Postfix in Confixx einbauen.
Das hat es ja auch alles gemacht, bis auf das Senden via SMTP über Outlock. :(

bye
Smoker
 
Aragon said:
Gut ich sehe aber das bei dir SSL an ist beim Postfixm,, wie hast denn das geschaft? *g

Wie ich das geschaft habe, weis ich selber nicht.
Ich habe Postfixx wie folgt installiert, so kann ich jetzt auch übver Confixx POP3 Boxen erstellen und aliasse die dann aber auch funzen :) ausgenommen derzeit senden :(

  1. Über YasT Postfix installiert
  2. Sendmail über Webmin gestoppt ( NICHT gelöscht ... grund dafür kommt noch )
  3. Postfix über Webmin gestartet
  4. Dann habe ich die ( /usr/local/confixx/admin/subs/postfix_install.pl ) ausgeführt, deswegen Sendmail nicht gelöscht, denn damit stelle ich mein Confixx mit Sendmail auf Postfix um.
  5. Dann dauerte es ein paar Minuten bis Confixx seine update script durchgeführt hat ( macht es glaube alle 2 Minuten bei mir )

Das wars, dann lief es so wie es jetzt ist, aber offenbar war etwas doch nicht ganz richtig.

Hier gleich mal meine main.cf im Anhang.
Habe sie mal in .txt umbenannt, weil sonst konnte ich sie nicht anhängen.

bye
Smoker
 

Attachments

  • main.cf.txt
    26.9 KB · Views: 169
Ich habe irgendwo noch gelesen ( fällt mir eben ) ein, das man noch

Yast –i qpopper

Ausführen soll nach dem install von Postfix.
Stimmt das ?
Das habe ich nicht gemacht, weil ja im Prinzip alles lief.

Thxx
Smoker
 
das mit den qpopper würd ich lassen, da ja dein pop3 anscheindend funktioniert

also ich habe meinen Postfix damals umgestellt auf pop3 bevor smtp mit diesen Zeilen:

smtp_sasl_auth_enable = no

# smtpd_sasl_local_domain = $myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_securtity_options = noanonymous
smtpd_recipient_restrictions = permit_sasl_authenticated,
permit_mynetworks,
reject_non_fqdn_sender,
reject_non_fqdn_recipient,
reject_non_fqdn_hostname,
reject_unknown_recipient_domain,
reject_invalid_hostname,
reject_unknown_hostname,
reject_unknown_sender_domain,
reject_rbl_client,
permit_mx_backup,
reject_unauth_destination


broken_sasl_auth_clients = yes

smtpd_use_tls = no
smtp_use_tls = no

jetzt weiß ich aber nicht mehr ob ich dazu den saslauthd gebraucht habe oder nicht, argh
 
Back
Top