Gelöst: Zertifikat zum Schutz von Plesk auf Kundendomain

gBonfire

New Member
Hallo zusammen,

nachdem ich bereits das Internet leergelesen habe und ich offensichtlich zu doof bin das gefundene auf mein Problem zu mappen, hoffe ich auf euer Know-How:

Aktuelle Konstellation:
- Einen Strato v-server
- Plesk Obsidian
- Linux Ubuntu 18.02
- Eine IP V4 IP
- Eine IP V6 IP
- Domain abc.de (A-Eintrag und AAAA-Eintrag zeigen auf die gleiche IP wie der Eintrag der Domain xyz.de)
- Domain abc.de (Ist nur ein Beispiel) ist mir als admin zugeordnet
- Domain xyz.de (A-Eintrag und AAAA-Eintrag zeigen auf die gleiche IP wie der Eintrag der Domain abc.de)
- Domain xyz.de wurde einem neu angelegten Kunden/Abbonement (Sohn) zugeordnet
- In Plesk habe ich also einen Kunden (Sohn)

Alle Zertifikate für beide Domains mit LetsEncrypt erzeugt und es funktioniert alles (Webseite, Mail etc.) und alle Sicherheitstests externer Testseiten bescheinigen mir eine einwandfreie und sichere Konfiguration. Auf beiden Domains ist das Zertifikat jeweils mit "Wildcard-Domain schützen (inklusive www und Webmail) " angefordert worden.

Jetzt kommt so langsam aber sicher mein Problem:

Ich möchte meinem Sohn ermöglichen, seinen eigenen Webauftritt selbst zu administrieren.
Hierfür soll er sich mit seiner Domain xyz.de:8443 anmelden.
Funktioniert theoretisch auch, allerdings immer mit dem Hinweis "Webseite unsicher. Zertifikat wurde auf abc.de ausgestellt....."

...was auf der einen Seite nachvollziehbar ist, weil unter "Zertifikat zum Schutz von Plesk" das Zertifikat von abc.de eingetragen ist. Auf der anderen Seite möchte ich sowohl auf meiner Domain ohne Fehlermeldung administrieren können, als auch meinem Sohn in seinem eigenen Bereich die Administraton ermöglich und zwar ohne, dass er über meine Adminseite des Hauptnutzers gehen muss.

Ich finde keine Möglichkeit, dass jeder von uns beiden auf seinen eigenen Adminbereich ohne das Zertifikatsproblem zugreifen kann.
Wie gesagt: Alles andere funktioniert einwandfrei. Der Zertifikatsfehler tritt nur dann auf, wenn ich auf den Plesk-Admin der Domain xyz.de:8443 zugreife.

Hat jemand eine Idee von euch ? Es muss doch theoretisch zumindest eine Lösung geben, da Plesk weitere Abonnements/Kunden grundsätzlich unterstützt.

Ich hoffe, ich habe keine wichtigen Angaben vergessen.
Ich sage schon mal einen ganz herzlichen Dank im Voraus !!!!

Viele weihnachtliche Grüße
Roland
-
 

danton

Debian User
Ob du abc.de:8443 oder xyz.de:8443 aufrufst, ist egal, es ist die gleiche Pleskoberfläche. Die Unterscheidung, was eingestellt werden soll, erfolgt an dieser Stelle nicht über die Domain, sondern rein über den Login. Wenn dein Sohn also die abc.de:8443 aufruft und dann seinen Login verwendet, hat er seine Einstellungen für seine Domain xyz.de - und hat keinen Zertifikatsfehler.
Bei einem Hoster ist das Kundenmenü i.d.R. ja auch (nur) über die Domain des Hosters erreichbar - in deinem Fall wäre das deine Domain abc.de
 

gBonfire

New Member
Hallo. Herzlichen Dank!!!!
Manchmal kann die Erklärung so einfach sein:)
Darauf wäre ich nie gekommen.
...was ich alles schon probiert habe....

So funktioniert es tatsächlich.

Viele Grüße und frohe Weihnachten
Roland
 
Top