[GELÖST] Korrekter Pfad zum opendkim.sock?

wakko

Blog Benutzer
Update und Lösung: Der Hinweis aus diesem Beitrag war doch der richtige: Offenbar darf bei ge-chrootetem postfix der Pfad zum Socket keinen führenden "/" haben. Nachdem ich den Socket in der postfix/main.cf auf unix:var/run/opendkim/opendkim.sock geändert habe, empfange ich Mails ohne Warning im syslog.

Ich lasse den Rest mal zu Dokumentationszwecken hier stehen...
------------------------------------------------------------
Ich habe gerade DKIM für den Postfix auf Debian 9 aktiviert. Scheint auch größtenteils zu funktionieren, aber ich kriege partout diese Warnung aus dem syslog nicht weg:
Code:
warning: connect to Milter service unix:/var/spool/postfix/var/run/opendkim/opendkim.sock: No such file or directory
Die opendkim.sock wohnt wie hier beschrieben in /var/spool/postfix/var/run/opendkim.
Ich habe drei config Files gefunden, in denen der Pfad verwendet wird: /etc/opendkim.conf, /etc/default/opendkim (laut Kommentar in der Datei überschreibt das die Pfadangabe in /etc/opendkim.conf) und /etc/postfix/main.cf.
Wenn ich das richtig verstanden habe, läuft der postfix ge-chrooted, also wohnt dessen root-dir in /var/spool/postfix, deswegen ja der zusätzliche Pfad (/var/run/opendkim) oben aus der Fehlermeldung, und deswegen auch nur der kurze Pfad (/var/run/opendkim) in der config.
Ich habe jetzt sämtliche Permutationen von /var/run/opendkim und /var/spool/postfix/var/run/opendkim in allen configs durch, aber jede neue Testmail haut wieder diese oben genannte Fehlermeldung raus.
Hat da jemand einen Rat?

Edit: Auch mit HIlfe dieser Lösung bin ich noch nicht weitergekommen. Meine Sockets haben alle das "unix:" Präfix.

Relevante Teile der Config files:
/etc/postfix/main.cf:
# milter stuff for DKIM
milter_default_action = accept
milter_protocol = 6
# from inside the chroot, the socket will be in /var/run/opendkim
#smtpd_milters = unix:/var/run/opendkim/opendkim.sock
smtpd_milters = unix:/var/spool/postfix/var/run/opendkim/opendkim.sock
#non_smtpd_milters = unix:/var/run/opendkim/opendkim.sock
non_smtpd_milters = unix:/var/spool/postfix/var/run/opendkim/opendkim.sock
/etc/opendkim.conf:
#Socket local:/var/run/opendkim/opendkim.sock
Socket unix:/var/spool/postfix/var/run/opendkim/opendkim.sock
/etc/default/opendkim:
# Command-line options specified here will override the contents of
# /etc/opendkim.conf. See opendkim(8) for a complete list of options.
#DAEMON_OPTS=""
# Change to /var/spool/postfix/var/run/opendkim to use a Unix socket with
# postfix in a chroot:
#RUNDIR=/var/spool/postfix/var/run/opendkim
RUNDIR=/var/run/opendkim
#
# Uncomment to specify an alternate socket
# Note that setting this will override any Socket value in opendkim.conf
# default:
#SOCKET=local:$RUNDIR/opendkim.sock
#SOCKET="local:/var/run/opendkim/opendkim.sock"
SOCKET="local:/var/spool/postfix/var/run/opendkim/opendkim.sock"
# listen on all interfaces on port 54321:
#SOCKET=inet:54321
# listen on loopback on port 12345:
#SOCKET=inet:12345@localhost
# listen on 192.0.2.1 on port 12345:
#SOCKET=inet:12345@192.0.2.1
USER=opendkim
GROUP=opendkim
PIDFILE=$RUNDIR/$NAME.pid
EXTRAAFTER=
Wo der Socket wohnt:
ls -l /var/spool/postfix/var/run/opendkim/
total 0
srwxrwx--- 1 opendkim opendkim 0 Oct 3 15:36 opendkim.sock
 
Last edited:
Top