FTP-Nutzer kann Ordner erstellen aber keine Dateien hochladen?

BuntesZebra

New Member
Hallo allerseits,

frohes Neues erst einmal! :)

Ich habe einen kleinen vServer gemietet und verwalte diesen mittels Webmin. Nun habe ich den proFTPd-Server installiert und er läuft auch. Ich habe einen FTP-Nutzer erstellt, mir FileZilla auf den Rechner geladen und mich mit dem FTP-Server verbunden.
Dann habe ich versucht, eine Datei hochzuladen und da bricht dann die Verbindung ab:

Status: Verbinde mit XXX.XXX.XXX:21...
Status: Verbindung hergestellt, warte auf Willkommensnachricht...
Status: Unsicherer Server; er unterstützt kein FTP über TLS.
Befehl: USER XYZ
Antwort: 331 Password required for XYZ
Befehl: PASS ***********
Antwort: 530 Login incorrect.
Fehler: Kritischer Fehler: Herstellen der Verbindung zum Server fehlgeschlagen

Der Ordner, in den ich die Datei laden wollte, hat als Owner den FTP-Nutzer, die Rechte habe ich schon in alle möglichen Höhen geschraubt, bis 776, aber ständig bricht es ab. Als Shell ist bin/sh für den Nutzer eingestellt.

Nach mehreren Versuchen probierte ich mal, einen Ordner via FTP in dem Verzeichnis zu erstellen, das ging dann plötzlich problemlos. Aber auch in den neuen Ordner konnte ich die Datei nicht laden.

Bei der Datei handelt es sich einfach nur um eine kleine html-Datei zum Testen. Also nichts, was Probleme bereiten sollte, denke ich.
Bin halt leider ein totaler Noob, was Serververwaltung angeht :/

Hat jemand vielleicht eine Idee, was ich falsch mache?
 

Cyperghost

Member
An aktive bitte das Error logging in der Konfiguration des FTP-Servers.
Oder guck/such den richtigen Pfad(falls ggfs. geändert) der log Datei. :)
 

BuntesZebra

New Member
Hallo, Cyberghost,

ich hab die Log-Einstellungen geändert und wollte testen, ob ich es richtig gemacht habe. Sitze aber nun an einem anderen Rechner und plötzlich geht es. Scheint also ein Problem mit meinem Desktop-PC zu sein.
Vielen lieben Dank aber für die Hilfe!
 

marce

Active Member
Hm, ich mag mich täuschen, aber
Code:
Antwort: 331 Password required for XYZ
Befehl: PASS ***********
Antwort: 530 Login incorrect.
ist für mich mehr als eindeutig.

... und daß es dann an einem anderen PC funktioniert - vermutlich im FTP-Client (sicherlich einer mit GUI?) das falsche Passwort eingegeben, gespeichert und dann...
 

BuntesZebra

New Member
Hallo, marce,

ja, sollte man meinen, dass das eindeutig ist, aber einmal konnte ich in derselben Session ja auch den Ordner erstellen, was ja mit dem falschen Login nicht möglich ist.... Nach dem Erstellen des Ordners kam beim direkt anschließenden Upload-Versuch aber auch diese Nachricht. Zumal ich zwischendurch bei meinen zig Versuchen auch das Passwort mal auf etwas elend einfaches stellte, nur um ganz sicher zu gehen, obwohl es daran ja nicht liegen konnte, so rein von der Logik her. Aber irgendwann ist man so verzweifelt, dass man einfach alles probiert :rolleyes:
 

ThomasChr

New Member
Evtl. probiert das FTP Programm für den Dateiupload eine neue Session aufzubauen aber der FTP Server erlaubt nur eine Session?
 

BuntesZebra

New Member
Also ich habe mir nun ein anderes FTP-Programm mal runtergeladen und damit klappt es einwandfrei. Ich vermute auch, dass FileZilla da irgendwie versucht hat, eine zweite Session aufzubauen, und das dann zum Problem führte.

Vielen Dank euch allen!
 

Muetze

New Member
Liegt eindeutig an Filezilla. Ich habe den jetzt auch deinstalliert und nutze WinSCP.
Mein FTP läuft ohne Probleme. Nur seid den letzten Updates gab es nur noch Probleme mit FileZilla. Keine Ahnung was die da verhunzt haben.
 

Top