Froxlor über https://meinedomain.tdl/froxlor aufrufen

Gadderbaumer

New Member
Hallo Community.

Ich habe mir für meinen Blog ein SSL-Zertifikat eingerichtet. Soweit läuft alles ganz gut. Nun möchte ich Froxlor gerne zusätzlich oder ausschließlich über https://meinedomain.tld/froxlor aufrufen und nicht mehr unter http://ip/froxlor.

Wie muss ich den Apache2 (VHosts) richtig konfigurieren?
Ich hoffe mir mag da jemand helfen. ;)

Gruß,
Gadderbaumer
 

d4f

Kaffee? Wo?
Froxlor unter deinem Account laufen zu lassen ist sicherheitstechnisch keine sehr gute Idee. Du kannst ihn zwar mit Alias auf einem außerhalb deines Document-Root liegenden Ordner (/var/www) umleiten, aber dann muss er noch immer unter den Rechten deines Accounts laufen (es sei du setzt auf mod_php + mpm_prefork wo es dann eh egal ist)

Du solltest eine Subdomain wie admin.pf-control.de für Froxlor konfigurieren, und dann unter Einstellungen->SystemEinstellungen->"Froxlor direkt über den Hostnamen erreichbar machen" diese für Froxlor konfigurieren. (Alternativ auch manuell direkt in Apache's sites-enabled Ordner)

Falls du keine Wildcard-Subdomain hast und (mehr oder weniger) allein Froxlor verwendest kannst du ihm auch ein selbst-signiertes Zertifikat geben wo du dir den Fingerprint aufschreibst und/oder das Zertifikat in den Browser importierst.
 

Gadderbaumer

New Member
Ich habe nun eine Subdomain froxlor.meinedomain.tld angelegt.
Jetzt einfach den Haken bei ""Froxlor direkt über den Hostnamen erreichbar machen" zu setzen wird ja nicht ausreichen sein, oder?

Ich bin quasi noch ein Noob, deshalb wäre eine detailliertere Anleitung toll. Tut mir Leid wenn ich damit viel Mühe mache.

Gruß,
Gadderbaumer
 

d4f

Kaffee? Wo?
Wenn ich es richtig in Erinnerung habe legt das einen vHost an der korrekt konfiguriert ist, es sollte also ausreichen. Statt einer Subdomain an zu legen musst du aber den "Hostname" in Froxlor (Eintrag ueber dem Haken) auf diesen Wert umkonfigurieren.

Ich hab den vHost allerdings manuell angelegt statt das Froxlor an zu vertrauen.
 

d4f

Kaffee? Wo?
Gern, aber du musst noch rauswerfen was du nicht benutzt oder anders konfiguriert hast. Ich hab nur die Kommentare entfernt.
0_default
Code:
<VirtualHost 1.2.3.4:80>

  ServerAdmin EMAIL@DOMAIN.TLD
  DocumentRoot "/var/www/"

  ServerName DOMAIN.TLD
  ServerAlias www.DOMAIN.TLD

  CGroup www-data

  AssignUserId froxlorlocal froxlorlocal
  MaxClientsVHost 75
  php_admin_flag engine on
  php_admin_value session.save_path "/tmpfs/"
  php_admin_flag log_errors on
  php_admin_flag safe_mode Off
  php_admin_value sendmail_path "/usr/sbin/sendmail -t -f EMAIL@DOMAIN.TLD"

</VirtualHost>
 
Top