• This forum has a zero tolerance policy regarding spam. If you register here to publish advertising, your user account will be deleted without further questions.

frage zu änderungen an php.ini und co

AWZ

Registered User
ich habe einen s4y vServer BUSINESS mit debian und wollte gern etwas ändern, auf den server an sich greife ich mit WinSCP3 zu iss auch soweit nicht weiter das ding, nur finde ich dort nicht was ich suche

hab zum testen bei mir auf dem home pc xamp zu laufen und mich da ein wenig orientiert,aber das iss sicher etwas anders unter linux

soll.JPG


ums kurz zu machen ich hätte gern die roten auch grün :eek:

Session save path /var/lib/php4, Nicht schreibbar

da sollte normal auch stehen schreibbar

danke für eure hilfe

mfg

AWZ
 
also der Safemode kannst in der php.ini in /etc/ deaktievieren.
( einfach in der datei die variable " safe_mode = on " suche und in
" safe_mode = Off " ändern )

Und in der selben dabei kannst du auch Gobal registers ausschalten in dem du das hier suchst " register_globals = on " und in das hier änderst " register_globals = off "

ich hoffe das ich dir helfen konnte ;-)

Achso und danach den Apache neustarten !


 
Last edited by a moderator:
mein problem ist nicht die variabeln zu ändern (trotzdem danke für den tip) ich würde gern erstma finden wo sie sind damit ich daran etwas ändern kann
 
guck mal in /etc/php4/apache2 /

oder /etc/php4/apache/

wenn nicht dann such doch mal über den MC Commander *g*
 
hab das wohl bei deinem ersten posting nich gesehen :rolleyes:

ja habs gefunden aber mein editor sacht das er das "safe_mode = on" nicht findet

sprich es steht alles auf off und wird aber als on angezeigt
kann sowas passieren ?
 
ja steht in der datei die variable mit off ? weil wenn se nett da setht ist er automatisch aktiviert...

es könnt aber auch sein das du vitual Hosts verwendest un hier kanst du nur pro kunde den safemode aktivieren (evtl. confixx ? )
 
jut dan wird das wohl die andere variante sein


safe_mode = Off im root steht das

und

register_globals = off

jetzt bin ich doch etwas sprachlos
weil über die php.ini bin ich schon des öffteren gestolpert und hiel sie nicht für relevant da sie ja so konfiguriert war wie ich es wollte, allerdings hatte ich ja eine ander mitteilung

so wo kann ich den soetwas über confix händeln

und vor allem über wen

admin resseler naja user schliesse ich ma aus :)
 
du hast im adminmenü die funktion httpd-Spezial

unter dieser funktion kanst du für domaisn oder ganze kunden einstellungen machen .... z.b machst du für web1 die einstellung " safe_mode = Off" und dann ab denm nächsten neustart von apche hat web1 den safemode aus ... *g* also eigentlich ganz einfach
 
wie ab dem nächsten neustart ?
muss ich das teil dan rebooten lassen.

ok werd mal mein glück versuchen
 
nein neustart des apaches also das läuft ca. alle 6 min .... und beim nächten mal schrieb gelcih dazu das du confixx hast ... weil da ist leider vieles anderst *g* viel glück noch
 
So mit meiner eigenwilligen Einstellung hab ich den Server zum stillstand gebracht.

Naja Ergebniss war das ich mich Tierisch mit dem super schnellen support rumärgern musste, der mir zwar die einstellungen (zumindest zu 50%) gesetzt hat, aber für halbe Arbeit gleich 39€ aufruft :( .

Na was solls der Server läuft wieder, ich hab micht ein wenig abgeregt durch ein entspanntes bad und alles scheint in bester Ordnung zu sein.

Schauen wir mal was noch alles auf mich zukommt.

mfg

AWZ
 
Ist mir auch schon passiert, dass ich über httpd-Spezial den Apache abgeschossen hab.

Allerdings kann man das Problem auch ohne den Support lösen: :)

1. Per Putty als root einloggen
2. In der error.log nachsehen, welche Zeile in der confixx_vhost.conf den Fehler verursacht (die Datei ist unter /var/log/apache oder /var/log/apache2)
3. Die confixx_host.conf editieren und die entsprechende Zeile löschen.
4. apache neu starten: /etc/init.d/apache2 restart oder /etc/init.d/apache restart
5. Prüfen ob der Apache wieder läuft, wenn nicht, zurück zu 2. (kann sein das mehrere Einstellungen Ärger machen.
6. Confixx über den Webserver aufrufen und die entsprechenden Einträge auch hier wieder rückgängig machen (Confixx trägt die Einstellungen sonst wieder neu ein.

Kleiner Tipp zu Confixx:
Um die Einstellungen zu sehen, muss man bei httpd Spezial "eine Domain ändern" auswählen.

Hoffe das hilft.

Jan
 
cool danke

Naja nachdem ich eher etwas unwissend die Einstellungen vornahm, sind sie jetzt durch den Support kostenpflichtig vorgenommen worden und der Server läuft wieder.
 
Back
Top